aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-11 10:08:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-11 10:08:38 +0000
commit8244fe99bcdbad7a2d0b22d66183394f5ffacd03 (patch)
treec9a458d29164af55be5bf3330f3f659428ac04ac /databases
parent365eb51f267a3ad97ff0d4953b9991547b5b8c45 (diff)
downloadports-8244fe99bcdbad7a2d0b22d66183394f5ffacd03.tar.gz
ports-8244fe99bcdbad7a2d0b22d66183394f5ffacd03.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=431169
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql80-server/Makefile9
-rw-r--r--databases/mysql80-server/files/rapid_plugin-patch-_x_mysqlxtest__src_mysqlxtest.cc12
2 files changed, 0 insertions, 21 deletions
diff --git a/databases/mysql80-server/Makefile b/databases/mysql80-server/Makefile
index 43006ffd2c86..54fc3375557e 100644
--- a/databases/mysql80-server/Makefile
+++ b/databases/mysql80-server/Makefile
@@ -131,15 +131,6 @@ PERFSCHM_SUB_LIST+= PERFSCHEMRC=""
PERFSCHM_SUB_LIST_OFF+= PERFSCHEMRC="--skip-performance-schema"
.endif
-.include <bsd.port.options.mk>
-
-### Just for the sake of FreeBSD 9.X ###
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-. if !defined(CLIENT_ONLY)
-EXTRA_PATCHES+= ${PATCHDIR}/rapid_plugin-patch-_x_mysqlxtest__src_mysqlxtest.cc
-. endif
-.endif
-
.include <bsd.port.pre.mk>
.if ${SSL_DEFAULT} == base
diff --git a/databases/mysql80-server/files/rapid_plugin-patch-_x_mysqlxtest__src_mysqlxtest.cc b/databases/mysql80-server/files/rapid_plugin-patch-_x_mysqlxtest__src_mysqlxtest.cc
deleted file mode 100644
index 078f3106848b..000000000000
--- a/databases/mysql80-server/files/rapid_plugin-patch-_x_mysqlxtest__src_mysqlxtest.cc
+++ /dev/null
@@ -1,12 +0,0 @@
---- rapid/plugin/x/mysqlxtest_src/mysqlxtest.cc.orig 2016-03-28 18:06:12 UTC
-+++ rapid/plugin/x/mysqlxtest_src/mysqlxtest.cc
-@@ -1661,7 +1661,8 @@ private:
- if (2 == argl.size())
- tolerance = atoi(argl[1].c_str());
-
-- if (abs(expected_msec - msec) > tolerance)
-+#define my_abs_64(x) ((x) < 0 ? (-x) : (x))
-+ if (my_abs_64((expected_msec - msec)) > tolerance)
- {
- std::cerr << "Timeout should occur after " << expected_msec << "ms, but it was " << msec <<"ms. \n";
- return Stop_with_failure;