aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-03-17 07:06:39 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-03-17 07:06:39 +0000
commit8ae88a3aa74f378c6cd789c02a4c57612a4c89bb (patch)
tree57a23bf64e606d669245858a5b532eafe5743544 /databases
parentde8cbc09e11b4950e89f0fe729080cfbbe86a35d (diff)
downloadports-8ae88a3aa74f378c6cd789c02a4c57612a4c89bb.tar.gz
ports-8ae88a3aa74f378c6cd789c02a4c57612a4c89bb.zip
Update to 5.0.19 release:
- add mysql_upgrade script to update the databases from an earlier (even minor) release
Notes
Notes: svn path=/head/; revision=157479
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql50-client/Makefile2
-rw-r--r--databases/mysql50-scripts/Makefile2
-rw-r--r--databases/mysql50-server/Makefile7
-rw-r--r--databases/mysql50-server/distinfo6
-rw-r--r--databases/mysql50-server/files/patch-scripts::Makefile.in17
-rw-r--r--databases/mysql50-server/pkg-message7
-rw-r--r--databases/mysql50-server/pkg-plist2
7 files changed, 27 insertions, 16 deletions
diff --git a/databases/mysql50-client/Makefile b/databases/mysql50-client/Makefile
index 704759cd7716..302a1133672f 100644
--- a/databases/mysql50-client/Makefile
+++ b/databases/mysql50-client/Makefile
@@ -6,7 +6,6 @@
#
PORTNAME= mysql
-PORTREVISION= 1
PKGNAMESUFFIX= -client
COMMENT= Multithreaded SQL database (client)
@@ -14,6 +13,7 @@ COMMENT= Multithreaded SQL database (client)
MASTERDIR= ${.CURDIR}/../mysql50-server
PKGINSTALL= mustnotexist
+PKGMESSAGE= mustnotexist
PLIST= ${PKGDIR}/pkg-plist.client
CLIENT_ONLY= yes
diff --git a/databases/mysql50-scripts/Makefile b/databases/mysql50-scripts/Makefile
index 8cb8c1a5df2a..1e96f2b0dd43 100644
--- a/databases/mysql50-scripts/Makefile
+++ b/databases/mysql50-scripts/Makefile
@@ -6,7 +6,6 @@
#
PORTNAME= mysql
-PORTREVISION= 1
PKGNAMESUFFIX= -scripts
COMMENT= Multithreaded SQL database (scripts)
@@ -14,6 +13,7 @@ COMMENT= Multithreaded SQL database (scripts)
MASTERDIR= ${.CURDIR}/../mysql50-server
PKGINSTALL= mustnotexist
+PKGMESSAGE= mustnotexist
PLIST= ${PKGDIR}/pkg-plist.scripts
SCRIPTS_ONLY= yes
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index 62656474a9d9..31464d9ff271 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME?= mysql
-PORTVERSION= 5.0.18
-PORTREVISION?= 2
+PORTVERSION= 5.0.19
+PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
MASTER_SITE_SUBDIR= MySQL-5.0
@@ -152,7 +152,7 @@ pre-fetch:
post-patch:
@${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @docs_dirs@ @zlib_dir@ @sql_server_dirs@ scripts @man_dirs@ support-files|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|all: config.h|all: config.h all-local|g" ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@ mysql_create_system_tables|g" ${WRKSRC}/scripts/Makefile.in
+ @${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@ mysql_upgrade mysql_create_system_tables|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = fill_help_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man1_MANS =|man1_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
@${REINPLACE_CMD} -e "s|install-data-am: install-pkgincludeHEADERS|install-data-am:|g" ${WRKSRC}/extra/Makefile.in
@@ -165,6 +165,7 @@ post-patch:
post-install:
.if !defined(PACKAGE_BUILDING)
@${SETENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
.endif
.else
diff --git a/databases/mysql50-server/distinfo b/databases/mysql50-server/distinfo
index a79459921780..757c401f387e 100644
--- a/databases/mysql50-server/distinfo
+++ b/databases/mysql50-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (mysql-5.0.18.tar.gz) = f18153b0239aaa03fc5a751f2d82cb71
-SHA256 (mysql-5.0.18.tar.gz) = bd3d4b56de636eb14330be20e58f6fc58b015ff9d43926661e2e688ca7b6188a
-SIZE (mysql-5.0.18.tar.gz) = 19169082
+MD5 (mysql-5.0.19.tar.gz) = d8a922fe657cca3b03d390e5f13d60a8
+SHA256 (mysql-5.0.19.tar.gz) = 4e8faa4268b48c77a94792a637e785e87840513a316fe1b7eb8d0a5be77469a2
+SIZE (mysql-5.0.19.tar.gz) = 19454023
diff --git a/databases/mysql50-server/files/patch-scripts::Makefile.in b/databases/mysql50-server/files/patch-scripts::Makefile.in
index 5e2d4e697ea6..81d5185703dc 100644
--- a/databases/mysql50-server/files/patch-scripts::Makefile.in
+++ b/databases/mysql50-server/files/patch-scripts::Makefile.in
@@ -1,8 +1,8 @@
---- scripts/Makefile.in.orig Sat Jun 11 03:32:05 2005
-+++ scripts/Makefile.in Thu Jun 16 23:09:08 2005
-@@ -333,24 +333,7 @@
- uname_prog = @uname_prog@
- yassl_dir = @yassl_dir@
+--- scripts/Makefile.in.orig Sat Mar 4 21:36:58 2006
++++ scripts/Makefile.in Thu Mar 16 08:22:23 2006
+@@ -344,25 +344,7 @@
+ yassl_libs_with_path = @yassl_libs_with_path@
+ yassl_taocrypt_extra_cxxflags = @yassl_taocrypt_extra_cxxflags@
zlib_dir = @zlib_dir@
-bin_SCRIPTS = @server_scripts@ \
- msql2mysql \
@@ -20,13 +20,14 @@
- mysqldumpslow \
- mysql_explain_log \
- mysql_tableinfo \
+- mysql_upgrade \
- mysqld_multi \
- mysql_create_system_tables
+bin_SCRIPTS =
- EXTRA_SCRIPTS = make_binary_distribution.sh \
- make_sharedlib_distribution.sh \
-@@ -380,7 +363,7 @@
+ noinst_SCRIPTS = make_binary_distribution \
+ make_sharedlib_distribution \
+@@ -396,7 +378,7 @@
mysqlaccess.conf \
mysqlbug
diff --git a/databases/mysql50-server/pkg-message b/databases/mysql50-server/pkg-message
new file mode 100644
index 000000000000..7e30302334e6
--- /dev/null
+++ b/databases/mysql50-server/pkg-message
@@ -0,0 +1,7 @@
+************************************************************************
+
+Remember to run mysql_upgrade (with the optional --datadir=<dbdir> flag)
+the first time you start the MySQL server after an upgrade from an
+earlier version.
+
+************************************************************************
diff --git a/databases/mysql50-server/pkg-plist b/databases/mysql50-server/pkg-plist
index f8dc70e0c995..79df803b2e54 100644
--- a/databases/mysql50-server/pkg-plist
+++ b/databases/mysql50-server/pkg-plist
@@ -9,6 +9,7 @@ bin/myisampack
bin/mysql_create_system_tables
bin/mysql_install_db
bin/mysql_tzinfo_to_sql
+bin/mysql_upgrade
bin/mysql_waitpid
bin/mysqld_safe
%%NDB%%bin/ndb_config
@@ -63,6 +64,7 @@ lib/mysql/libmyisammrg.a
lib/mysql/libmystrings.a
lib/mysql/libmysys.a
%%NDB%%lib/mysql/libndbclient.a
+%%NDB%%lib/mysql/libndbclient.la
%%NDB%%lib/mysql/libndbclient.so
%%NDB%%lib/mysql/libndbclient.so.0
lib/mysql/libvio.a