aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-12-01 16:29:35 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-12-01 16:29:35 +0000
commita7eafba0327d4406797625d7383d512b369bdb29 (patch)
tree1926b1a4ba58113aedab6ec5f04ceffa358c43e3 /databases
parent2547854f7f4f26230c68426a4666db4f6a3c0deb (diff)
downloadports-a7eafba0327d4406797625d7383d512b369bdb29.tar.gz
ports-a7eafba0327d4406797625d7383d512b369bdb29.zip
fix databases/arangodb32 on FreeBSD 10.x
o Fix build on FreeBSD 10.x by requiring recent LLVM o Only build on amd64 - many hardcoded directories PR: 223815 Submitted by: galu@packetdam.com (maintainer, same as dev@dudu.ro) Differential Revision: https://reviews.freebsd.org/D13282
Notes
Notes: svn path=/head/; revision=455300
Diffstat (limited to 'databases')
-rw-r--r--databases/arangodb32/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/databases/arangodb32/Makefile b/databases/arangodb32/Makefile
index e6f574eec16d..94bc4b71fe52 100644
--- a/databases/arangodb32/Makefile
+++ b/databases/arangodb32/Makefile
@@ -7,12 +7,14 @@ DISTVERSION= 3.2.8
CATEGORIES= databases net
PKGNAMESUFFIX= 32
-MAINTAINER= galu@packetdam.com
+MAINTAINER= galu@packetdam.com
COMMENT= ArangoDB is a distributed NoSQL database with multiple data models
LICENSE= APACHE20
-USES= gmake ssl cmake:outsource,noninja python:2.7
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= "Only builds on amd64"
+USES= gmake ssl cmake:outsource,noninja python:2.7 compiler
USE_GITHUB= yes
CMAKE_ARGS= -DUSE_JEMALLOC:BOOL=off \
@@ -23,6 +25,15 @@ USERS= arangodb
GROUPS= arangodb
USE_RC_SUBR= arangod
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 40
+BUILD_DEPENDS+= ${LOCALBASE}/bin/clang40:devel/llvm40
+CPP= ${LOCALBASE}/bin/clang-cpp40
+CC= ${LOCALBASE}/bin/clang40
+CXX= ${LOCALBASE}/bin/clang++40
+.endif
+
post-install:
.for section in 1 8
${MV} ${STAGEDIR}${PREFIX}/share/man/man${section}/* ${STAGEDIR}${PREFIX}/man/man${section}/
@@ -38,4 +49,5 @@ post-install:
${RMDIR} ${STAGEDIR}${PREFIX}/var/log/arangodb
${RMDIR} ${STAGEDIR}${PREFIX}/var/log
${RMDIR} ${STAGEDIR}${PREFIX}/var
-.include <bsd.port.mk>
+
+.include <bsd.port.post.mk>