aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2006-11-21 17:12:30 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2006-11-21 17:12:30 +0000
commitb08c8bbe60ab1613daf1add0fb2e677c0de701ca (patch)
tree0caefb36837ab4edddf29b3578b20ff2812bbda6 /databases
parentd5fa35d160dbb206ab56b5eb9b37097be1857b38 (diff)
downloadports-b08c8bbe60ab1613daf1add0fb2e677c0de701ca.tar.gz
ports-b08c8bbe60ab1613daf1add0fb2e677c0de701ca.zip
Fix "fbintl not found" issue for embedded mode.
Notes
Notes: svn path=/head/; revision=177735
Diffstat (limited to 'databases')
-rw-r--r--databases/firebird2-client/Makefile2
-rw-r--r--databases/firebird2-server/files/patch-src+jrd+IntlManager.cpp11
-rw-r--r--databases/firebird20-client/Makefile2
-rw-r--r--databases/firebird20-server/files/patch-src+jrd+IntlManager.cpp11
4 files changed, 24 insertions, 2 deletions
diff --git a/databases/firebird2-client/Makefile b/databases/firebird2-client/Makefile
index 84efb7b9bf4e..e4b999703b99 100644
--- a/databases/firebird2-client/Makefile
+++ b/databases/firebird2-client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= firebird
-PORTREVISION= 3
+PORTREVISION= 4
PKGNAMESUFFIX= -client
COMMENT= Firebird-2 database client
diff --git a/databases/firebird2-server/files/patch-src+jrd+IntlManager.cpp b/databases/firebird2-server/files/patch-src+jrd+IntlManager.cpp
new file mode 100644
index 000000000000..c918181dce4f
--- /dev/null
+++ b/databases/firebird2-server/files/patch-src+jrd+IntlManager.cpp
@@ -0,0 +1,11 @@
+--- src/jrd/IntlManager.cpp.orig Tue Nov 21 16:24:19 2006
++++ src/jrd/IntlManager.cpp Tue Nov 21 16:30:40 2006
+@@ -78,7 +78,7 @@
+ #endif
+
+ Firebird::PathName intlPath;
+- PathUtils::concatPath(intlPath, Config::getRootDirectory(), "intl");
++ PathUtils::concatPath(intlPath, FB_LIBEXEC_PREFIX, "intl");
+
+ ScanDir dir(intlPath.c_str(), "*.conf");
+
diff --git a/databases/firebird20-client/Makefile b/databases/firebird20-client/Makefile
index 84efb7b9bf4e..e4b999703b99 100644
--- a/databases/firebird20-client/Makefile
+++ b/databases/firebird20-client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= firebird
-PORTREVISION= 3
+PORTREVISION= 4
PKGNAMESUFFIX= -client
COMMENT= Firebird-2 database client
diff --git a/databases/firebird20-server/files/patch-src+jrd+IntlManager.cpp b/databases/firebird20-server/files/patch-src+jrd+IntlManager.cpp
new file mode 100644
index 000000000000..c918181dce4f
--- /dev/null
+++ b/databases/firebird20-server/files/patch-src+jrd+IntlManager.cpp
@@ -0,0 +1,11 @@
+--- src/jrd/IntlManager.cpp.orig Tue Nov 21 16:24:19 2006
++++ src/jrd/IntlManager.cpp Tue Nov 21 16:30:40 2006
+@@ -78,7 +78,7 @@
+ #endif
+
+ Firebird::PathName intlPath;
+- PathUtils::concatPath(intlPath, Config::getRootDirectory(), "intl");
++ PathUtils::concatPath(intlPath, FB_LIBEXEC_PREFIX, "intl");
+
+ ScanDir dir(intlPath.c_str(), "*.conf");
+