aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-14 18:03:41 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-14 18:03:41 +0000
commitba6cd8292fd6c12a017c1476fb629560a8e1c287 (patch)
treef290a9a66a15194499020e2ecf258803ff01997a /databases
parent0c667cfcc097fb93eb11102e82e84188b6ddb25c (diff)
downloadports-ba6cd8292fd6c12a017c1476fb629560a8e1c287.tar.gz
ports-ba6cd8292fd6c12a017c1476fb629560a8e1c287.zip
- Integrate completely with bsd.wx.mk.
- Use ARCH instead of MACHINE_ARCH (will possibly allow cross-compilation). - Rename local WX_VERSION since it is a variable defined in bsd.wx.mk. - Remove BROKEN for 4.x since bsd.wx.mk takes care of it when WX_UNICODE is defined. PR: ports/105492 Submitted by: alepulver Approved by: Denis Barov <dindin@dindin.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=177269
Diffstat (limited to 'databases')
-rw-r--r--databases/flamerobin/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/databases/flamerobin/Makefile b/databases/flamerobin/Makefile
index 2061eb3d094d..075451f9a466 100644
--- a/databases/flamerobin/Makefile
+++ b/databases/flamerobin/Makefile
@@ -19,28 +19,22 @@ LIB_DEPENDS= fbclient.1:${PORTSDIR}/databases/firebird-client
USE_WX= 2.6
WX_COMPS= wx contrib
+WX_CONF_ARGS= absolute
+WX_PREMK= yes
WX_UNICODE= yes
-GNU_CONFIGURE= yes
USE_X_PREFIX= yes
-
-WX_CONFIG= ${X11BASE}/bin/wxgtk2u-2.6-config
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
SUB_FILES= pkg-message
MAN1= flamerobin.1
-.if exists(${WX_CONFIG})
-WX_VERSION!= ${WX_CONFIG} --release
-PLIST_SUB+= WX_VERSION=${WX_VERSION}
-.endif
-
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
-
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on FreeBSD 4.x
+.if exists(${WX_CONFIG})
+WX_VER_STR!= ${WX_CONFIG} --release
+PLIST_SUB+= WX_VERSION=${WX_VER_STR}
.endif
post-install: