aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 12:03:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 12:03:51 +0000
commitbc221a68c15c8e0767c7e506835360a84c2428b2 (patch)
tree431ec3996e95945e366f01ab27f2b341ed69df41 /databases
parent810f699bfefb6805c8c40fd746af650e11986757 (diff)
downloadports-bc221a68c15c8e0767c7e506835360a84c2428b2.tar.gz
ports-bc221a68c15c8e0767c7e506835360a84c2428b2.zip
- Use USES=gmake
Notes
Notes: svn path=/head/; revision=325110
Diffstat (limited to 'databases')
-rw-r--r--databases/kyotocabinet/Makefile2
-rw-r--r--databases/kyototycoon/Makefile2
-rw-r--r--databases/leveldb/Makefile2
-rw-r--r--databases/p5-Tie-LevelDB/Makefile2
-rw-r--r--databases/pgsphere/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/databases/kyotocabinet/Makefile b/databases/kyotocabinet/Makefile
index 3c1a83557b38..047782410085 100644
--- a/databases/kyotocabinet/Makefile
+++ b/databases/kyotocabinet/Makefile
@@ -17,8 +17,8 @@ OPTIONS_DEFINE= DOCS
GNU_CONFIGURE= yes
MAKE_ARGS= PCDIR="${PREFIX}/libdata/pkgconfig"
USE_GCC= 4.2+
-USE_GMAKE= yes
USE_LDCONFIG= yes
+USES= gmake
MAN1= kccachetest.1 \
kcdirmgr.1 \
diff --git a/databases/kyototycoon/Makefile b/databases/kyototycoon/Makefile
index e97a14aa7e75..94807e85b061 100644
--- a/databases/kyototycoon/Makefile
+++ b/databases/kyototycoon/Makefile
@@ -19,8 +19,8 @@ OPTIONS_DEFINE= DOCS
CONFIGURE_ARGS= --enable-profile --enable-uyield
GNU_CONFIGURE= yes
MAKE_ARGS= PCDIR="${PREFIX}/libdata/pkgconfig"
-USE_GMAKE= yes
USE_LDCONFIG= yes
+USES= gmake
MAN1= ktremotemgr.1 \
ktremotetest.1 \
diff --git a/databases/leveldb/Makefile b/databases/leveldb/Makefile
index f4b77ddcf7d7..fc522b7aee5d 100644
--- a/databases/leveldb/Makefile
+++ b/databases/leveldb/Makefile
@@ -13,8 +13,8 @@ OPTIONS_DEFINE= GPERFTOOLS SNAPPY
OPTIONS_DEFAULT=SNAPPY
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GMAKE= yes
USE_LDCONFIG= yes
+USES= gmake
PLIST_SUB= SHLIB_MAJOR=${SHLIB_MAJOR} \
SHLIB_MINOR=${SHLIB_MINOR}
diff --git a/databases/p5-Tie-LevelDB/Makefile b/databases/p5-Tie-LevelDB/Makefile
index 8d879509dc3f..ba3a1bdd0eaf 100644
--- a/databases/p5-Tie-LevelDB/Makefile
+++ b/databases/p5-Tie-LevelDB/Makefile
@@ -18,8 +18,8 @@ COMMENT= A Perl Interface to the Google LevelDB NoSQL database
LIB_DEPENDS= leveldb:${PORTSDIR}/databases/leveldb
MAKE_ARGS= CC=${CXX}
-USE_GMAKE= yes
PERL_CONFIGURE= yes
+USES= gmake
MAN3= Tie::LevelDB.3
diff --git a/databases/pgsphere/Makefile b/databases/pgsphere/Makefile
index cc6378e32d7d..4e3f10369ff0 100644
--- a/databases/pgsphere/Makefile
+++ b/databases/pgsphere/Makefile
@@ -18,7 +18,7 @@ COMMENT= Spherical data types, functions, and operators for PostgreSQL
DATADIR= ${PREFIX}/share/postgresql
DOCSDIR?= ${PREFIX}/share/doc/postgresql
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
USE_PGSQL= yes