aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-09-18 05:56:10 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-09-18 06:13:10 +0000
commitd2ad9a14a5faa48892a0dd408687cfdb31655350 (patch)
tree03a2da194df7dd89a1c8d8b3c2f0a46eb40f9a4c /databases
parent79893751643ae9e162011ace70e383cc0cd8e6c3 (diff)
downloadports-d2ad9a14a5faa48892a0dd408687cfdb31655350.tar.gz
ports-d2ad9a14a5faa48892a0dd408687cfdb31655350.zip
databases/py-tiledb: Update to 0.32.0
Diffstat (limited to 'databases')
-rw-r--r--databases/py-tiledb/Makefile5
-rw-r--r--databases/py-tiledb/distinfo6
-rw-r--r--databases/py-tiledb/files/patch-pyproject.toml11
3 files changed, 14 insertions, 8 deletions
diff --git a/databases/py-tiledb/Makefile b/databases/py-tiledb/Makefile
index 18b188cfa15e..a78855f2c8a9 100644
--- a/databases/py-tiledb/Makefile
+++ b/databases/py-tiledb/Makefile
@@ -1,5 +1,5 @@
PORTNAME= tiledb
-PORTVERSION= 0.31.1
+PORTVERSION= 0.32.0
CATEGORIES= databases python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,10 +13,11 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.25,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pybind11>=0:devel/py-pybind11@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-build-core>=0:devel/py-scikit-build-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=1.5.4:devel/py-setuptools-scm@${PY_FLAVOR} \
- tiledb>=2.25.0:databases/tiledb
+ tiledb>=2.26.0:databases/tiledb
LIB_DEPENDS= libtiledb.so:databases/tiledb
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.25,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR}
diff --git a/databases/py-tiledb/distinfo b/databases/py-tiledb/distinfo
index 14b521230b83..675f9f68d220 100644
--- a/databases/py-tiledb/distinfo
+++ b/databases/py-tiledb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1722711191
-SHA256 (tiledb-0.31.1.tar.gz) = 7b9ddd32c4c7437111764645d8a042d603102a813c8b89addaf9a15bd40dd939
-SIZE (tiledb-0.31.1.tar.gz) = 365917
+TIMESTAMP = 1726487330
+SHA256 (tiledb-0.32.0.tar.gz) = 15c30c4e1baf5104bd18b83ab884d7dd9ae03f4e2bf04193113313f0b9b92aac
+SIZE (tiledb-0.32.0.tar.gz) = 371733
diff --git a/databases/py-tiledb/files/patch-pyproject.toml b/databases/py-tiledb/files/patch-pyproject.toml
index fde710137b67..499ce61c25e6 100644
--- a/databases/py-tiledb/files/patch-pyproject.toml
+++ b/databases/py-tiledb/files/patch-pyproject.toml
@@ -1,11 +1,16 @@
--- pyproject.toml.orig 2022-11-09 12:37:21 UTC
+++ pyproject.toml
-@@ -6,7 +6,7 @@ requires = [
+@@ -2,11 +2,11 @@ requires = [
+ requires = [
+ "scikit-build-core",
+ "pybind11",
+- "Cython>=3",
++ "Cython",
"numpy==1.17.* ; python_version == '3.8' and platform_machine not in 'arm64|aarch64'",
"numpy==1.19.* ; python_version == '3.8' and platform_machine == 'aarch64'",
"numpy==1.21.* ; python_version == '3.8' and platform_machine == 'arm64'",
-- "numpy>=2.0.0rc2 ; python_version >= '3.9'"
-+ "numpy>=1.25; python_version >= '3.9'"
+- "numpy>=2.0.1 ; python_version >= '3.9'"
++ "numpy>=1.25 ; python_version >= '3.9'"
]
build-backend = "scikit_build_core.build"