aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-07-20 14:28:42 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-07-20 14:28:42 +0000
commitda566bc8534e93a6c9c15e3db46c315d3cd96a62 (patch)
treeb216bb7d79aab48e31aa8437e8950b3225bd8dad /databases
parent8e1a50a558fa2a6ba256e1d4d53b791bfc628394 (diff)
downloadports-da566bc8534e93a6c9c15e3db46c315d3cd96a62.tar.gz
ports-da566bc8534e93a6c9c15e3db46c315d3cd96a62.zip
databases/py-apsw: Add option to enable EXTENSION loading.
The new option adds support to load DB extensions at runtime. The option is enabled by default because it is required by the latest version of deskutils/calibre. PR: 257111 Approved by: sunpoet (maintainer)
Diffstat (limited to 'databases')
-rw-r--r--databases/py-apsw/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/databases/py-apsw/Makefile b/databases/py-apsw/Makefile
index 8b5dc4fffcde..d205bea531e5 100644
--- a/databases/py-apsw/Makefile
+++ b/databases/py-apsw/Makefile
@@ -3,6 +3,7 @@
PORTNAME= apsw
PORTVERSION= 3.35.4
DISTVERSIONSUFFIX= -r1
+PORTREVISION= 1
CATEGORIES= databases python
MASTER_SITES= https://github.com/rogerbinns/apsw/releases/download/${PORTVERSION}${DISTVERSIONSUFFIX}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,6 +18,14 @@ BUILD_DEPENDS= sqlite3>=${PORTVERSION:R},1:databases/sqlite3
USES= localbase python:3.6+ sqlite:3 zip
USE_PYTHON= autoplist concurrent distutils
+OPTIONS_DEFINE= EXTENSION
+OPTIONS_DEFAULT= EXTENSION
+
+EXTENSION_DESC= Allow loadable extensions
+
+EXTENSION_VARS= PYDISTUTILS_BUILDARGS+=--enable=load_extension
+EXTENSION_VARS_OFF= PYDISTUTILS_BUILDARGS+=--omit=load_extension
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/apsw*.so