aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-24 07:33:35 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-24 07:33:35 +0000
commite56a0f846832acf1256481fd4b8d2f3a88e42459 (patch)
tree935cf0cab2899ddbb4f87417890fb9c13eab92b1 /databases
parenta640f4628df36883f2cd8d3c5002dbc919c9c0ab (diff)
downloadports-e56a0f846832acf1256481fd4b8d2f3a88e42459.tar.gz
ports-e56a0f846832acf1256481fd4b8d2f3a88e42459.zip
Add innotop 0.1.160, a MySQL and InnoDB monitoring program.
PR: ports/104722 Submitted by: Steven Kreuzer <skreuzer at f2o.org>
Notes
Notes: svn path=/head/; revision=177955
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/innotop/Makefile26
-rw-r--r--databases/innotop/distinfo3
-rw-r--r--databases/innotop/pkg-descr8
-rw-r--r--databases/innotop/pkg-plist4
5 files changed, 42 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 6b41969fc78c..6be5ffb3d563 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -77,6 +77,7 @@
SUBDIR += gtksql
SUBDIR += hk_classes
SUBDIR += hsqldb
+ SUBDIR += innotop
SUBDIR += ip4r
SUBDIR += ipa_sdb
SUBDIR += isql-viewer
diff --git a/databases/innotop/Makefile b/databases/innotop/Makefile
new file mode 100644
index 000000000000..2851680b56e1
--- /dev/null
+++ b/databases/innotop/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: innotop
+# Date created: 23 October 2006
+# Whom: Steven Kreuzer <skreuzer@f2o.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= innotop
+PORTVERSION= 0.1.160
+CATEGORIES= databases
+MASTER_SITES= http://www.xaprb.com/innotop/src/ \
+ http://skreuzer.f2o.org/mirror/innotop/
+
+MAINTAINER= skreuzer@f2o.org
+COMMENT= A MySQL and InnoDB monitoring program
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
+ ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
+
+PERL_CONFIGURE= yes
+
+MAN1= innotop.1
+MAN3= InnoDBParser.3
+
+.include <bsd.port.mk>
diff --git a/databases/innotop/distinfo b/databases/innotop/distinfo
new file mode 100644
index 000000000000..c96cdcb0d6c2
--- /dev/null
+++ b/databases/innotop/distinfo
@@ -0,0 +1,3 @@
+MD5 (innotop-0.1.160.tar.gz) = de400da5d88abe8dc50bf9dc495138cf
+SHA256 (innotop-0.1.160.tar.gz) = 0ecc7fa818b74569ac0e851ea9c5710059fff973882324f16231ec3a4d902284
+SIZE (innotop-0.1.160.tar.gz) = 50223
diff --git a/databases/innotop/pkg-descr b/databases/innotop/pkg-descr
new file mode 100644
index 000000000000..ed2a52ec745e
--- /dev/null
+++ b/databases/innotop/pkg-descr
@@ -0,0 +1,8 @@
+innotop connects to a MySQL database server and retrieves
+information from it, then displays it in a manner similar
+to the UNIX top program.
+
+It runs on most Unix systems which have Perl, DBI, and
+Term::ReadKey installed.
+
+WWW: http://www.xaprb.com/innotop/
diff --git a/databases/innotop/pkg-plist b/databases/innotop/pkg-plist
new file mode 100644
index 000000000000..ad908eff160a
--- /dev/null
+++ b/databases/innotop/pkg-plist
@@ -0,0 +1,4 @@
+bin/innotop
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/innotop/.packlist
+%%SITE_PERL%%/InnoDBParser.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/innotop