aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2009-03-23 15:36:21 +0000
committerMartin Matuska <mm@FreeBSD.org>2009-03-23 15:36:21 +0000
commitf6a72ebaee2ead8a9bb106787b790f116fece9b9 (patch)
treeea90487b1a901f29bc676ad70aa6db190f6eaaf2 /databases
parentb2a5391713e76b058df97e561e0e1f1aa4a93d4a (diff)
downloadports-f6a72ebaee2ead8a9bb106787b790f116fece9b9.tar.gz
ports-f6a72ebaee2ead8a9bb106787b790f116fece9b9.zip
- Add MAKE_JOBS_SAFE variable (enable SMP compilation)
- Tinderbox tested on SMP systems i386 + amd64 PR: ports/132970 Submitted by: mm (myself) Approved by: Gea-Suan Lin <gslin@gslin.org> (maintainer)
Notes
Notes: svn path=/head/; revision=230754
Diffstat (limited to 'databases')
-rw-r--r--databases/db45/Makefile1
-rw-r--r--databases/db46/Makefile1
-rw-r--r--databases/db47/Makefile3
3 files changed, 4 insertions, 1 deletions
diff --git a/databases/db45/Makefile b/databases/db45/Makefile
index 9441dad04f78..e1de74057174 100644
--- a/databases/db45/Makefile
+++ b/databases/db45/Makefile
@@ -28,6 +28,7 @@ CONFIGURE_ARGS= --enable-compat185 --enable-dump185 --enable-cxx \
--bindir=${PREFIX}/bin/${PORTNAME}
CONFIGURE_SCRIPT= ../dist/configure
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
INSTALL_TARGET= install_include install_lib install_utilities
LIBTOOLFILES= ${CONFIGURE_SCRIPT}
WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
diff --git a/databases/db46/Makefile b/databases/db46/Makefile
index 00fd1cbd4bc5..0a46cb5de7e5 100644
--- a/databases/db46/Makefile
+++ b/databases/db46/Makefile
@@ -42,6 +42,7 @@ CONFIGURE_ARGS= --enable-compat185 --enable-dump185 --enable-cxx \
--bindir=${PREFIX}/bin/${PORTNAME}
CONFIGURE_SCRIPT= ../dist/configure
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
INSTALL_TARGET= install_include install_lib install_utilities
LIBTOOLFILES= ${CONFIGURE_SCRIPT}
WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
diff --git a/databases/db47/Makefile b/databases/db47/Makefile
index 55e48dae3c00..670ca18ddd04 100644
--- a/databases/db47/Makefile
+++ b/databases/db47/Makefile
@@ -23,7 +23,7 @@ PATCH_DIST_STRIP= -d .. --ignore-whitespace
#
# * patch.4.7.25.2: -----------------------------------------------------------
# # [#16415] DB_ENV->lock_get may self deadlock if user defined locks
-# are used and there is only one lock partition defined.
+# are used and there is only one lock partition defined.
# I allow matthias.andree@gmx.de and all freebsd committer to do changes
# to this package.
@@ -39,6 +39,7 @@ CONFIGURE_ARGS= --enable-compat185 --enable-dump185 --enable-cxx \
--bindir=${PREFIX}/bin/${PORTNAME}
CONFIGURE_SCRIPT= ../dist/configure
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
INSTALL_TARGET= install_include install_lib install_utilities
LIBTOOLFILES= ${CONFIGURE_SCRIPT}
WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix