aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-29 19:10:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-29 19:10:35 +0000
commitfa9186211930f0370123c284996a9a411934f4bd (patch)
tree917107a5ed6e490ddb9bb89dd4d60e8e876d5ee3 /databases
parentf616d389ecafba6ae40fd2c6baf044e03782d71b (diff)
downloadports-fa9186211930f0370123c284996a9a411934f4bd.tar.gz
ports-fa9186211930f0370123c284996a9a411934f4bd.zip
Because the many-to-many relationships are not real relationships,
they can not be introspected with DBIx::Class. Many-to-many relationships are actually just a collection of convenience methods installed to bridge two relationships. This DBIx::Class component can be used to store all relevant information about these non-relationships so they can later be introspected and examined. This module is fairly esoteric and, unless you are dynamically creating something out of of a DBIC Schema, is probably the wrong solution for whatever it is you are trying to do. Please be advised that compatibility is not guaranteed for DBIx::Class 0.09000+. We will try to mantain all compatibility, but internal changes might make it impossible. WWW: http://search.cpan.org/dist/DBIx-Class-IntrospectableM2M/
Notes
Notes: svn path=/head/; revision=223548
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Class-IntrospectableM2M/Makefile23
-rw-r--r--databases/p5-DBIx-Class-IntrospectableM2M/distinfo3
-rw-r--r--databases/p5-DBIx-Class-IntrospectableM2M/pkg-descr15
-rw-r--r--databases/p5-DBIx-Class-IntrospectableM2M/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7d5be57fd571..23971a441f77 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -284,6 +284,7 @@
SUBDIR += p5-DBIx-Class-EncodeColumns
SUBDIR += p5-DBIx-Class-FrozenColumns
SUBDIR += p5-DBIx-Class-InflateColumn-IP
+ SUBDIR += p5-DBIx-Class-IntrospectableM2M
SUBDIR += p5-DBIx-Class-Loader
SUBDIR += p5-DBIx-Class-Schema-Loader
SUBDIR += p5-DBIx-Class-UUIDColumns
diff --git a/databases/p5-DBIx-Class-IntrospectableM2M/Makefile b/databases/p5-DBIx-Class-IntrospectableM2M/Makefile
new file mode 100644
index 000000000000..b6a27a99df8b
--- /dev/null
+++ b/databases/p5-DBIx-Class-IntrospectableM2M/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-DBIx-Class-IntrospectableM2M
+# Date created: 23 Oct 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-IntrospectableM2M
+PORTVERSION= 0.001001
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Introspect many-to-many shortcuts
+
+RUN_DEPENDS= p5-DBIx-Class>=0.06002:${PORTSDIR}/databases/p5-DBIx-Class
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::IntrospectableM2M.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-IntrospectableM2M/distinfo b/databases/p5-DBIx-Class-IntrospectableM2M/distinfo
new file mode 100644
index 000000000000..fc1ad7b373f3
--- /dev/null
+++ b/databases/p5-DBIx-Class-IntrospectableM2M/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Class-IntrospectableM2M-0.001001.tar.gz) = 9c05959fdb632062ec827ec0c7335eae
+SHA256 (DBIx-Class-IntrospectableM2M-0.001001.tar.gz) = 951b4f7cbd20588fb0705bb06769455b44ab69e406083a5079d2b8c07ce83f5d
+SIZE (DBIx-Class-IntrospectableM2M-0.001001.tar.gz) = 14210
diff --git a/databases/p5-DBIx-Class-IntrospectableM2M/pkg-descr b/databases/p5-DBIx-Class-IntrospectableM2M/pkg-descr
new file mode 100644
index 000000000000..6485771f7981
--- /dev/null
+++ b/databases/p5-DBIx-Class-IntrospectableM2M/pkg-descr
@@ -0,0 +1,15 @@
+Because the many-to-many relationships are not real relationships,
+they can not be introspected with DBIx::Class. Many-to-many
+relationships are actually just a collection of convenience methods
+installed to bridge two relationships. This DBIx::Class component
+can be used to store all relevant information about these
+non-relationships so they can later be introspected and examined.
+
+This module is fairly esoteric and, unless you are dynamically
+creating something out of of a DBIC Schema, is probably the wrong
+solution for whatever it is you are trying to do. Please be advised
+that compatibility is not guaranteed for DBIx::Class 0.09000+. We
+will try to mantain all compatibility, but internal changes might
+make it impossible.
+
+WWW: http://search.cpan.org/dist/DBIx-Class-IntrospectableM2M/
diff --git a/databases/p5-DBIx-Class-IntrospectableM2M/pkg-plist b/databases/p5-DBIx-Class-IntrospectableM2M/pkg-plist
new file mode 100644
index 000000000000..ba5a570a89c5
--- /dev/null
+++ b/databases/p5-DBIx-Class-IntrospectableM2M/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/DBIx/Class/IntrospectableM2M.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/IntrospectableM2M/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/IntrospectableM2M
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/DBIx/Class
+@dirrmtry %%SITE_PERL%%/DBIx