aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-08-05 06:36:06 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-08-05 06:36:06 +0000
commitff06f04d625e3c28311d8254b72c85a6195d5f33 (patch)
tree51f033288fcc6580e295342276492a46dcd51644 /databases
parent3c5549caa0e34e627b6016ce5f5a2dc713123c43 (diff)
downloadports-ff06f04d625e3c28311d8254b72c85a6195d5f33.tar.gz
ports-ff06f04d625e3c28311d8254b72c85a6195d5f33.zip
USES=execinfo
Notes
Notes: svn path=/head/; revision=364076
Diffstat (limited to 'databases')
-rw-r--r--databases/akonadi/Makefile3
-rw-r--r--databases/galera/Makefile5
-rw-r--r--databases/libmemcached/Makefile5
-rw-r--r--databases/mongodb/Makefile5
-rw-r--r--databases/redis-devel/Makefile2
-rw-r--r--databases/redis/Makefile2
-rw-r--r--databases/rubygem-bdb1/Makefile2
-rw-r--r--databases/twemproxy/Makefile2
8 files changed, 11 insertions, 15 deletions
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index bd729e1bcc26..2ca96e8684e7 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -16,11 +16,10 @@ LICENSE= LGPL21
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
# Let process generate meaningful backtrace on core dump.
-LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
USE_KDE4= kdehier kdeprefix automoc4 soprano
-USES= cmake:outsource shared-mime-info compiler:c++11-lang tar:bzip2
+USES= cmake:outsource execinfo shared-mime-info compiler:c++11-lang tar:bzip2
USE_QT4= corelib dbus gui network qtestlib_build sql xml \
moc_build qmake_build rcc_build uic_build
CMAKE_ARGS+= -DAKONADI_BUILD_TESTS:BOOL=FALSE \
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index c62dd1bb82f5..ecb4c8af69c2 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -16,10 +16,9 @@ LICENSE= GPLv2
BUILD_DEPENDS= checkmk:${PORTSDIR}/devel/libcheck \
doxygen:${PORTSDIR}/devel/doxygen \
${PYTHON_PKGNAMEPREFIX}cloud_sptheme>=0:${PORTSDIR}/textproc/py-cloud_sptheme
-LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
- libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs
-USES= scons shebangfix
+USES= execinfo scons shebangfix
USE_CXXSTD= c++11
USE_LDCONFIG= yes
diff --git a/databases/libmemcached/Makefile b/databases/libmemcached/Makefile
index 31276fd7dfad..cd134bbd7aae 100644
--- a/databases/libmemcached/Makefile
+++ b/databases/libmemcached/Makefile
@@ -9,10 +9,9 @@ MASTER_SITES= http://launchpad.net/${PORTNAME}/1.0/${PORTVERSION}/+download/
MAINTAINER= m.tsatsenko@gmail.com
COMMENT= C and C++ client library to the memcached server
-LIB_DEPENDS?= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libevent.so:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS?= libevent.so:${PORTSDIR}/devel/libevent2
-USES= gmake pathfix pkgconfig perl5 libtool
+USES= execinfo gmake pathfix pkgconfig perl5 libtool
USE_PERL5= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index 9c2666dd464f..50c8f66435a1 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -14,8 +14,7 @@ COMMENT= NOSQL distributed document-oriented database
LICENSE= AGPLv3 APACHE20
LICENSE_COMB= multi
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libpcre.so:${PORTSDIR}/devel/pcre \
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
libsnappy.so:${PORTSDIR}/archivers/snappy \
libv8.so:${PORTSDIR}/lang/v8 \
# boost 1.52/1.55 from ports make mongod segfaulting with many tests
@@ -32,7 +31,7 @@ OPTIONS_DEFINE= SSL SASL TEST
OPTIONS_DEFAULT=SSL
TEST_DESC= Add support for running regression test
-USES= scons
+USES= execinfo scons
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} --cc=${CC} --cxx=${CXX} \
--use-system-pcre --use-system-snappy --use-system-v8
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index 5441cf730716..4907c809ea8d 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -14,7 +14,7 @@ COMMENT= Persistent key-value database with built-in net interface
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+USES= execinfo
OPTIONS_DEFINE= TESTS
OPTIONS_RADIO= EXTLUA
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 54bf1327e722..dbaeda0a3145 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -11,7 +11,7 @@ COMMENT= Persistent key-value database with built-in net interface
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+USES= execinfo
OPTIONS_DEFINE= TESTS
OPTIONS_RADIO= EXTLUA
diff --git a/databases/rubygem-bdb1/Makefile b/databases/rubygem-bdb1/Makefile
index fde185f12ea0..122a154aa4e8 100644
--- a/databases/rubygem-bdb1/Makefile
+++ b/databases/rubygem-bdb1/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby interface to Berkeley DB revision 1.8x with full feature support
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+USES= execinfo
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/twemproxy/Makefile b/databases/twemproxy/Makefile
index 5efc1edb1ee1..92b8b05f05ba 100644
--- a/databases/twemproxy/Makefile
+++ b/databases/twemproxy/Makefile
@@ -12,7 +12,7 @@ COMMENT= Fast, light-weight proxy for memcached and redis
LICENSE= APACHE20
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+USES= execinfo
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo