aboutsummaryrefslogtreecommitdiff
path: root/deskutils/caja-extensions/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-04-14 11:58:42 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-04-14 11:58:42 +0000
commitb65cda7726a4a2943f95a9d4db4a258ad16d589e (patch)
tree6d15d8e5673f01c92b62897517646373426ad7b4 /deskutils/caja-extensions/Makefile
parent959b42f142c16bdb9f8875e0816df1f05e8253df (diff)
downloadports-b65cda7726a4a2943f95a9d4db4a258ad16d589e.tar.gz
ports-b65cda7726a4a2943f95a9d4db4a258ad16d589e.zip
Fix some glib schema issues.
The schemas should be listed in GLIB_SCHEMAS instead of in the plist so the glib schema database can be updated on installed/removal of the package. This updating is done by the GLIB_SCHEMAS macro. Make shotwell not run glib-compile-schemas in the stagedir, this has no effect. Additional this generates the share/glib-2.0/schemas/gschemas.compiled file. This file is managed by the glib20 port. And has a changing checksum because it recompiled every time a GLIB_SCHEMAS enabled port is installed or removed.
Notes
Notes: svn path=/head/; revision=383994
Diffstat (limited to 'deskutils/caja-extensions/Makefile')
-rw-r--r--deskutils/caja-extensions/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/deskutils/caja-extensions/Makefile b/deskutils/caja-extensions/Makefile
index 50c16d8c26a5..11b9cdc93d22 100644
--- a/deskutils/caja-extensions/Makefile
+++ b/deskutils/caja-extensions/Makefile
@@ -3,7 +3,7 @@
PORTNAME= caja-extensions
PORTVERSION= 1.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -24,4 +24,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+GLIB_SCHEMAS= org.mate.Caja.Sendto.gschema.xml \
+ org.mate.caja-open-terminal.gschema.xml
+
.include <bsd.port.mk>