aboutsummaryrefslogtreecommitdiff
path: root/deskutils/calendar
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-10-30 18:23:58 +0000
committerStefan Eßer <se@FreeBSD.org>2020-10-30 18:23:58 +0000
commitaa905f6b03922075a02c7f826e5c86cdb25df0eb (patch)
tree8e7753aaf83214e1efb73f9e0a5b5cded5661d6d /deskutils/calendar
parent1b8f14c12b8f867d4707d87d9d1f60342a778d66 (diff)
downloadports-aa905f6b03922075a02c7f826e5c86cdb25df0eb.tar.gz
ports-aa905f6b03922075a02c7f826e5c86cdb25df0eb.zip
Upgrade to to FreeBSD base SVN revision r367173
The order of events printed was reversed due to the way a link list was updated. This version prints the events in the order they appear in in the data file.
Notes
Notes: svn path=/head/; revision=553710
Diffstat (limited to 'deskutils/calendar')
-rw-r--r--deskutils/calendar/Makefile4
-rw-r--r--deskutils/calendar/distinfo6
-rw-r--r--deskutils/calendar/files/patch-dates.c35
-rw-r--r--deskutils/calendar/files/patch-tests_regress.s5.out7
4 files changed, 47 insertions, 5 deletions
diff --git a/deskutils/calendar/Makefile b/deskutils/calendar/Makefile
index b2b46106121a..afb8c9998962 100644
--- a/deskutils/calendar/Makefile
+++ b/deskutils/calendar/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= calendar
-DISTVERSION= 0.5
+DISTVERSION= 0.6
CATEGORIES= deskutils
MAINTAINER= se@FreeBSD.org
@@ -15,7 +15,7 @@ USE_GITHUB= yes
GH_ACCOUNT= bsdimp
GH_TAGNAME= fcc5d31
-CFLAGS+= -D_PATH_LOCALBASE=\"${LOCALBASE}\" -g -O0 # -DDEBUG
+CFLAGS+= -D_PATH_LOCALBASE=\"${LOCALBASE}\"
LDFLAGS+= -lm -lutil
PLIST_FILES= bin/calendar \
diff --git a/deskutils/calendar/distinfo b/deskutils/calendar/distinfo
index c41ee82628a1..eae8196e8e16 100644
--- a/deskutils/calendar/distinfo
+++ b/deskutils/calendar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604068556
-SHA256 (bsdimp-calendar-0.5-fcc5d31_GH0.tar.gz) = ad7d0b51c4b834241aebbf6c50d187e5720f6c46c02615b27841a923e082aebc
-SIZE (bsdimp-calendar-0.5-fcc5d31_GH0.tar.gz) = 132824
+TIMESTAMP = 1604081560
+SHA256 (bsdimp-calendar-0.6-fcc5d31_GH0.tar.gz) = ad7d0b51c4b834241aebbf6c50d187e5720f6c46c02615b27841a923e082aebc
+SIZE (bsdimp-calendar-0.6-fcc5d31_GH0.tar.gz) = 132824
diff --git a/deskutils/calendar/files/patch-dates.c b/deskutils/calendar/files/patch-dates.c
new file mode 100644
index 000000000000..c2c707afa3c6
--- /dev/null
+++ b/deskutils/calendar/files/patch-dates.c
@@ -0,0 +1,35 @@
+--- dates.c.orig 2020-10-18 03:01:26 UTC
++++ dates.c
+@@ -28,7 +28,7 @@
+ */
+
+ #include <sys/cdefs.h>
+-__FBSDID("$FreeBSD$");
++__FBSDID("$FreeBSD: head/usr.bin/calendar/dates.c 367173 2020-10-30 15:43:52Z se $");
+
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -64,6 +64,7 @@ struct cal_day {
+ struct cal_month *month; /* points back */
+ struct cal_year *year; /* points back */
+ struct event *events;
++ struct event *lastevent;
+ };
+
+ int debug_remember = 0;
+@@ -446,8 +447,13 @@ void
+ addtodate(struct event *e, int year, int month, int day)
+ {
+ struct cal_day *d;
++ struct event *ee;
+
+ d = find_day(year, month, day);
+- e->next = d->events;
+- d->events = e;
++ ee = d->lastevent;
++ if (ee != NULL)
++ ee->next = e;
++ else
++ d->events = e;
++ d->lastevent = e;
+ }
diff --git a/deskutils/calendar/files/patch-tests_regress.s5.out b/deskutils/calendar/files/patch-tests_regress.s5.out
new file mode 100644
index 000000000000..1c3c07b1f86f
--- /dev/null
+++ b/deskutils/calendar/files/patch-tests_regress.s5.out
@@ -0,0 +1,7 @@
+--- tests/regress.s5.out.orig 2020-10-18 03:01:26 UTC
++++ tests/regress.s5.out
+@@ -1,3 +1,3 @@
+-Jun 21* sunthird
+ Jun 21 jun 21
++Jun 21* sunthird
+ Jun 22 jun 22