aboutsummaryrefslogtreecommitdiff
path: root/deskutils/calibre
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-02-11 16:44:11 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-02-11 16:44:11 +0000
commit4f1604c79cd140192cf4b07fe942c0586dba37fc (patch)
tree894da96a70f2c010be60c0fc496e75f351dd7d38 /deskutils/calibre
parenteac5501ee7cac3a423a963b84ff48f82093e00fd (diff)
downloadports-4f1604c79cd140192cf4b07fe942c0586dba37fc.tar.gz
ports-4f1604c79cd140192cf4b07fe942c0586dba37fc.zip
- Update to 1.23.0
PR: ports/186609 Submitted by: Rusty Nejdl <rnejdl@ringofsaturn.com> (maintainer)
Notes
Notes: svn path=/head/; revision=343767
Diffstat (limited to 'deskutils/calibre')
-rw-r--r--deskutils/calibre/Makefile3
-rw-r--r--deskutils/calibre/distinfo4
-rw-r--r--deskutils/calibre/files/patch-calibre_linux.py18
-rw-r--r--deskutils/calibre/pkg-plist16
4 files changed, 28 insertions, 13 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index f290e1012d7e..5886f44ad311 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= calibre
-PORTVERSION= 1.21.0
-PORTREVISION= 1
+PORTVERSION= 1.23.0
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index 095858413e25..b29b8350bb56 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,2 +1,2 @@
-SHA256 (calibre-1.21.0.tar.xz) = 30327d0b298b02dc80b9724ab847e1ff2d9b717e713705c79c4f8cf893b71c16
-SIZE (calibre-1.21.0.tar.xz) = 32437820
+SHA256 (calibre-1.23.0.tar.xz) = a95076588ae047b9f75f036da4c8b1eb573e7f0d8fd8b3afc5d38ac046d9a6ea
+SIZE (calibre-1.23.0.tar.xz) = 32690648
diff --git a/deskutils/calibre/files/patch-calibre_linux.py b/deskutils/calibre/files/patch-calibre_linux.py
index b6a6a7b1e4c3..97b7cd82e7d0 100644
--- a/deskutils/calibre/files/patch-calibre_linux.py
+++ b/deskutils/calibre/files/patch-calibre_linux.py
@@ -1,10 +1,16 @@
---- src/calibre/linux.py.orig 2014-01-24 05:56:21.000000000 +0100
-+++ src/calibre/linux.py 2014-01-29 00:30:43.102775394 +0100
-@@ -712,9 +712,12 @@
+--- src/calibre/linux.py.orig 2014-02-09 13:42:40.000000000 -0600
++++ src/calibre/linux.py 2014-02-09 13:43:59.000000000 -0600
+@@ -712,6 +712,7 @@
f.close()
des = ('calibre-gui.desktop', 'calibre-lrfviewer.desktop',
'calibre-ebook-viewer.desktop', 'calibre-ebook-edit.desktop')
-+ dtpdirs = ('gnome/apps', 'applications')
++ dtpdirs = ('gnome/apps', 'applications')
+ appdata = os.path.join(os.path.dirname(self.opts.staging_sharedir), 'appdata')
+ if not os.path.exists(appdata):
+ try:
+@@ -726,8 +727,10 @@
+
+ APPDATA = get_appdata()
for x in des:
- cmd = ['xdg-desktop-menu', 'install', '--noupdate', './'+x]
- cc(' '.join(cmd), shell=True)
@@ -13,5 +19,5 @@
+ cmd = ['cp', './'+x, dest]
+ cc(' '.join(cmd), shell=True)
self.menu_resources.append(x)
- cc(['xdg-desktop-menu', 'forceupdate'])
- f = open('calibre-mimetypes.xml', 'wb')
+ ak = x.partition('.')[0]
+ if ak in APPDATA and os.access(appdata, os.W_OK):
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index b00e7306dd3c..126d4ce88e42 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -998,11 +998,16 @@ lib/calibre/calibre/gui2/tweak_book/__init__.py
lib/calibre/calibre/gui2/tweak_book/boss.py
lib/calibre/calibre/gui2/tweak_book/char_select.py
lib/calibre/calibre/gui2/tweak_book/check.py
-lib/calibre/calibre/gui2/tweak_book/diff.py
+lib/calibre/calibre/gui2/tweak_book/diff/__init__.py
+lib/calibre/calibre/gui2/tweak_book/diff/highlight.py
+lib/calibre/calibre/gui2/tweak_book/diff/main.py
+lib/calibre/calibre/gui2/tweak_book/diff/view.py
lib/calibre/calibre/gui2/tweak_book/editor/__init__.py
lib/calibre/calibre/gui2/tweak_book/editor/canvas.py
lib/calibre/calibre/gui2/tweak_book/editor/image.py
lib/calibre/calibre/gui2/tweak_book/editor/insert_resource.py
+lib/calibre/calibre/gui2/tweak_book/editor/smart/__init__.py
+lib/calibre/calibre/gui2/tweak_book/editor/smart/html.py
lib/calibre/calibre/gui2/tweak_book/editor/syntax/__init__.py
lib/calibre/calibre/gui2/tweak_book/editor/syntax/base.py
lib/calibre/calibre/gui2/tweak_book/editor/syntax/css.py
@@ -1129,7 +1134,6 @@ lib/calibre/calibre/utils/config.py
lib/calibre/calibre/utils/config_base.py
lib/calibre/calibre/utils/date.py
lib/calibre/calibre/utils/dictclient.py
-lib/calibre/calibre/utils/diff/__init__.py
lib/calibre/calibre/utils/file_associations.py
lib/calibre/calibre/utils/filenames.py
lib/calibre/calibre/utils/fonts/__init__.py
@@ -1404,6 +1408,9 @@ lib/calibre/routes/route.py
lib/calibre/routes/util.py
lib/calibre/templite/__init__.py
%%PYTHON_SITELIBDIR%%/init_calibre.py
+share/appdata/calibre-ebook-edit.appdata.xml
+share/appdata/calibre-ebook-viewer.appdata.xml
+share/appdata/calibre-gui.appdata.xml
share/applications/calibre-ebook-edit.desktop
share/applications/calibre-ebook-viewer.desktop
share/applications/calibre-gui.desktop
@@ -1520,6 +1527,7 @@ share/applications/calibre-lrfviewer.desktop
%%DATADIR%%/images/dialog_question.png
%%DATADIR%%/images/dialog_warning.png
%%DATADIR%%/images/dictionary.png
+%%DATADIR%%/images/diff.png
%%DATADIR%%/images/document-encrypt.png
%%DATADIR%%/images/document-new.png
%%DATADIR%%/images/document_open.png
@@ -1955,6 +1963,7 @@ share/zsh/site-functions/_calibre
@dirrmtry share/gnome
@dirrmtry share/desktop-directories
@dirrmtry share/bash-completion
+@dirrmtry share/appdata
@dirrmtry share/zsh/site-functions
@dirrmtry share/zsh
@dirrm %%DATADIR%%/viewer/mathjax/jax/output/SVG/fonts/TeX/Typewriter/Regular
@@ -2063,7 +2072,6 @@ share/zsh/site-functions/_calibre
@dirrm lib/calibre/calibre/utils/fonts/sfnt/cff
@dirrm lib/calibre/calibre/utils/fonts/sfnt
@dirrm lib/calibre/calibre/utils/fonts
-@dirrm lib/calibre/calibre/utils/diff
@dirrm lib/calibre/calibre/utils/chm
@dirrm lib/calibre/calibre/utils
@dirrm lib/calibre/calibre/translations
@@ -2074,7 +2082,9 @@ share/zsh/site-functions/_calibre
@dirrm lib/calibre/calibre/gui2/wizard
@dirrm lib/calibre/calibre/gui2/viewer
@dirrm lib/calibre/calibre/gui2/tweak_book/editor/syntax
+@dirrm lib/calibre/calibre/gui2/tweak_book/editor/smart
@dirrm lib/calibre/calibre/gui2/tweak_book/editor
+@dirrm lib/calibre/calibre/gui2/tweak_book/diff
@dirrm lib/calibre/calibre/gui2/tweak_book
@dirrm lib/calibre/calibre/gui2/toc
@dirrm lib/calibre/calibre/gui2/tag_browser