aboutsummaryrefslogtreecommitdiff
path: root/deskutils/conkyforecast
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 04:15:47 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-16 04:19:54 +0000
commit193550c2afde726e71f0835f589b435986ec8f97 (patch)
tree5879dc51d4f328c03c7b2b067c67290275ed5e5f /deskutils/conkyforecast
parented99bf72da584a055018b0351fc3e34a97e23f64 (diff)
downloadports-193550c2afde726e71f0835f589b435986ec8f97.tar.gz
ports-193550c2afde726e71f0835f589b435986ec8f97.zip
deskutils/conkyforecast: Fix build with setuptools 61.0.0+
With hat: python
Diffstat (limited to 'deskutils/conkyforecast')
-rw-r--r--deskutils/conkyforecast/files/patch-setup.py16
1 files changed, 12 insertions, 4 deletions
diff --git a/deskutils/conkyforecast/files/patch-setup.py b/deskutils/conkyforecast/files/patch-setup.py
index 32a0c3ff412a..2adc1b4676a0 100644
--- a/deskutils/conkyforecast/files/patch-setup.py
+++ b/deskutils/conkyforecast/files/patch-setup.py
@@ -1,10 +1,18 @@
---- setup.py.orig 2010-01-07 05:02:45.000000000 +0700
-+++ setup.py 2010-05-07 23:16:08.000000000 +0800
-@@ -46,7 +46,6 @@
- ('/usr/share/conkyforecast/', [ 'conkyForecast.pot' ] ),
+--- setup.py.orig 2011-04-29 09:12:29 UTC
++++ setup.py
+@@ -46,7 +46,6 @@ setup(
('/usr/share/conkyforecast/', [ 'conkyForecast.config' ] ),
+ ('/usr/share/conkyforecast/', [ 'conkyForecast-SunsetSunriseCountdown.py' ] ),
('/usr/share/conkyforecast/example', listfiles( 'example', '*' ) ),
- ('/usr/share/fonts/truetype/conkyforecast', listfiles( 'fonts', '*' ) ),
('/usr/share/conkyforecast/images/bearingicons', listfiles( 'images/bearingicons', '*' ) ),
('/usr/share/conkyforecast/images/moonicons', listfiles( 'images/moonicons', '*' ) ),
('/usr/share/conkyforecast/images/weathericons', listfiles( 'images/weathericons', '*' ) ),
+@@ -68,5 +67,7 @@ setup(
+ ('/usr/share/conkyforecast/locale/zh/LC_MESSAGES', listfiles( 'locale/zh/LC_MESSAGES', '*' ) ),
+ ('/usr/share/conkyforecast/test', listfiles( 'test', '*' ) )
+ ],
++ # Declare packages explicitly so that setuptools does not attempt auto discovery
++ packages=[],
+ )
+