aboutsummaryrefslogtreecommitdiff
path: root/deskutils/egroupware/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-19 16:34:02 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-19 16:34:02 +0000
commite3cee949f106af42246631f561813eae55e43c80 (patch)
tree71a22cda7c06ff0a0083fcc0931b67514ad51404 /deskutils/egroupware/Makefile
parentbf302e919b020f03ea9f497c152613417a0efd05 (diff)
downloadports-e3cee949f106af42246631f561813eae55e43c80.tar.gz
ports-e3cee949f106af42246631f561813eae55e43c80.zip
- Update from 1.8.005.20131007 to 1.8.006.20140217
- Use options helpers
Notes
Notes: svn path=/head/; revision=345113
Diffstat (limited to 'deskutils/egroupware/Makefile')
-rw-r--r--deskutils/egroupware/Makefile50
1 files changed, 10 insertions, 40 deletions
diff --git a/deskutils/egroupware/Makefile b/deskutils/egroupware/Makefile
index 0a23b939e083..709bf2002d8e 100644
--- a/deskutils/egroupware/Makefile
+++ b/deskutils/egroupware/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= eGroupware
-PORTVERSION= 1.8.005.20131007
+PORTVERSION= 1.8.006.20140217
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}-1.8/${PORTNAME}-${PORTVERSION}
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.bz2 \
@@ -38,45 +38,15 @@ MBSTRING_DESC= Support multi-byte character sets
POSTGRES_DESC= PostgreSQL database support
ZIP_DESC= Install PHP zip extension
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
-USE_PHP+= pdo_mysql
-.endif
-
-.if ${PORT_OPTIONS:MPOSTGRES}
-USE_PHP+= pgsql
-USE_PHP+= pdo_pgsql
-.endif
-
-.if ${PORT_OPTIONS:MMBSTRING}
-USE_PHP+= mbstring
-.endif
-
-.if ${PORT_OPTIONS:MIMAP}
-USE_PHP+= imap
-.endif
-
-.if ${PORT_OPTIONS:MOSSL}
-USE_PHP+= openssl
-.endif
-
-.if ${PORT_OPTIONS:MTNEF}
-RUN_DEPENDS+= tnef:${PORTSDIR}/converters/tnef
-.endif
-
-.if ${PORT_OPTIONS:MZIP}
-USE_PHP+= zip
-.endif
-
-.if ${PORT_OPTIONS:MGD}
-USE_PHP+= gd
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_PHP+= ldap
-.endif
+MYSQL_USE= PHP=mysql,pdo_mysql
+POSTGRES_USE= PHP=pgsql,pdo_pgsql
+MBSTRING_USE= PHP=mbstring
+IMAP_USE= PHP=imap
+OSSL_USE= PHP=openssl
+ZIP_USE= PHP=zip
+GD_USE= PHP=gd
+LDAP_USE= PHP=ldap
+TNEF_RUN_DEPENDS= tnef:${PORTSDIR}/converters/tnef
WRKSRC= ${WRKDIR}/egroupware
EG_DIR= www/eg