aboutsummaryrefslogtreecommitdiff
path: root/deskutils/etask
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2004-12-15 15:59:15 +0000
committerClive Lin <clive@FreeBSD.org>2004-12-15 15:59:15 +0000
commitfc64824d902478e57ea509474315b8e262cc3034 (patch)
tree6d6aec82ef243092503f0e9ae249af8e6d9880c9 /deskutils/etask
parent2c46093464219d61ba09b3666beee28c1289c111 (diff)
downloadports-fc64824d902478e57ea509474315b8e262cc3034.tar.gz
ports-fc64824d902478e57ea509474315b8e262cc3034.zip
Add etask, an emacs mode to handle projects/todos/events.
PR: ports/75095 Submitted by: "Dryice Liu" dryice at liu.com.cn
Notes
Notes: svn path=/head/; revision=124126
Diffstat (limited to 'deskutils/etask')
-rw-r--r--deskutils/etask/Makefile52
-rw-r--r--deskutils/etask/distinfo2
-rw-r--r--deskutils/etask/pkg-descr22
-rw-r--r--deskutils/etask/pkg-plist19
4 files changed, 95 insertions, 0 deletions
diff --git a/deskutils/etask/Makefile b/deskutils/etask/Makefile
new file mode 100644
index 000000000000..812116bf4d45
--- /dev/null
+++ b/deskutils/etask/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: etask
+# Date created: 15 December 2004
+# Whom: Dryice Liu <dryice@liu.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= etask
+PORTVERSION= 0.3.91
+CATEGORIES= deskutils elisp
+MASTER_SITES= http://members.chello.at/rene.weichselbaum/
+
+MAINTAINER= dryice@liu.com.cn
+COMMENT= Manage your projects or tasks within GNU Emacs
+
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
+ dvips:${PORTSDIR}/print/dvipsk-tetex \
+ ps2pdf:${PORTSDIR}/print/ghostscript-gnu \
+ xpdf:${PORTSDIR}/graphics/xpdf
+
+EMACS_PORT_NAME?= emacs21
+
+.if ${EMACS_PORT_NAME} != "emacs21"
+PORTNAMESUFFIX= ${PKGNAMESUFFIX}
+.endif
+
+LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${DISTNAME}a
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= etasktut.pdf gpl.txt README
+.endif
+
+do-build:
+ cd ${WRKSRC}; ${EMACS_NAME} -batch -no-site-file\
+ --eval="(add-to-list 'load-path \"${WRKSRC}\")"\
+ -f batch-byte-compile *.el
+
+do-install:
+ ${MKDIR} ${LISPDIR}
+.for i in *.el *.elc
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${LISPDIR}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/deskutils/etask/distinfo b/deskutils/etask/distinfo
new file mode 100644
index 000000000000..ad57e103f31e
--- /dev/null
+++ b/deskutils/etask/distinfo
@@ -0,0 +1,2 @@
+MD5 (etask-0.3.91.tar.gz) = 88a5f99d80c84b8a81bfa62dd2b0911b
+SIZE (etask-0.3.91.tar.gz) = 199577
diff --git a/deskutils/etask/pkg-descr b/deskutils/etask/pkg-descr
new file mode 100644
index 000000000000..2ac631f72a0b
--- /dev/null
+++ b/deskutils/etask/pkg-descr
@@ -0,0 +1,22 @@
+If you want Emacs to support you in your efforts to define and manage
+your projects or tasks this Emacs extension is for you.
+
+Some of the features you might find useful within the Emacs environment:
+
+ * Keep track of tasks in multiple projects
+ * Manage your todos
+ * Display Gantt bars for all tasks and todos
+ * Change the zoom factor of the Gantt chart
+ * Classify each project task according to its criticality:
+ o Normal tasks
+ o High risk tasks
+ o Tasks lying on the critical path
+ * Make task and todo notes
+ * Set task-specific progress goals: linear, moderate s-shaped, or
+ s-shaped with tougher requirements for the middle phase and
+ therefore more flexibility towards the planned end
+ * Multilingual (German and English)
+ * Print detailed project status reports
+ * Generate LaTeX output for high-quality Gantt charts
+
+WWW: http://members.chello.at/rene.weichselbaum/etask.html
diff --git a/deskutils/etask/pkg-plist b/deskutils/etask/pkg-plist
new file mode 100644
index 000000000000..0e143560865e
--- /dev/null
+++ b/deskutils/etask/pkg-plist
@@ -0,0 +1,19 @@
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-cat.el
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-cat.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-db.el
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-db.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-event.el
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-event.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-lang.el
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-lang.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-port.el
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-port.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-proj.el
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-proj.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-tex.el
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-tex.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-todo.el
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask-todo.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask.el
+%%EMACS_VERSION_SITE_LISPDIR%%/etask/etask.elc
+@dirrm %%EMACS_VERSION_SITE_LISPDIR%%/etask