aboutsummaryrefslogtreecommitdiff
path: root/deskutils/fet/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /deskutils/fet/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'deskutils/fet/Makefile')
-rw-r--r--deskutils/fet/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/deskutils/fet/Makefile b/deskutils/fet/Makefile
index d23158e3a260..107419b199b9 100644
--- a/deskutils/fet/Makefile
+++ b/deskutils/fet/Makefile
@@ -15,7 +15,7 @@ COMMENT= Free timetabling software
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= qmake tar:bzip2
+USES= qmake qt:4 tar:bzip2
PORTEXAMPLES= *
@@ -34,8 +34,10 @@ ONLYCL_DESC= Build only command line version (without Qt GUI)
OPTIONS_SUB= yes
-QT4_USE= QT4=corelib,moc_build,rcc_build,uic_build,xml
-QT5_USE= QT5=buildtools_build,core,xml GL=gl
+QT4_USES= qt:4
+QT4_USE= QT=corelib,moc_build,rcc_build,uic_build,xml
+QT5_USES= qt:5
+QT5_USE= QT=buildtools_build,core,xml GL=gl
.include <bsd.port.options.mk>
@@ -45,9 +47,9 @@ QMAKE_SOURCE_PATH= ${WRKSRC}/src/src-cl.pro
.else
INSTALL_TARGET+= ${WRKSRC}/fet
.if ${PORT_OPTIONS:MQT4}
-USE_QT4+=gui network
+USE_QT+= gui network
.else
-USE_QT5+=gui network printsupport widgets
+USE_QT+= gui network printsupport widgets
.endif
.endif