aboutsummaryrefslogtreecommitdiff
path: root/deskutils/genius/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-30 08:35:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-30 08:35:49 +0000
commit24794c61d6e3c9b86f9c4972eedb598c14266a10 (patch)
tree6834cae424635efc6fd5cecd039422f85bca412b /deskutils/genius/Makefile
parent53ae2abde5fff49698ad1598e013e4f7d8d0b721 (diff)
downloadports-24794c61d6e3c9b86f9c4972eedb598c14266a10.tar.gz
ports-24794c61d6e3c9b86f9c4972eedb598c14266a10.zip
Update to version 0.7.2
PR: ports/75619 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=125507
Diffstat (limited to 'deskutils/genius/Makefile')
-rw-r--r--deskutils/genius/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index ab9cba3b5df6..0d933a1750f1 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= genius
-PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTVERSION= 0.7.2
CATEGORIES= deskutils gnome
-MASTER_SITES= http://ftp.5z.com/pub/genius/
+MASTER_SITES= ${MASTER_SITE_GNOME} \
+ http://ftp.5z.com/pub/genius/
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
MAINTAINER= ports@FreeBSD.org
COMMENT= Arbitrary precision calculator for Gnome Desktop Environment
@@ -18,20 +19,20 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_PERL5_BUILD= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget gtksourceview libgnomeui \
- lthack vte
+USE_GNOME= gnomehack gnomeprefix gnometarget gtksourceview libgnomeui vte
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
+LIBTOOLFILES= configure mpfr/configure
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-extra-gcc-optimization
+INSTALLS_OMF= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500018
-IGNORE= "Requires readline 4.2 or newer"
+BROKEN= Does not compile on 4.x
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
-post-patch:
- @${PERL} -pi -e 's|-O3 ||g' ${WRKSRC}/configure
-
.include <bsd.port.post.mk>