aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnotime
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /deskutils/gnotime
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'deskutils/gnotime')
-rw-r--r--deskutils/gnotime/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/deskutils/gnotime/Makefile b/deskutils/gnotime/Makefile
index 1be663112d44..586d3e343047 100644
--- a/deskutils/gnotime/Makefile
+++ b/deskutils/gnotime/Makefile
@@ -26,8 +26,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool libltdl
LIBTOOLFILES= configure ../${QOF_DISTNAME}/configure
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- LIBQOF_CFLAGS="${LIBQOF_CFLAGS}" LIBQOF_LIBS="${LIBQOF_LIBS}"
+CONFIGURE_ENV= LIBQOF_CFLAGS="${LIBQOF_CFLAGS}" LIBQOF_LIBS="${LIBQOF_LIBS}"
USE_LDCONFIG= yes
INSTALLS_OMF= yes
@@ -38,8 +37,8 @@ QOF_VERSION= 0.7.5
QOF_DISTNAME= qof-${QOF_VERSION}
QOF_WRKSRC= ${WRKDIR}/${QOF_DISTNAME}
-CPPFLAGS= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
-LDFLAGS= -L${LOCALBASE}/lib `pkg-config --libs libgnomeui-2.0`
+CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
+LDFLAGS+= -L${LOCALBASE}/lib `pkg-config --libs libgnomeui-2.0`
LIBQOF_CFLAGS= -I${QOF_WRKSRC}/qof
LIBQOF_LIBS= -L${QOF_WRKSRC}/qof/.libs -lqof
@@ -57,6 +56,7 @@ pre-configure:
@(cd ${QOF_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
CC="${CC}" CFLAGS="${CFLAGS}" \
CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
./configure --prefix=${PREFIX} --disable-error-on-warning \
--disable-sqlite --disable-gdasql)