aboutsummaryrefslogtreecommitdiff
path: root/deskutils/griffith/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 16:59:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 16:59:20 +0000
commitebdc8740cb89f824afce83e20c29f487f5fffdb1 (patch)
tree1e21bd11cd298963c7da7054dbb6e9a6e6d1eb1d /deskutils/griffith/Makefile
parentcb564fb324f294b0ac8ecd9ce88e4d9d4bd0608f (diff)
downloadports-ebdc8740cb89f824afce83e20c29f487f5fffdb1.tar.gz
ports-ebdc8740cb89f824afce83e20c29f487f5fffdb1.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=297967
Diffstat (limited to 'deskutils/griffith/Makefile')
-rw-r--r--deskutils/griffith/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/deskutils/griffith/Makefile b/deskutils/griffith/Makefile
index a9bac2e94b45..ebb02fcc8cba 100644
--- a/deskutils/griffith/Makefile
+++ b/deskutils/griffith/Makefile
@@ -21,10 +21,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3
${PYTHON_PKGNAMEPREFIX}imaging>=0:${PORTSDIR}/graphics/py-imaging \
${PYXML}
-OPTIONS= LXML "Enable lxml support" off \
- REPORTLAB2 "Enable ReportLab2 support" off \
- CHARDET "Enable chardet support" off \
- PYGNOMEEXTRAS "Enable python-gnome-extras support" off
+OPTIONS_DEFINE= LXML REPORTLAB2 CHARDET PYGNOMEEXTRAS
+LXML_DESC= Enable lxml support
+REPORTLAB2_DESC= Enable ReportLab2 support
+CHARDET_DESC= Enable chardet support
+PYGNOMEEXTRAS_DESC= Enable python-gnome-extras support
USE_XZ= yes
USE_GNOME= pygtk2
@@ -38,21 +39,21 @@ MAN1= ${PORTNAME}.1
.include <bsd.port.options.mk>
-.if defined(WITH_LXML)
+.if ${PORT_OPTIONS:MLXML}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml
.endif
-.if defined(WITH_REPORTLAB2)
+.if ${PORT_OPTIONS:MREPORTLAB2}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab2>=2:${PORTSDIR}/print/py-reportlab2
.else
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab>=1.19:${PORTSDIR}/print/py-reportlab
.endif
-.if defined(WITH_CHARDET)
+.if ${PORT_OPTIONS:MCHARDET}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}chardet>=0:${PORTSDIR}/textproc/py-chardet
.endif
-.if defined(WITH_PYGNOMEEXTRAS)
+.if ${PORT_OPTIONS:MPYGNOMEEXTRAS}
USE_GNOME+= pygnomeextras
.endif