aboutsummaryrefslogtreecommitdiff
path: root/deskutils/horde4-mnemo/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-12-26 10:24:55 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-12-26 10:24:55 +0000
commitfe309f86808e2777a2d339ee9c48074bbee17af7 (patch)
tree0d09d120889a8e560d237c89d48d7e3ffec58810 /deskutils/horde4-mnemo/Makefile
parent086982b91fb4e8bc995213f02546e71345b18f59 (diff)
downloadports-fe309f86808e2777a2d339ee9c48074bbee17af7.tar.gz
ports-fe309f86808e2777a2d339ee9c48074bbee17af7.zip
Upgrade to 2.0.
The major changes compared to the Mnemo 1.x versions are: * Shared notepads. * vNote support. * Kolab server support. * Access keys.
Notes
Notes: svn path=/head/; revision=125199
Diffstat (limited to 'deskutils/horde4-mnemo/Makefile')
-rw-r--r--deskutils/horde4-mnemo/Makefile39
1 files changed, 14 insertions, 25 deletions
diff --git a/deskutils/horde4-mnemo/Makefile b/deskutils/horde4-mnemo/Makefile
index 0de63b50f4c3..de5164a4ada1 100644
--- a/deskutils/horde4-mnemo/Makefile
+++ b/deskutils/horde4-mnemo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mnemo
-PORTVERSION= 1.1.2
+PORTVERSION= 2.0
CATEGORIES= deskutils www
MASTER_SITES= ftp://ftp.horde.org/pub/mnemo/ \
ftp://ftp.planetmirror.com/pub/horde/mnemo/ \
@@ -16,36 +16,35 @@ MASTER_SITES= ftp://ftp.horde.org/pub/mnemo/ \
ftp://ftp.nl.horde.org/mirror/horde-ftp/pub/mnemo/ \
ftp://ftp.uk.horde.org/mirrors/ftp.horde.org/pub/mnemo/ \
http://ftp.horde.org/pub/mnemo/
+DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Mnemo is the Horde notes and memos application
-RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
+RUN_DEPENDS= ${LOCALBASE}/www/horde/rpc.php:${PORTSDIR}/www/horde
NO_BUILD= yes
USE_REINPLACE= yes
-REINPLACE_ARGS= -i.beforeMnemo
-
-PLIST_SUB= HORDEDIR=${LHORDEDIR} MNEMODIR=${LMNEMODIR}
+PLIST_SUB= MNEMODIR=${LMNEMODIR}
PKGMESSAGE= ${WRKDIR}/pkg-message
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL \
- docs/RELEASE_NOTES
-CONFFILE= conf.php menu.php prefs.php
-SUB_DIRS= config graphics lib locale po scripts templates util
+ docs/RELEASE_NOTES docs/TODO docs/UPGRADING
+CONFFILE= prefs.php
+SUB_DIRS= config lib locale po scripts templates themes
LHORDEDIR?= www/horde
LMNEMODIR?= ${LHORDEDIR}/mnemo
-HORDEDIR= ${PREFIX}/${LHORDEDIR}
MNEMODIR= ${PREFIX}/${LMNEMODIR}
CONFDIR= ${MNEMODIR}/config
HORDE_INC= ${LOCALBASE}/etc/horde
-post-patch:
- @${RM} ${WRKSRC}/config/conf.php.dist.orig
+pre-configure:
+ @${SED} -e "s:/home/httpd/html/horde/mnemo:${MNEMODIR}:g" \
+ ${FILESDIR}/httpd.conf.mnemo > ${WRKDIR}/httpd.conf.mnemo
do-install:
@${MKDIR} ${MNEMODIR}
@@ -58,18 +57,9 @@ do-install:
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
- @${CHOWN} -R www:www ${MNEMODIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${MNEMODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
- @${CP} -p ${FILESDIR}/httpd.conf.mnemo ${HORDE_INC}
- @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/mnemo:${MNEMODIR}:g" \
- ${HORDE_INC}/httpd.conf.mnemo
- @${RM} ${HORDE_INC}/httpd.conf.mnemo.beforeMnemo
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeMnemo
- @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTMNEMO::" \
- ${HORDEDIR}/config/registry.php
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.afterMnemo
+ @${INSTALL_DATA} ${WRKDIR}/httpd.conf.mnemo ${HORDE_INC}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@@ -79,10 +69,9 @@ do-install:
.endif
post-install:
- @${ECHO_MSG}
- @${SED} -e "s:%%MNEMODIR%%:${MNEMODIR}:g;s:%%PORTSDIR%%:${PORTSDIR}:g" \
- -e "s:%%CONFDIR%%:${CONFDIR}:g;s:%%HORDEDIR%%:${HORDEDIR}:" \
+ @${SED} -e "s:%%MNEMODIR%%:${MNEMODIR}:g;s:%%DOCSDIR%%:${DOCSDIR}:g" \
< ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}