aboutsummaryrefslogtreecommitdiff
path: root/deskutils/horde4-nag
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 03:54:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 03:54:09 +0000
commit0825d343b67d333a5eb074ffc162e99e36afd05b (patch)
treefa9e30457336a2f3f64d4b8aec724296f7285e0a /deskutils/horde4-nag
parent527b94968318c37ba67fae67811b60ad2500b11c (diff)
downloadports-0825d343b67d333a5eb074ffc162e99e36afd05b.tar.gz
ports-0825d343b67d333a5eb074ffc162e99e36afd05b.zip
${PERL} -> ${REINPLACE_CMD}
PR: 39856 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=61971
Diffstat (limited to 'deskutils/horde4-nag')
-rw-r--r--deskutils/horde4-nag/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/deskutils/horde4-nag/Makefile b/deskutils/horde4-nag/Makefile
index 2f997563f112..cbbd623abdff 100644
--- a/deskutils/horde4-nag/Makefile
+++ b/deskutils/horde4-nag/Makefile
@@ -16,8 +16,11 @@ MAINTAINER= thierry@pompo.net
RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeNag
+
PLIST_SUB= HORDEDIR=${LHORDEDIR} NAGDIR=${LNAGDIR}
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -48,11 +51,10 @@ do-install:
@${CHOWN} -R www:www ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.nag ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
${HORDE_INC}/httpd.conf.nag
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeNag
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
+ @${RM} ${HORDE_INC}/httpd.conf.nag.beforeNag
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterNag
.if !defined(NOPORTDOCS)