aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdeconnect-kde
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-02-10 21:04:35 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-02-10 21:04:35 +0000
commitb188d964ed1e2c530e63d4265309c790c2b07275 (patch)
tree213c79c24dccb54b1743e7eec028f229782f504a /deskutils/kdeconnect-kde
parentd2d9303975fbeadd4d1ffaf3a679d5b3968a2bfd (diff)
downloadports-b188d964ed1e2c530e63d4265309c790c2b07275.tar.gz
ports-b188d964ed1e2c530e63d4265309c790c2b07275.zip
deskutils/kdeconnect-kde: use security/sshpass to pass passwords to sshfs
On FreeBSD sshfs does not seem to support the "-o password_stdin" option. Work around this limitation by using security/sshpass. This should be considered a temporary work around until a better solution is found. With this fix sharing of files from the device should finally work. PR: 25303 Submitted by: Stefan Rumetshofer <sterum77@gmail.com>
Notes
Notes: svn path=/head/; revision=492644
Diffstat (limited to 'deskutils/kdeconnect-kde')
-rw-r--r--deskutils/kdeconnect-kde/Makefile5
-rw-r--r--deskutils/kdeconnect-kde/files/patch-plugins_sftp_mounter.cpp22
2 files changed, 25 insertions, 2 deletions
diff --git a/deskutils/kdeconnect-kde/Makefile b/deskutils/kdeconnect-kde/Makefile
index 8fa481339909..8f671f8b55e0 100644
--- a/deskutils/kdeconnect-kde/Makefile
+++ b/deskutils/kdeconnect-kde/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kdeconnect-kde
DISTVERSION= 1.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde
MASTER_SITES= KDE/stable/kdeconnect/${DISTVERSION}/src/
DIST_SUBDIR= KDE
@@ -15,7 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfakekey.so:x11/libfakekey \
libqca-qt5.so:devel/qca@qt5
-RUN_DEPENDS= sshfs:sysutils/fusefs-sshfs
+RUN_DEPENDS= sshpass:security/sshpass \
+ sshfs:sysutils/fusefs-sshfs
CONFLICTS_INSTALL= kdeconnect-kde-0.7* kdeconnect-kde-kde4-0.7.*
diff --git a/deskutils/kdeconnect-kde/files/patch-plugins_sftp_mounter.cpp b/deskutils/kdeconnect-kde/files/patch-plugins_sftp_mounter.cpp
new file mode 100644
index 000000000000..1ac476bcabf2
--- /dev/null
+++ b/deskutils/kdeconnect-kde/files/patch-plugins_sftp_mounter.cpp
@@ -0,0 +1,22 @@
+--- plugins/sftp/mounter.cpp.orig 2018-11-06 14:32:08.000000000 +0100
++++ plugins/sftp/mounter.cpp 2019-01-29 18:43:47.324002000 +0100
+@@ -139,7 +139,7 @@
+ << QStringLiteral("-o") << QStringLiteral("gid=") + QString::number(getgid())
+ << QStringLiteral("-o") << QStringLiteral("reconnect")
+ << QStringLiteral("-o") << QStringLiteral("ServerAliveInterval=30")
+- << QStringLiteral("-o") << QStringLiteral("password_stdin")
++ << QStringLiteral("-o") << QStringLiteral("ssh_command=sshpass -p ") + np.get<QString>("password").toLatin1() + (" ssh")
+ ;
+
+ m_proc->setProgram(program, arguments);
+@@ -148,8 +148,8 @@
+ m_proc->start();
+
+ //qCDebug(KDECONNECT_PLUGIN_SFTP) << "Passing password: " << np.get<QString>("password").toLatin1();
+- m_proc->write(np.get<QString>(QStringLiteral("password")).toLatin1());
+- m_proc->write("\n");
++ //m_proc->write(np.get<QString>(QStringLiteral("password")).toLatin1());
++ // m_proc->write("\n");
+
+ }
+