aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdeplasma-addons
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 18:28:10 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 18:28:10 +0000
commit0d0c38abda42953116077041374621f29398bca1 (patch)
treef84adaddc0b7a4395bdc34d83a623d5052d2e8b9 /deskutils/kdeplasma-addons
parentb4f16ddf9e841edbd8aa8e09adc1c959e5cf6f7d (diff)
downloadports-0d0c38abda42953116077041374621f29398bca1.tar.gz
ports-0d0c38abda42953116077041374621f29398bca1.zip
In preparation for making libtool generate libraries with a sane name, fix all
LIB_DEPENDS in deskutils
Notes
Notes: svn path=/head/; revision=336190
Diffstat (limited to 'deskutils/kdeplasma-addons')
-rw-r--r--deskutils/kdeplasma-addons/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/deskutils/kdeplasma-addons/Makefile b/deskutils/kdeplasma-addons/Makefile
index 4702122b32c9..13cae96a5365 100644
--- a/deskutils/kdeplasma-addons/Makefile
+++ b/deskutils/kdeplasma-addons/Makefile
@@ -11,11 +11,11 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Extra plasmoids for KDE SC 4
-LIB_DEPENDS= qalculate.5:${PORTSDIR}/math/libqalculate \
- qwt.5:${PORTSDIR}/x11-toolkits/qwt5 \
- qca.2:${PORTSDIR}/devel/qca \
- qoauth.1:${PORTSDIR}/net/qoauth \
- qjson.0:${PORTSDIR}/devel/qjson
+LIB_DEPENDS= libqalculate.so:${PORTSDIR}/math/libqalculate \
+ libqwt.so:${PORTSDIR}/x11-toolkits/qwt5 \
+ libqca.so:${PORTSDIR}/devel/qca \
+ libqoauth.so:${PORTSDIR}/net/qoauth \
+ libqjson.so:${PORTSDIR}/devel/qjson
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
@@ -50,7 +50,7 @@ PLIST_SUB+= MARBLE="@comment "
.if ${PORT_OPTIONS:MIBUS}
IGNORE= requires ibus version 1.4.2 or greater
-LIB_DEPENDS+= ibus-1.0:${PORTSDIR}/textproc/ibus
+LIB_DEPENDS+= libibus-1.0.so:${PORTSDIR}/textproc/ibus
PLIST_SUB+= IBUS=""
.else
CMAKE_ARGS+= -DBUILD_ibus=off
@@ -58,7 +58,7 @@ PLIST_SUB+= IBUS="@comment "
.endif
.if ${PORT_OPTIONS:MSCIM}
-LIB_DEPENDS+= scim-1.0.10:${PORTSDIR}/textproc/scim
+LIB_DEPENDS+= libscim-1.0.so:${PORTSDIR}/textproc/scim
PLIST_SUB+= SCIM=""
.else
CMAKE_ARGS+= -DBUILD_scim=off