aboutsummaryrefslogtreecommitdiff
path: root/deskutils/knotes
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:31:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:31:53 +0000
commitb23d58fb6208b7ce383fc02b29883825567dd2a7 (patch)
tree7dd8d38fba0f783f52046ed64480422275947e61 /deskutils/knotes
parent6b76837295efce053cfb7540bd720c9665d24aca (diff)
downloadports-b23d58fb6208b7ce383fc02b29883825567dd2a7.tar.gz
ports-b23d58fb6208b7ce383fc02b29883825567dd2a7.zip
New ports: KDE Applications deskutils/
* deskutils/akonadi-calendar-tools * deskutils/akonadi-import-wizard * deskutils/akonadiconsole * deskutils/akregator * deskutils/grantlee-editor * deskutils/kaddressbook * deskutils/kalarm * deskutils/kcharselect * deskutils/kdepim-addons * deskutils/kdepim-runtime * deskutils/keditbookmarks * deskutils/kfind * deskutils/kmail * deskutils/kmail-account-wizard * deskutils/knotes * deskutils/kontact * deskutils/korganizer * deskutils/kruler * deskutils/mbox-importer * deskutils/pim-data-exporter * deskutils/pim-sieve-editor This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4. This adds a slew of KDE Pim related ports and some of their dependencies. Note, that KDE Pim has a history of working poorly on FreeBSD.
Notes
Notes: svn path=/head/; revision=467009
Diffstat (limited to 'deskutils/knotes')
-rw-r--r--deskutils/knotes/Makefile33
-rw-r--r--deskutils/knotes/distinfo3
-rw-r--r--deskutils/knotes/files/patch-fix_protected_signal_call21
-rw-r--r--deskutils/knotes/pkg-plist174
4 files changed, 231 insertions, 0 deletions
diff --git a/deskutils/knotes/Makefile b/deskutils/knotes/Makefile
new file mode 100644
index 000000000000..dbcd42c2d82a
--- /dev/null
+++ b/deskutils/knotes/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= knotes
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= deskutils kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Popup notes
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libical.so:devel/libical
+
+USES= cmake:outsource compiler:c++11-lib gettext grantlee:5 kde:5 tar:xz
+USE_KDE= attica auth bookmarks codecs completion config configwidgets \
+ coreaddons crash dbusaddons dnssd globalaccel guiaddons i18n \
+ iconthemes itemmodels itemviews jobwidgets kcmutils \
+ kdelibs4support kio newstuff notifications notifyconfig parts \
+ service solid sonnet textwidgets unitconversion widgetsaddons \
+ windowsystem xmlgui
+# pim components
+USE_KDE+= akonadi akonadicontacts akonadinotes akonadisearch \
+ calendarcore calendarutils contacts kontactinterface libkdepim \
+ mime pimcommon pimtextedit
+USE_QT5= core dbus gui network printsupport widgets x11extras xml \
+ buildtools_build qmake_build
+USE_XORG= ice sm x11 xext
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+
+.include <bsd.port.mk>
diff --git a/deskutils/knotes/distinfo b/deskutils/knotes/distinfo
new file mode 100644
index 000000000000..a6f255f91b6a
--- /dev/null
+++ b/deskutils/knotes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519274
+SHA256 (KDE/applications/17.12.3/knotes-17.12.3.tar.xz) = a3226766e0972abc7ef4a303ce306d353aa9145638639ebbcf4f1e4861cdc6c7
+SIZE (KDE/applications/17.12.3/knotes-17.12.3.tar.xz) = 335744
diff --git a/deskutils/knotes/files/patch-fix_protected_signal_call b/deskutils/knotes/files/patch-fix_protected_signal_call
new file mode 100644
index 000000000000..9bc29184f52b
--- /dev/null
+++ b/deskutils/knotes/files/patch-fix_protected_signal_call
@@ -0,0 +1,21 @@
+https://www.mail-archive.com/release-team@kde.org/msg10606.html
+
+--- src/configdialog/knoteconfigdialog.cpp.omv~ 2017-12-02 20:35:45.818678460 +0100
++++ src/configdialog/knoteconfigdialog.cpp 2017-12-02 20:36:11.846720640 +0100
+@@ -210,7 +210,7 @@ KNoteMiscConfig::KNoteMiscConfig(QWidget
+ howItWorks->setContextMenuPolicy(Qt::NoContextMenu);
+ lay->addStretch();
+ load();
+- connect(mDefaultTitle, &QLineEdit::textChanged, this, QOverload<>::of(&KCModule::changed));
++ connect(mDefaultTitle, &QLineEdit::textChanged, this, QOverload<>::of(&KNoteMiscConfig::changed));
+ }
+
+ void KNoteMiscConfig::load()
+@@ -317,7 +317,7 @@ KNoteCollectionConfig::KNoteCollectionCo
+ QHBoxLayout *lay = new QHBoxLayout(this);
+ mCollectionConfigWidget = new KNoteCollectionConfigWidget;
+ lay->addWidget(mCollectionConfigWidget);
+- connect(mCollectionConfigWidget, &KNoteCollectionConfigWidget::emitChanged, this, QOverload<>::of(&KCModule::changed));
++ connect(mCollectionConfigWidget, &KNoteCollectionConfigWidget::emitChanged, this, QOverload<>::of(&KNoteCollectionConfig::changed));
+ load();
+ }
diff --git a/deskutils/knotes/pkg-plist b/deskutils/knotes/pkg-plist
new file mode 100644
index 000000000000..49ef6bfa6f62
--- /dev/null
+++ b/deskutils/knotes/pkg-plist
@@ -0,0 +1,174 @@
+bin/akonadi_notes_agent
+bin/knotes
+etc/xdg/knotes.categories
+etc/xdg/knotes.renamecategories
+etc/xdg/knotes_printing_theme.knsrc
+lib/libknotesprivate.so.5
+lib/libknotesprivate.so.%%KDE_APPLICATIONS_SHLIB_VER%%
+lib/libnotesharedprivate.so.5
+lib/libnotesharedprivate.so.%%KDE_APPLICATIONS_SHLIB_VER%%
+%%QT_PLUGINDIR%%/kcm_knote.so
+%%QT_PLUGINDIR%%/kcm_knotessummary.so
+%%QT_PLUGINDIR%%/kontact_knotesplugin.so
+share/akonadi/agents/notesagent.desktop
+share/applications/org.kde.knotes.desktop
+share/config.kcfg/knotesglobalconfig.kcfg
+share/config.kcfg/notesagentsettings.kcfg
+share/dbus-1/interfaces/org.kde.KNotes.xml
+share/dbus-1/interfaces/org.kde.kontact.KNotes.xml
+share/icons/hicolor/128x128/apps/knotes.png
+share/icons/hicolor/16x16/actions/knotes_alarm.png
+share/icons/hicolor/16x16/actions/knotes_close.png
+share/icons/hicolor/16x16/actions/knotes_date.png
+share/icons/hicolor/16x16/actions/knotes_delete.png
+share/icons/hicolor/16x16/apps/knotes.png
+share/icons/hicolor/22x22/apps/knotes.png
+share/icons/hicolor/32x32/apps/knotes.png
+share/icons/hicolor/48x48/apps/knotes.png
+share/icons/hicolor/64x64/apps/knotes.png
+share/kconf_update/knotes-15.08-kickoff.sh
+share/kconf_update/knotes.upd
+%%DATADIR%%/print/themes/background-color/theme.desktop
+%%DATADIR%%/print/themes/background-color/theme.html
+%%DATADIR%%/print/themes/big-title/theme.desktop
+%%DATADIR%%/print/themes/big-title/theme.html
+%%DATADIR%%/print/themes/default/theme.desktop
+%%DATADIR%%/print/themes/default/theme.html
+share/knotifications5/akonadi_notes_agent.notifyrc
+share/kontact/ksettingsdialog/knotes.setdlg
+share/kservices5/kcmknotessummary.desktop
+share/kservices5/knote_config_action.desktop
+share/kservices5/knote_config_collection.desktop
+share/kservices5/knote_config_display.desktop
+share/kservices5/knote_config_editor.desktop
+share/kservices5/knote_config_misc.desktop
+share/kservices5/knote_config_network.desktop
+share/kservices5/knote_config_print.desktop
+share/kservices5/kontact/knotesplugin.desktop
+share/kxmlgui5/knotes/knotes_part.rc
+share/kxmlgui5/knotes/knotesappui.rc
+share/kxmlgui5/knotes/knotesui.rc
+share/locale/ar/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/ar/LC_MESSAGES/knotes.mo
+share/locale/ast/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/ast/LC_MESSAGES/knotes.mo
+share/locale/ast/LC_MESSAGES/libnoteshared.mo
+share/locale/bg/LC_MESSAGES/knotes.mo
+share/locale/bs/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/bs/LC_MESSAGES/knotes.mo
+share/locale/bs/LC_MESSAGES/libnoteshared.mo
+share/locale/ca/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/ca/LC_MESSAGES/knotes.mo
+share/locale/ca/LC_MESSAGES/libnoteshared.mo
+share/locale/ca@valencia/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/ca@valencia/LC_MESSAGES/knotes.mo
+share/locale/ca@valencia/LC_MESSAGES/libnoteshared.mo
+share/locale/cs/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/cs/LC_MESSAGES/knotes.mo
+share/locale/cs/LC_MESSAGES/libnoteshared.mo
+share/locale/da/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/da/LC_MESSAGES/knotes.mo
+share/locale/da/LC_MESSAGES/libnoteshared.mo
+share/locale/de/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/de/LC_MESSAGES/knotes.mo
+share/locale/de/LC_MESSAGES/libnoteshared.mo
+share/locale/el/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/el/LC_MESSAGES/knotes.mo
+share/locale/en_GB/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/en_GB/LC_MESSAGES/knotes.mo
+share/locale/en_GB/LC_MESSAGES/libnoteshared.mo
+share/locale/eo/LC_MESSAGES/knotes.mo
+share/locale/es/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/es/LC_MESSAGES/knotes.mo
+share/locale/es/LC_MESSAGES/libnoteshared.mo
+share/locale/et/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/et/LC_MESSAGES/knotes.mo
+share/locale/et/LC_MESSAGES/libnoteshared.mo
+share/locale/eu/LC_MESSAGES/knotes.mo
+share/locale/fa/LC_MESSAGES/knotes.mo
+share/locale/fi/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/fi/LC_MESSAGES/knotes.mo
+share/locale/fi/LC_MESSAGES/libnoteshared.mo
+share/locale/fr/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/fr/LC_MESSAGES/knotes.mo
+share/locale/fr/LC_MESSAGES/libnoteshared.mo
+share/locale/ga/LC_MESSAGES/knotes.mo
+share/locale/gl/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/gl/LC_MESSAGES/knotes.mo
+share/locale/gl/LC_MESSAGES/libnoteshared.mo
+share/locale/he/LC_MESSAGES/knotes.mo
+share/locale/hi/LC_MESSAGES/knotes.mo
+share/locale/hr/LC_MESSAGES/knotes.mo
+share/locale/hu/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/hu/LC_MESSAGES/knotes.mo
+share/locale/hu/LC_MESSAGES/libnoteshared.mo
+share/locale/ia/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/ia/LC_MESSAGES/knotes.mo
+share/locale/ia/LC_MESSAGES/libnoteshared.mo
+share/locale/is/LC_MESSAGES/knotes.mo
+share/locale/it/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/it/LC_MESSAGES/knotes.mo
+share/locale/it/LC_MESSAGES/libnoteshared.mo
+share/locale/ja/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/ja/LC_MESSAGES/knotes.mo
+share/locale/ja/LC_MESSAGES/libnoteshared.mo
+share/locale/kk/LC_MESSAGES/knotes.mo
+share/locale/km/LC_MESSAGES/knotes.mo
+share/locale/ko/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/ko/LC_MESSAGES/knotes.mo
+share/locale/ko/LC_MESSAGES/libnoteshared.mo
+share/locale/lt/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/lt/LC_MESSAGES/knotes.mo
+share/locale/lt/LC_MESSAGES/libnoteshared.mo
+share/locale/lv/LC_MESSAGES/knotes.mo
+share/locale/mr/LC_MESSAGES/knotes.mo
+share/locale/nb/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/nb/LC_MESSAGES/knotes.mo
+share/locale/nb/LC_MESSAGES/libnoteshared.mo
+share/locale/nds/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/nds/LC_MESSAGES/knotes.mo
+share/locale/nds/LC_MESSAGES/libnoteshared.mo
+share/locale/nl/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/nl/LC_MESSAGES/knotes.mo
+share/locale/nl/LC_MESSAGES/libnoteshared.mo
+share/locale/nn/LC_MESSAGES/knotes.mo
+share/locale/pa/LC_MESSAGES/knotes.mo
+share/locale/pl/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/pl/LC_MESSAGES/knotes.mo
+share/locale/pl/LC_MESSAGES/libnoteshared.mo
+share/locale/pt/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/pt/LC_MESSAGES/knotes.mo
+share/locale/pt/LC_MESSAGES/libnoteshared.mo
+share/locale/pt_BR/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/pt_BR/LC_MESSAGES/knotes.mo
+share/locale/pt_BR/LC_MESSAGES/libnoteshared.mo
+share/locale/ro/LC_MESSAGES/knotes.mo
+share/locale/ro/LC_MESSAGES/libnoteshared.mo
+share/locale/ru/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/ru/LC_MESSAGES/knotes.mo
+share/locale/ru/LC_MESSAGES/libnoteshared.mo
+share/locale/sk/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/sk/LC_MESSAGES/knotes.mo
+share/locale/sk/LC_MESSAGES/libnoteshared.mo
+share/locale/sl/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/sl/LC_MESSAGES/knotes.mo
+share/locale/sl/LC_MESSAGES/libnoteshared.mo
+share/locale/sr/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/sr/LC_MESSAGES/libnoteshared.mo
+share/locale/sv/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/sv/LC_MESSAGES/knotes.mo
+share/locale/sv/LC_MESSAGES/libnoteshared.mo
+share/locale/tr/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/tr/LC_MESSAGES/knotes.mo
+share/locale/tr/LC_MESSAGES/libnoteshared.mo
+share/locale/ug/LC_MESSAGES/knotes.mo
+share/locale/uk/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/uk/LC_MESSAGES/knotes.mo
+share/locale/uk/LC_MESSAGES/libnoteshared.mo
+share/locale/zh_CN/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/zh_CN/LC_MESSAGES/knotes.mo
+share/locale/zh_CN/LC_MESSAGES/libnoteshared.mo
+share/locale/zh_TW/LC_MESSAGES/akonadi_notes_agent.mo
+share/locale/zh_TW/LC_MESSAGES/knotes.mo
+share/locale/zh_TW/LC_MESSAGES/libnoteshared.mo
+share/metainfo/org.kde.knotes.appdata.xml