aboutsummaryrefslogtreecommitdiff
path: root/deskutils/launchy
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-12-24 08:57:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-12-24 08:57:51 +0000
commitb5207853941e62d91d09c4a2ce4d72aee26b61de (patch)
tree2e431c3be18fbd3634141de4b1f0093b558ca873 /deskutils/launchy
parent802a91006f6e2a01aec52244eb30b4cbda988868 (diff)
downloadports-b5207853941e62d91d09c4a2ce4d72aee26b61de.tar.gz
ports-b5207853941e62d91d09c4a2ce4d72aee26b61de.zip
- Add missing run-time dependency on xdg-open
- Switch to GNU make to avoid rebuild of things upon installation - Propagate correct PREFIX value Reported by: daichi, QAT
Notes
Notes: svn path=/head/; revision=224678
Diffstat (limited to 'deskutils/launchy')
-rw-r--r--deskutils/launchy/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/deskutils/launchy/Makefile b/deskutils/launchy/Makefile
index 1c649e9ac369..a1c29c0b9cb8 100644
--- a/deskutils/launchy/Makefile
+++ b/deskutils/launchy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= launchy
PORTVERSION= 2.1.2
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= SF
@@ -14,15 +15,21 @@ MAINTAINER= danfe@FreeBSD.org
COMMENT= Access applications, files, and bookmarks with just a few keystrokes
BUILD_DEPENDS= ${LOCALBASE}/include/boost/spirit/core.hpp:${PORTSDIR}/devel/boost
+RUN_DEPENDS= ${LOCALBASE}/bin/xdg-open:${PORTSDIR}/devel/xdg-utils
USE_DOS2UNIX= readme.lyx readme.txt
+USE_GMAKE= yes
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build uic_build gui network
MAKEFILE= makefile
ALL_TARGET= release
+MAKE_ARGS= PREFIX="${PREFIX}"
PORTDOCS= *
+post-patch:
+ @${REINPLACE_CMD} 's,make ,g&,' ${WRKSRC}/${MAKEFILE}
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}