aboutsummaryrefslogtreecommitdiff
path: root/deskutils/logjam
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-09-13 14:36:40 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-09-13 14:36:40 +0000
commit71a499b0faa9245d24d130caf710259fa7886301 (patch)
tree6f3c747e1c9f91ac37be9c6af986aa6097b8d640 /deskutils/logjam
parent59d8592164cf460a2f319af54dfd95e75fd8a50f (diff)
downloadports-71a499b0faa9245d24d130caf710259fa7886301.tar.gz
ports-71a499b0faa9245d24d130caf710259fa7886301.zip
Convert to option framework
Use options helpers Remove usage of HAVE_GNOME
Notes
Notes: svn path=/head/; revision=396829
Diffstat (limited to 'deskutils/logjam')
-rw-r--r--deskutils/logjam/Makefile58
-rw-r--r--deskutils/logjam/pkg-plist2
2 files changed, 22 insertions, 38 deletions
diff --git a/deskutils/logjam/Makefile b/deskutils/logjam/Makefile
index 09c922bfd07b..67693aaac937 100644
--- a/deskutils/logjam/Makefile
+++ b/deskutils/logjam/Makefile
@@ -13,55 +13,39 @@ COMMENT= GTK2 interface to livejournals, ie www.livejournal.com
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
+OPTIONS_DEFINE= GTKSPELL SQLITE XMMS GTKHTML RSVG
+OPTIONS_DEFAULT= GTKSPELL
+OPTIONS_SUB= yes
+
+GTKSPELL_DESC= Support spell checking
+GTKHTML_DESC= Support rendering HTML
+RSVG_DESC= Support rendering SVG
+SQLITE_DESC= Use sqlite3 as a backend
+XMMS_DESC= Enable XMMS music detection
+
USES= gettext gmake pathfix pkgconfig tar:bzip2
-WANT_GNOME= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gtk20 libxml2 intlhack
CONFIGURE_ARGS= --program-transform-name="s/$$//"
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-.ifndef(WITHOUT_GTKSPELL)
-LIB_DEPENDS+= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
-.else
-CONFIGURE_ARGS+= --without-gtkspell
-.endif
-
-.if defined(WITH_SQLITE)
-CONFIGURE_ARGS+= --with-sqlite3
-LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite3
-.endif
-
-.if defined(WITH_XMMS)
-LIB_DEPENDS+= libxmms.so:${PORTSDIR}/multimedia/xmms
-PLIST_SUB+= WITH_XMMS=""
-.else
-PLIST_SUB+= WITH_XMMS="@comment "
-CONFIGURE_ARGS+= --without-xmms
-.endif
+GTKSPELL_LIB_DEPENDS= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
+GTKSPELL_CONFIGURE_WITH= gtkspell
-.include <bsd.port.pre.mk>
+SQLITE_CONFIGURE_WITH= sqlite3
+SQLITE_LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
-.if ${HAVE_GNOME:Mgtkhtml3}!=""
-USE_GNOME+= gtkhtml3
-.else
-CONFIGURE_ARGS+= --without-gtkhtml
-.endif
+XMMS_LIB_DEPENDS= libxmms.so:${PORTSDIR}/multimedia/xmms
+XMMS_CONFIGURE_WITH= xmms
-.if ${HAVE_GNOME:Mlibrsvg2}!=""
-USE_GNOME+= librsvg2
-.else
-CONFIGURE_ARGS+= --without-librsvg
-.endif
+GTKHTML_USE= GNOME=gtkhtml3
+GTKHTML_CONFIGURE_WITH= gtkhtml
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "logjam has the following tunable option(s):"
- @${ECHO_MSG} " WITHOUT_GTKSPELL Disable spell checking"
- @${ECHO_MSG} " WITH_XMMS Enable XMMS music detection"
- @${ECHO_MSG} ""
+RSVG_USE= GNOME=librsvg2
+RSVG_CONFIGURE_WITH= librsvg
post-patch:
@${REINPLACE_CMD} -e 's|libgtkhtml-3.0|libgtkhtml-3.18|g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/logjam/pkg-plist b/deskutils/logjam/pkg-plist
index 0e6f26427a2a..2393bbd255a5 100644
--- a/deskutils/logjam/pkg-plist
+++ b/deskutils/logjam/pkg-plist
@@ -1,6 +1,6 @@
bin/logjam
man/man1/logjam.1.gz
-%%WITH_XMMS%%bin/logjam-xmms-client
+%%XMMS%%bin/logjam-xmms-client
share/applications/logjam.desktop
share/pixmaps/logjam_goat.png
share/pixmaps/logjam_pencil.png