aboutsummaryrefslogtreecommitdiff
path: root/deskutils/mbox-importer
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:31:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:31:53 +0000
commitb23d58fb6208b7ce383fc02b29883825567dd2a7 (patch)
tree7dd8d38fba0f783f52046ed64480422275947e61 /deskutils/mbox-importer
parent6b76837295efce053cfb7540bd720c9665d24aca (diff)
downloadports-b23d58fb6208b7ce383fc02b29883825567dd2a7.tar.gz
ports-b23d58fb6208b7ce383fc02b29883825567dd2a7.zip
New ports: KDE Applications deskutils/
* deskutils/akonadi-calendar-tools * deskutils/akonadi-import-wizard * deskutils/akonadiconsole * deskutils/akregator * deskutils/grantlee-editor * deskutils/kaddressbook * deskutils/kalarm * deskutils/kcharselect * deskutils/kdepim-addons * deskutils/kdepim-runtime * deskutils/keditbookmarks * deskutils/kfind * deskutils/kmail * deskutils/kmail-account-wizard * deskutils/knotes * deskutils/kontact * deskutils/korganizer * deskutils/kruler * deskutils/mbox-importer * deskutils/pim-data-exporter * deskutils/pim-sieve-editor This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4. This adds a slew of KDE Pim related ports and some of their dependencies. Note, that KDE Pim has a history of working poorly on FreeBSD.
Notes
Notes: svn path=/head/; revision=467009
Diffstat (limited to 'deskutils/mbox-importer')
-rw-r--r--deskutils/mbox-importer/Makefile29
-rw-r--r--deskutils/mbox-importer/distinfo3
-rw-r--r--deskutils/mbox-importer/pkg-plist40
3 files changed, 72 insertions, 0 deletions
diff --git a/deskutils/mbox-importer/Makefile b/deskutils/mbox-importer/Makefile
new file mode 100644
index 000000000000..a389e3f8b012
--- /dev/null
+++ b/deskutils/mbox-importer/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= mbox-importer
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= deskutils kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Import mbox files to KMail
+
+LIB_DEPENDS= libassuan.so:security/libassuan \
+ libgpg-error.so:security/libgpg-error \
+ libgpgme.so:security/gpgme \
+ libgpgmepp.so:security/gpgme-cpp \
+ libqgpgme.so:security/gpgme-qt5
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= archive auth codecs completion config configwidgets coreaddons \
+ crash ecm i18n itemmodels kio service widgetsaddons
+# pim components
+USE_KDE+= akonadi akonadicontacts akonadimime contacts \
+ identitymanagement libkleo mailcommon mailimporter messagelib \
+ mime pimcommon pimtextedit
+USE_QT5= core gui network widgets xml \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/deskutils/mbox-importer/distinfo b/deskutils/mbox-importer/distinfo
new file mode 100644
index 000000000000..e469bb426617
--- /dev/null
+++ b/deskutils/mbox-importer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519272
+SHA256 (KDE/applications/17.12.3/mbox-importer-17.12.3.tar.xz) = 371b41801145203deb329ed78699efce6084506d917cf9b2e8332428f193f399
+SIZE (KDE/applications/17.12.3/mbox-importer-17.12.3.tar.xz) = 32868
diff --git a/deskutils/mbox-importer/pkg-plist b/deskutils/mbox-importer/pkg-plist
new file mode 100644
index 000000000000..0e319655a96e
--- /dev/null
+++ b/deskutils/mbox-importer/pkg-plist
@@ -0,0 +1,40 @@
+bin/mboximporter
+share/applications/org.kde.mboximporter.desktop
+share/locale/ast/LC_MESSAGES/mboximporter.mo
+share/locale/bg/LC_MESSAGES/mboximporter.mo
+share/locale/bs/LC_MESSAGES/mboximporter.mo
+share/locale/ca/LC_MESSAGES/mboximporter.mo
+share/locale/ca@valencia/LC_MESSAGES/mboximporter.mo
+share/locale/cs/LC_MESSAGES/mboximporter.mo
+share/locale/da/LC_MESSAGES/mboximporter.mo
+share/locale/de/LC_MESSAGES/mboximporter.mo
+share/locale/en_GB/LC_MESSAGES/mboximporter.mo
+share/locale/es/LC_MESSAGES/mboximporter.mo
+share/locale/et/LC_MESSAGES/mboximporter.mo
+share/locale/fi/LC_MESSAGES/mboximporter.mo
+share/locale/fr/LC_MESSAGES/mboximporter.mo
+share/locale/gl/LC_MESSAGES/mboximporter.mo
+share/locale/hu/LC_MESSAGES/mboximporter.mo
+share/locale/ia/LC_MESSAGES/mboximporter.mo
+share/locale/it/LC_MESSAGES/mboximporter.mo
+share/locale/ja/LC_MESSAGES/mboximporter.mo
+share/locale/kk/LC_MESSAGES/mboximporter.mo
+share/locale/ko/LC_MESSAGES/mboximporter.mo
+share/locale/lt/LC_MESSAGES/mboximporter.mo
+share/locale/nb/LC_MESSAGES/mboximporter.mo
+share/locale/nds/LC_MESSAGES/mboximporter.mo
+share/locale/nl/LC_MESSAGES/mboximporter.mo
+share/locale/pl/LC_MESSAGES/mboximporter.mo
+share/locale/pt/LC_MESSAGES/mboximporter.mo
+share/locale/pt_BR/LC_MESSAGES/mboximporter.mo
+share/locale/ro/LC_MESSAGES/mboximporter.mo
+share/locale/ru/LC_MESSAGES/mboximporter.mo
+share/locale/sk/LC_MESSAGES/mboximporter.mo
+share/locale/sl/LC_MESSAGES/mboximporter.mo
+share/locale/sr/LC_MESSAGES/mboximporter.mo
+share/locale/sv/LC_MESSAGES/mboximporter.mo
+share/locale/tr/LC_MESSAGES/mboximporter.mo
+share/locale/ug/LC_MESSAGES/mboximporter.mo
+share/locale/uk/LC_MESSAGES/mboximporter.mo
+share/locale/zh_CN/LC_MESSAGES/mboximporter.mo
+share/locale/zh_TW/LC_MESSAGES/mboximporter.mo