aboutsummaryrefslogtreecommitdiff
path: root/deskutils/noti/Makefile
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-07-15 10:11:37 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-07-15 10:11:37 +0000
commitfcc278aeea242bfc0cf9e5349c68ae261a8f3c61 (patch)
tree2efb169944af89307a95ae760fec3ef955e225e2 /deskutils/noti/Makefile
parente13712ddefbadec1f6232d810f6b624a52ed51a5 (diff)
downloadports-fcc278aeea242bfc0cf9e5349c68ae261a8f3c61.tar.gz
ports-fcc278aeea242bfc0cf9e5349c68ae261a8f3c61.zip
deskutils/noti: Update to 3.2.0
* Switch to GO modules-aware build mode as the port uses various modules. Changelog: Added: * Support for Mattermost. * Support for Slack App URL. * Support for pollPID for BSD and Windows. Removed: * Installation by go get, can revisit in Go 1.14. Fixed: * Incorrect deprecation mapping. https://github.com/variadico/noti/releases/tag/3.2.0 PR: 238842 Submitted by: Hiroki Tagato <tagattie@yandex.com> (maintainer) Reviewed by: danfe
Notes
Notes: svn path=/head/; revision=506654
Diffstat (limited to 'deskutils/noti/Makefile')
-rw-r--r--deskutils/noti/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/deskutils/noti/Makefile b/deskutils/noti/Makefile
index f8ae73095150..261637ea26c9 100644
--- a/deskutils/noti/Makefile
+++ b/deskutils/noti/Makefile
@@ -1,8 +1,7 @@
-# Created by: Hiroki Tagato <tagattie@yandex.com>
# $FreeBSD$
PORTNAME= noti
-DISTVERSION= 3.1.0
+DISTVERSION= 3.2.0
CATEGORIES= deskutils
MAINTAINER= tagattie@yandex.com
@@ -13,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= notify-send:devel/libnotify
-USES= go
+USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= variadico
@@ -25,7 +24,7 @@ PLIST_FILES= bin/noti man/man1/noti.1.gz man/man5/noti.yaml.5.gz
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/bin/noti ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${DISTVERSION}/docs/man/noti.1 ${STAGEDIR}${PREFIX}/man/man1/noti.1
- ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${DISTVERSION}/docs/man/noti.yaml.5 ${STAGEDIR}${PREFIX}/man/man5/noti.yaml.5
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/noti.1 ${STAGEDIR}${MANPREFIX}/man/man1/noti.1
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/noti.yaml.5 ${STAGEDIR}${MANPREFIX}/man/man5/noti.yaml.5
.include <bsd.port.mk>