aboutsummaryrefslogtreecommitdiff
path: root/deskutils/openproj
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-04-15 08:54:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-04-15 08:54:28 +0000
commit3006ce6ae36ef6d967cad9c28b2efdf32758fc40 (patch)
tree4b00ffde8ee6ac180a87689bca8ea1f1079cd1c1 /deskutils/openproj
parent65361e4c1513ab57c43231260ef165189822c157 (diff)
downloadports-3006ce6ae36ef6d967cad9c28b2efdf32758fc40.tar.gz
ports-3006ce6ae36ef6d967cad9c28b2efdf32758fc40.zip
OpenProj is a free, open source desktop alternative to Microsoft Project.
OpenProj has equivalent functionality, a familiar user interface and even opens existing MSProject files. OpenProj is interoperable with Project, with a Gantt Chart and PERT chart etc. Licensed under Common Public Attribution License Version 1.0 (CPAL). WWW: http://openproj.org/
Notes
Notes: svn path=/head/; revision=211294
Diffstat (limited to 'deskutils/openproj')
-rw-r--r--deskutils/openproj/Makefile33
-rw-r--r--deskutils/openproj/distinfo3
-rw-r--r--deskutils/openproj/files/openproj.sh.in11
-rw-r--r--deskutils/openproj/pkg-descr8
-rw-r--r--deskutils/openproj/pkg-plist27
5 files changed, 82 insertions, 0 deletions
diff --git a/deskutils/openproj/Makefile b/deskutils/openproj/Makefile
new file mode 100644
index 000000000000..7756f7de713a
--- /dev/null
+++ b/deskutils/openproj/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: openproj
+# Date created: 15 Apr 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= openproj
+PORTVERSION= 1.0
+CATEGORIES= deskutils editors java
+MASTER_SITES= SF
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= A free, open source Project Manager
+
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}-${PORTVERSION}
+DATAFILES= lib license openproj.jar readme.txt
+
+SUB_FILES= openproj.sh
+
+do-install:
+ cd ${WRKSRC} \
+ && ${FIND} ${DATAFILES} -type d -exec ${MKDIR} ${DATADIR}/{} \; \
+ && ${FIND} ${DATAFILES} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+ ${INSTALL_SCRIPT} ${WRKDIR}/openproj.sh ${PREFIX}/bin/openproj
+
+.include <bsd.port.mk>
diff --git a/deskutils/openproj/distinfo b/deskutils/openproj/distinfo
new file mode 100644
index 000000000000..bf17bc03299a
--- /dev/null
+++ b/deskutils/openproj/distinfo
@@ -0,0 +1,3 @@
+MD5 (openproj-1.0.tar.gz) = e763d8479c0db357cd24b15ecc7c11f1
+SHA256 (openproj-1.0.tar.gz) = 9d86af7609e33e324637e6597730b51d966ff2e9cc0c311c2a01ced659703a70
+SIZE (openproj-1.0.tar.gz) = 6186801
diff --git a/deskutils/openproj/files/openproj.sh.in b/deskutils/openproj/files/openproj.sh.in
new file mode 100644
index 000000000000..98f5a3b5dd0b
--- /dev/null
+++ b/deskutils/openproj/files/openproj.sh.in
@@ -0,0 +1,11 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/deskutils/openproj/files/openproj.sh.in,v 1.1 2008-04-15 08:54:28 dinoex Exp $
+
+FILE="`realpath "$1"`"
+OPENPROJ_HOME="%%DATADIR%%"
+export OPENPROJ_HOME
+cd "%%DATADIR%%"
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "$OPENPROJ_HOME/openproj.jar" "${FILE}" > /dev/null 2>&1
+
+# eof
diff --git a/deskutils/openproj/pkg-descr b/deskutils/openproj/pkg-descr
new file mode 100644
index 000000000000..422d3869281d
--- /dev/null
+++ b/deskutils/openproj/pkg-descr
@@ -0,0 +1,8 @@
+OpenProj is a free, open source desktop alternative to Microsoft Project.
+OpenProj has equivalent functionality, a familiar user interface and even
+opens existing MSProject files. OpenProj is interoperable with Project,
+with a Gantt Chart and PERT chart etc.
+
+Licensed under Common Public Attribution License Version 1.0 (CPAL).
+
+WWW: http://openproj.org/
diff --git a/deskutils/openproj/pkg-plist b/deskutils/openproj/pkg-plist
new file mode 100644
index 000000000000..e84a2177b423
--- /dev/null
+++ b/deskutils/openproj/pkg-plist
@@ -0,0 +1,27 @@
+%%DATADIR%%/lib/openproj-contrib.jar
+%%DATADIR%%/lib/openproj-exchange.jar
+%%DATADIR%%/lib/openproj-reports.jar
+%%DATADIR%%/lib/openproj-script.jar
+%%DATADIR%%/license/index.html
+%%DATADIR%%/license/third-party/Apache-LICENSE-2.0.txt
+%%DATADIR%%/license/third-party/CDDL.txt
+%%DATADIR%%/license/third-party/Jasper-LGPL.txt
+%%DATADIR%%/license/third-party/antlr.txt
+%%DATADIR%%/license/third-party/bsd-generic.txt
+%%DATADIR%%/license/third-party/cpl-1.0.txt
+%%DATADIR%%/license/third-party/groovy.txt
+%%DATADIR%%/license/third-party/iCal4j.txt
+%%DATADIR%%/license/third-party/index.html
+%%DATADIR%%/license/third-party/jgoodies-forms.txt
+%%DATADIR%%/license/third-party/lgpl-2.1.txt
+%%DATADIR%%/license/third-party/sun-jwsdp.txt
+%%DATADIR%%/license/third-party/sun.txt
+%%DATADIR%%/license/third-party/third-party-licenses-with-build-libs.html
+%%DATADIR%%/license/third-party/xstream.txt
+%%DATADIR%%/openproj.jar
+%%DATADIR%%/readme.txt
+bin/openproj
+@dirrm %%DATADIR%%/license/third-party
+@dirrm %%DATADIR%%/license
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%