aboutsummaryrefslogtreecommitdiff
path: root/deskutils/orage
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-03-18 15:19:58 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-03-18 15:20:41 +0000
commitefd69100909b0896fd9cc9d294491c7c062132d6 (patch)
tree653ef18ef75e706443fa2071eab78b73b0eef812 /deskutils/orage
parent1938dcf6c16c887e960e17d7875c3e65360b9a2b (diff)
downloadports-efd69100909b0896fd9cc9d294491c7c062132d6.tar.gz
ports-efd69100909b0896fd9cc9d294491c7c062132d6.zip
deskutils/orage: Add back to ports tree
Resuscitate the orage port removed in r563574. A new version ported to GTK3 is now available. Changelog: https://gitlab.xfce.org/apps/orage/-/blob/master/NEWS
Diffstat (limited to 'deskutils/orage')
-rw-r--r--deskutils/orage/Makefile46
-rw-r--r--deskutils/orage/distinfo3
-rw-r--r--deskutils/orage/pkg-descr6
-rw-r--r--deskutils/orage/pkg-plist86
4 files changed, 141 insertions, 0 deletions
diff --git a/deskutils/orage/Makefile b/deskutils/orage/Makefile
new file mode 100644
index 000000000000..0b24b955826f
--- /dev/null
+++ b/deskutils/orage/Makefile
@@ -0,0 +1,46 @@
+# Created by: Matt Lancereau <matt@rimasec.net>
+
+PORTNAME= orage
+PORTVERSION= 4.16.0
+CATEGORIES= deskutils xfce
+MASTER_SITES= XFCE/apps
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Calendar application for the Xfce Desktop
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpopt.so:devel/popt \
+ libdbus-glib-1.so:devel/dbus-glib \
+ libdbus-1.so:devel/dbus \
+ libical.so:devel/libical \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
+
+USES= compiler:c++11-lang desktop-file-utils gettext gmake gnome \
+ libtool pkgconfig tar:bzip2 xfce xorg
+USE_GNOME= cairo gdkpixbuf2 gtk30 intltool
+USE_XFCE= panel
+USE_XORG= ice sm x11
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+CFLAGS+= -I${LOCALBASE}/include/libical
+CONFIGURE_ARGS= --enable-dbus
+
+PORTSCOUT= limitw:1,even
+
+OPTIONS_DEFINE= NLS NOTIFY
+OPTIONS_DEFAULT= NOTIFY
+OPTIONS_SUB= yes
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime
+
+NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
+NOTIFY_CONFIGURE_ENABLE=libnotify
+
+.include <bsd.port.mk>
diff --git a/deskutils/orage/distinfo b/deskutils/orage/distinfo
new file mode 100644
index 000000000000..4a03291d081c
--- /dev/null
+++ b/deskutils/orage/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1647543001
+SHA256 (xfce4/orage-4.16.0.tar.bz2) = 26111a3b6a2007c82f1e0a1e0591b774a0b132f3a7f1cde53d9be661b2f11700
+SIZE (xfce4/orage-4.16.0.tar.bz2) = 2054409
diff --git a/deskutils/orage/pkg-descr b/deskutils/orage/pkg-descr
new file mode 100644
index 000000000000..6460df32de74
--- /dev/null
+++ b/deskutils/orage/pkg-descr
@@ -0,0 +1,6 @@
+Orage provides an highly configurable calendar and supports alerts based
+on dates.
+It warns you with popup or audio alarm. As it is an application kind-of
+every day use it launches itself in the background as a daemon.
+
+WWW: https://git.xfce.org/apps/orage/about/
diff --git a/deskutils/orage/pkg-plist b/deskutils/orage/pkg-plist
new file mode 100644
index 000000000000..d189c18a286e
--- /dev/null
+++ b/deskutils/orage/pkg-plist
@@ -0,0 +1,86 @@
+bin/globaltime
+bin/orage
+lib/xfce4/panel/plugins/liborageclock.so
+share/applications/org.xfce.orage-settings.desktop
+share/applications/org.xfce.orage.desktop
+share/applications/org.xfce.orage.globaltime.desktop
+share/dbus-1/services/org.xfce.orage.service
+share/icons/hicolor/128x128/apps/org.xfce.orage.png
+share/icons/hicolor/160x160/apps/org.xfce.orage.xpm
+share/icons/hicolor/160x160/apps/org.xfce.orage_ice.xpm
+share/icons/hicolor/160x160/apps/org.xfce.orage_round.xpm
+share/icons/hicolor/160x160/apps/org.xfce.orage_sun.xpm
+share/icons/hicolor/16x16/apps/org.xfce.orage.png
+share/icons/hicolor/24x24/apps/org.xfce.orage.png
+share/icons/hicolor/32x32/apps/org.xfce.orage.png
+share/icons/hicolor/48x48/apps/org.xfce.orage.globaltime.png
+share/icons/hicolor/48x48/apps/org.xfce.orage.png
+share/icons/hicolor/64x64/apps/org.xfce.orage.png
+share/icons/hicolor/scalable/apps/org.xfce.orage.globaltime.svg
+share/icons/hicolor/scalable/apps/org.xfce.orage.svg
+%%NLS%%share/locale/am/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/be/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/da/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/de/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/el/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/en_AU/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/es/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/et/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/he/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/hy_AM/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/id/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/is/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/it/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/si/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/th/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/orage.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/orage.mo
+share/metainfo/org.xfce.orage.appdata.xml
+%%DATADIR%%/sounds/Boiling.wav
+%%DATADIR%%/sounds/KDE_Beep_Digital_1.ogg
+%%DATADIR%%/sounds/KDE_Beep_Digital_2.ogg
+%%DATADIR%%/sounds/Knock.wav
+%%DATADIR%%/sounds/Phone.wav
+%%DATADIR%%/sounds/Spo.wav
+%%DATADIR%%/sounds/Tear.wav
+%%DATADIR%%/sounds/Wall_c.wav
+share/xfce4/panel/plugins/org.xfce.orage.clock-plugin.desktop