aboutsummaryrefslogtreecommitdiff
path: root/deskutils/plan
diff options
context:
space:
mode:
authorDaniel Eischen <deischen@FreeBSD.org>2000-11-24 22:10:06 +0000
committerDaniel Eischen <deischen@FreeBSD.org>2000-11-24 22:10:06 +0000
commit5c6c4bd604296ae3fe654392f860f1256624011a (patch)
tree7315b4c1731ef83da6598a9006e7d384ff957631 /deskutils/plan
parenteeed0d0cf16c8c33e1a841ea09439649781489a1 (diff)
downloadports-5c6c4bd604296ae3fe654392f860f1256624011a.tar.gz
ports-5c6c4bd604296ae3fe654392f860f1256624011a.zip
Update to plan-1.8.4. Change my email address in MAINTAINER.
PR: 22001 Submitted by: Palle Girgensohn <girgen@partitur.se>
Notes
Notes: svn path=/head/; revision=35393
Diffstat (limited to 'deskutils/plan')
-rw-r--r--deskutils/plan/Makefile29
-rw-r--r--deskutils/plan/distinfo2
-rw-r--r--deskutils/plan/files/patch-ab99
-rw-r--r--deskutils/plan/pkg-plist8
4 files changed, 61 insertions, 77 deletions
diff --git a/deskutils/plan/Makefile b/deskutils/plan/Makefile
index e4bc0d7ba7dc..8abe873206c8 100644
--- a/deskutils/plan/Makefile
+++ b/deskutils/plan/Makefile
@@ -1,26 +1,47 @@
# New ports collection makefile for: plan
# Date created: 14 April 1996
-# Whom: Daniel Eischen <deischen@iworks.InterWorks.org>
+# Whom: Daniel Eischen <deischen@freebsd.org>
#
# $FreeBSD$
#
# Also update ports/japanese/plan/ (ja-plan) when this port is updated
PORTNAME= plan
-PORTVERSION= 1.8.2
+PORTVERSION= 1.8.4
CATEGORIES+= deskutils
MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
ftp://ftp.fu-berlin.de/pub/unix/graphics/plan/
MASTER_SITE_SUBDIR= applications
-MAINTAINER= deischen@iworks.InterWorks.org
+MAINTAINER= deischen@freebsd.org
USE_MOTIF= yes
-WRKSRC= ${WRKDIR}/plan-1.8.2/src
+WRKSRC= ${WRKDIR}/${PKGNAME}/src
ALL_TARGET= freebsd
MAN1= netplan.1 plan.1
MAN4= plan.4
+post-patch:
+ cd ${WRKSRC} && ${MV} config.h config.h.orig && ${SED} -e 's,%%PREFIX%%,$(PREFIX),' \
+ < config.h.orig > config.h
+do-install:
+ @${MKDIR} ${PREFIX}/share/plan ;\
+ ${MKDIR} ${PREFIX}/share/doc/plan/examples ;\
+ cd ${WRKSRC} ; ${INSTALL_PROGRAM} plan pland netplan notifier ${PREFIX}/bin ;\
+ ${INSTALL_SCRIPT} ../misc/Killpland ${PREFIX}/bin ;\
+ ${INSTALL_MAN} ../misc/netplan.1 ../misc/plan.1 ${MAN1PREFIX}/man/man1 ;\
+ ${INSTALL_MAN} ../misc/plan.4 ${MAN4PREFIX}/man/man4 ;\
+ ${INSTALL_DATA} ../misc/plan_cal.ps ../language/* ../misc/Mkdoc ../misc/Mkdoc.nawk \
+ ../misc/BlackWhite ../misc/Monochrome ../README \
+ ${PREFIX}/share/doc/plan ;\
+ cd ${WRKSRC}/../holiday ; ${INSTALL_DATA} \
+ holiday_australia holiday_austria holiday_bavarian holiday_belgium \
+ holiday_canada holiday_combi holiday_czech holiday_denmark holiday_dutch \
+ holiday_finnish holiday_french holiday_frswiss holiday_german holiday_greek \
+ holiday_hungary holiday_italy holiday_japan holiday_norway holiday_portugal \
+ holiday_quebec holiday_spain holiday_swedish holiday_uk holiday_us \
+ ${PREFIX}/share/doc/plan/examples
+
post-install:
@${MKDIR} ${PREFIX}/share/netplan.dir
diff --git a/deskutils/plan/distinfo b/deskutils/plan/distinfo
index 20a4f3a90019..f2ab5e424274 100644
--- a/deskutils/plan/distinfo
+++ b/deskutils/plan/distinfo
@@ -1 +1 @@
-MD5 (plan-1.8.2.tar.gz) = 7070567facebf8b1b5eeb38934fa4ad2
+MD5 (plan-1.8.4.tar.gz) = 85f793084fbb88c4bb128c1d835c6b30
diff --git a/deskutils/plan/files/patch-ab b/deskutils/plan/files/patch-ab
index d74cff7d2b8b..b24e667fc46c 100644
--- a/deskutils/plan/files/patch-ab
+++ b/deskutils/plan/files/patch-ab
@@ -1,15 +1,15 @@
---- Makefile.orig Wed Jul 7 13:24:27 1999
-+++ Makefile Thu Jul 8 23:19:14 1999
-@@ -7,16 +7,22 @@
- # DO NOT put blanks before and after "=", this is parsed and rewritten by the
- # configure script.
+--- Makefile.orig Thu Jul 27 05:37:12 2000
++++ Makefile Thu Jul 27 05:37:12 2000
+@@ -7,18 +7,26 @@
+ # path and the #, or you'll get compile errors. DO NOT put blanks before and
+ # after "=", this is parsed and rewritten by the configure script.
#
-+DOCBASE = $(PREFIX)/share/doc/plan
++DOCBASE=$(PREFIX)/share/doc/plan
+#
# # user-callable executable (plan)
-DIR=/usr/local/bin
+DIR=$(PREFIX)/bin
- # # auxiliary programs (pland, notifier, netplan)
+ # # auxiliary programs (pland, notifier, PS)
-LIB=/usr/local/lib
+LIB=$(PREFIX)/share
+# # Example holiday files
@@ -17,6 +17,11 @@
+# # doc files
+DOCS=$(DOCBASE)
# # help file (plan.help)
+-SBIN=/usr/local/lib
++HELP=$(DOCBASE)
++#
++SBIN=$(PREFIX)/bin
+ # # system programs (netplan)
-HELP=/usr/local/lib
+HELP=$(DOCBASE)
# # netplan expects netplan.dir/ here
@@ -28,7 +33,7 @@
# # formatted manpage (plan.[14])
CATMAN=/usr/catman/local/cat
# # subdirectory in home dir, or empty
-@@ -32,9 +38,9 @@
+@@ -34,9 +42,9 @@
# # standard Unix compiler generator
YACC=yacc
# # numerical user ID of <nobody> account
@@ -40,24 +45,25 @@
# # used by plan to pre-process holiday files,
# # plan will check if this file really exists
CPP_PATH='/lib/cpp -P -I$(HELP)'
-@@ -47,11 +53,15 @@
+@@ -49,11 +57,16 @@
# # uncomment this for Japanese version of plan
# # JAPAN requires X11R5 and a Japanese env.
- JAPANDEFS="-DJAPAN -DESCTOASCII=$(ESCTOJISLATIN) -DLENTOASCII=3 -DLOCALE_SJIS='ja_JP.SJIS' -DLOCALE_EUC='ja_JP.EUC'"
+ JAPANDEFS=-DJAPAN -DESCTOASCII=$(ESCTOJISLATIN) -DLENTOASCII=3 -DLOCALE_SJIS='ja_JP.SJIS' -DLOCALE_EUC='ja_JP.EUC'
+.if defined(JAPANESE)
-+JAPAN = -DJAPAN -DESCTOASCII=$(ESCTOJISLATIN) -DLENTOASCII=3 \
++JAPAN=-DJAPAN -DESCTOASCII=$(ESCTOJISLATIN) -DLENTOASCII=3 \
+ -DLOCALE_SJIS=\"ja_JP.SJIS\" -DLOCALE_EUC=\"ja_JP.EUC\"
-+.endif
++.else
JAPAN=
++.endif
# # default holiday locale
HOLIDAY=german
# # do NOT define -O2 on DEC OSF/1 machines!
-DEBUG=-O2
+DEBUG=${CFLAGS}
# # what to do without make arguments
- DEFTARGET=linux
+ DEFTARGET=help
#------------------------- end of configuration section ----------------------
-@@ -222,8 +232,10 @@
+@@ -226,8 +239,10 @@
BSDIG_L2= -L/usr/X11/lib -lc
NBSD_L1 = -L/usr/X11R6/lib -lXm -lXt -lX11
NBSD_L2 = -L/usr/X11R6/lib -lc
@@ -70,17 +76,17 @@
LINUX_L1= -L/usr/X11R6/lib -L/usr/lib/X11R6/lib -lSM -lXm -lXt -lX11 -lXpm -lc -lXext -lSM -lICE -lX11
LINUX_L2= -lc
SLINUX_L1= -L/usr/X11R6/lib -L/usr/lib/X11R6/lib -lSM /usr/X11R6/lib/libXm.a -lXt -lX11 /usr/X11R6/lib/libXpm.a -lc -lXext -lSM -lICE -lX11
-@@ -291,7 +303,8 @@
+@@ -295,7 +310,8 @@
@echo " make bsdi BSDI/386"
@echo " make bsdig BSDI/386 with gcc"
@echo " make netbsd NetBSD/i386 1.0A (maybe others too)"
- @echo " make freebsd FreeBSD 2.x"
-+ @echo " make freebsd FreeBSD 3.x"
++ @echo " make freebsd FreeBSD"
+ @echo " make openbsd OpenBSD 2.x"
@echo " make svr4 SVR4 Using gcc"
@echo " make news4 Sony NEWS-OS4.x"
@echo " make news4g Sony NEWS-OS4.x with gcc"
-@@ -421,6 +434,9 @@
+@@ -425,6 +441,9 @@
freebsd:
env CF="$(FBSD_C)" L1F="$(FBSD_L1)" L2F="$(FBSD_L2)" MYCC=${CC} make all
@@ -90,61 +96,12 @@
svr4:
env CF="$(SVR4_C)" L1F="$(SVR4_L1)" L2F="$(SVR4_L2)" MYCC=gcc make all
-@@ -533,7 +549,7 @@
- $(MYCC) $(OPT) $(CF) $(JAPAN) $(INCDIR) -c -DLIB=\"$(LIB)\" $<
+@@ -538,7 +557,7 @@
+ $(CCLINE) -c -DLIB=\"$(LIB)\" $<
holiday.o: holiday.c $(MAKEFILE)
-- $(MYCC) $(OPT) $(CF) $(JAPAN) $(INCDIR) -DCPP_PATH=\"$(CPP_PATH)\" -c -DLIB=\"$(LIB)\" $<
-+ $(MYCC) $(OPT) $(CF) $(JAPAN) $(INCDIR) -DCPP_PATH=\"$(CPP_PATH)\" -c -DLIB=\"$(DOCS)\" $<
+- $(CCLINE) -DCPP_PATH=\"$(CPP_PATH)\" -c -DLIB=\"$(LIB)\" $<
++ $(CCLINE) -DCPP_PATH=\"$(CPP_PATH)\" -c -DLIB=\"$(DOCS)\" $<
util.o: util.c $(MAKEFILE)
- $(MYCC) $(OPT) $(CF) $(JAPAN) $(INCDIR) -c -DPATH=\"$(LIB):$(DIR):$(HELP)\" $<
-@@ -564,31 +580,25 @@
-
- #---------------------------------------------------------------
- install:
-- cp plan $(DIR)
-- -rm -f $(DIR)/pland $(DIR)/notifier
-- cp pland notifier netplan ../misc/plan_cal.ps ../language/* $(LIB)
-- -(test x'$(JAPAN)' != x && cp ../misc/plan_calSJ.ps $(LIB)) || exit 0
-- cp ../language/plan.help $(HELP)
-- -strip $(DIR)/plan $(LIB)/pland $(LIB)/notifier $(LIB)/netplan
-- -chmod 755 $(DIR)/plan $(LIB)/pland $(LIB)/notifier $(LIB)/netplan
-- -chmod 644 $(HELP)/plan.help $(LIB)/plan_cal.ps $(LIB)/plan.lang.*
-- -(test x'$(JAPAN)' != x && chmod 644 $(LIB)/plan_calSJ.ps) || exit 0
-+ ${INSTALL} -d $(DOCBASE)
-+ ${INSTALL} -d $(EXAMPLES)
-+ ${BSD_INSTALL_PROGRAM} pland $(DIR)
-+ ${BSD_INSTALL_PROGRAM} notifier netplan plan $(DIR)
-+ ${BSD_INSTALL_SCRIPT} ../misc/Killpland $(DIR)
-+ ${BSD_INSTALL_MAN} ../language/plan.help ../misc/plan_cal.ps \
-+ ../misc/Monochrome ../misc/BlackWhite $(DOCS)
-+ ${BSD_INSTALL_SCRIPT} -c -m 755 ../misc/Mkdoc ../misc/Mkdoc.nawk $(DOCS)
-+ -test x$(JAPAN) != x && ${BSD_INSTALL_MAN} ../misc/plan_calSJ.ps $(DOCS)
-+
- -mkdir $(NETPLANDIR)/netplan.dir
- -chmod 700 $(NETPLANDIR)/netplan.dir
-- -(test -x `which nroff` && nroff -man ../misc/plan.1 >../misc/plan.1cat) || exit 0
-- -(test -x `which nroff` && nroff -man ../misc/plan.4 >../misc/plan.4cat) || exit 0
-- -(test -x `which nroff` && nroff -man ../misc/netplan.1 >../misc/netplan.1cat) || exit 0
-- -(test -d $(MAN)1 && cp ../misc/plan.1 $(MAN)1/plan) || exit 0
-- -(test -d $(MAN)4 && cp ../misc/plan.4 $(MAN)4/plan) || exit 0
-- -(test -d $(MAN)1 && cp ../misc/netplan.1 $(MAN)1/netplan) || exit 0
-- -(test -d $(CATMAN)1 && cp ../misc/plan.1cat $(CATMAN)1/plan) || exit 0
-- -(test -d $(CATMAN)4 && cp ../misc/plan.4cat $(CATMAN)4/plan) || exit 0
-- -(test -d $(CATMAN)1 && cp ../misc/netplan.1cat $(CATMAN)1/netplan) || exit 0
-- -(test -f ${HOME}/.holiday || cp ../holiday/holiday_$(HOLIDAY) ${HOME}/.holiday) || exit 0
-- -(test `uname` = IRIX -o `uname` = IRIX64 && mkdir $$HOME/.icons) || exit 0
-- -(test `uname` = IRIX -o `uname` = IRIX64 && cp ../misc/Plan.icon $$HOME/.icons/Plan.icon) || exit 0
-- @echo ""
-- @echo "use ../holiday/* as templates for your ~/.holiday file"
-+ -(test -d $(MAN)1 && cp ../misc/plan.1 $(MAN)1/) || exit 0
-+ -(test -d $(MAN)4 && cp ../misc/plan.4 $(MAN)4/) || exit 0
-+ -(test -d $(MAN)1 && cp ../misc/netplan.1 $(MAN)1/) || exit 0
-+ ${BSD_INSTALL_MAN} ../README $(DOCBASE)
-+ ${BSD_INSTALL_DATA} ../holiday/holiday_* $(EXAMPLES)
-+ ${ECHO} ""
-+ ${ECHO} "Use " $(EXAMPLES)"/holiday/* as templates for your ~/.holiday file"
-
- clean:
- -rm -f *.o
+ $(CCLINE) -c -DPATH=\"$(LIB):$(DIR):$(HELP)\" $<
diff --git a/deskutils/plan/pkg-plist b/deskutils/plan/pkg-plist
index cc867c03f5b1..cedde6d83e3f 100644
--- a/deskutils/plan/pkg-plist
+++ b/deskutils/plan/pkg-plist
@@ -20,6 +20,7 @@ share/doc/plan/examples/holiday_finnish
share/doc/plan/examples/holiday_french
share/doc/plan/examples/holiday_frswiss
share/doc/plan/examples/holiday_german
+share/doc/plan/examples/holiday_greek
share/doc/plan/examples/holiday_hungary
share/doc/plan/examples/holiday_italy
share/doc/plan/examples/holiday_japan
@@ -33,7 +34,12 @@ share/doc/plan/examples/holiday_us
share/doc/plan/BlackWhite
share/doc/plan/Monochrome
share/doc/plan/README
-@exec /bin/mkdir -p share/netplan.dir
+share/doc/plan/plan.lang.dutch
+share/doc/plan/plan.lang.english
+share/doc/plan/plan.lang.french
+share/doc/plan/plan.lang.german
+share/doc/plan/plan.lang.spanish
+@exec /bin/mkdir -p %D/share/netplan.dir
@dirrm share/netplan.dir
@dirrm share/doc/plan/examples
@dirrm share/doc/plan