aboutsummaryrefslogtreecommitdiff
path: root/deskutils/py-autokey
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-12-31 20:19:50 +0000
committerSteve Wills <swills@FreeBSD.org>2018-12-31 20:19:50 +0000
commit5861da04675773e991e95768bfaaccc5616613c4 (patch)
treed438952f9f98d580f536f17980726ce955ea1a66 /deskutils/py-autokey
parent913ff03a2a92f43b6256153a9eb87646b1952cfa (diff)
downloadports-5861da04675773e991e95768bfaaccc5616613c4.tar.gz
ports-5861da04675773e991e95768bfaaccc5616613c4.zip
deskutils/py-autokey: fix missing dependencies, cleanup
PR: 234533 Submitted by: Daniel Shafer <daniel@shafer.cc> (maintainer)
Notes
Notes: svn path=/head/; revision=488832
Diffstat (limited to 'deskutils/py-autokey')
-rw-r--r--deskutils/py-autokey/Makefile29
-rw-r--r--deskutils/py-autokey/distinfo2
2 files changed, 17 insertions, 14 deletions
diff --git a/deskutils/py-autokey/Makefile b/deskutils/py-autokey/Makefile
index ce5af1698dbf..ee4586f0372d 100644
--- a/deskutils/py-autokey/Makefile
+++ b/deskutils/py-autokey/Makefile
@@ -2,6 +2,7 @@
PORTNAME= autokey
DISTVERSION= 0.95.4
+PORTREVISION= 1
CATEGORIES= deskutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,8 +21,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyinotify>0:devel/py-pyinotify@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}xlib>0:x11-toolkits/py-xlib@${PY_FLAVOR}
-USES= python:3.5+ shebangfix
-USE_PYTHON= distutils
+USES= python:3.6+ shebangfix
+USE_PYTHON= distutils concurrent
NO_ARCH= yes
@@ -34,22 +35,24 @@ GTK3_RUN_DEPENDS= libappindicator>0:devel/libappindicator
GTK3_USES= gnome
GTK3_USE= GNOME=gtk30,gtksourceview3,pygobject3
-QT5_USES= pyqt:5 qt:5
-QT5_USE= PYQT=qscintilla2,sip,svg,xml
+QT5_USES= pyqt:5
+QT5_USE= PYQT=dbus,qscintilla2,sip,svg,xml
post-patch:
- ${REINPLACE_CMD} 's|share/man|man|g' ${WRKSRC}/setup.py
- # Remove dbus-python from reqs as its the wrong dep name, devs will fix next release.
- ${REINPLACE_CMD} "/install_requires=/s|'dbus-python', ||g" ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} 's|share/man|man|g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} "/install_requires=/s|'dbus-python', ||g" ${WRKSRC}/setup.py
# setup.py installs both gtk and qt files no matter what, need to clean that up.
post-install-GTK3-off:
- ${RM} ${STAGEDIR}${PREFIX}/share/applications/autokey-gtk.desktop
- ${RM} ${STAGEDIR}${PREFIX}/bin/autokey-gtk
- ${RM} ${STAGEDIR}${PREFIX}/man/man1/autokey-gtk.1
+ @${RM} ${STAGEDIR}${PREFIX}/share/applications/autokey-gtk.desktop
+ @${RM} ${STAGEDIR}${PREFIX}/bin/autokey-gtk
+ @${RM} ${STAGEDIR}${PREFIX}/man/man1/autokey-gtk.1
+ @${RM} -r ${STAGEDIR}${PYTHON_SITELIBDIR}${PORTNAME}/gtkui
+
post-install-QT5-off:
- ${RM} ${STAGEDIR}${PREFIX}/share/applications/autokey-qt.desktop
- ${RM} ${STAGEDIR}${PREFIX}/bin/autokey-qt
- ${RM} ${STAGEDIR}${PREFIX}/man/man1/autokey-qt.1
+ @${RM} ${STAGEDIR}${PREFIX}/share/applications/autokey-qt.desktop
+ @${RM} ${STAGEDIR}${PREFIX}/bin/autokey-qt
+ @${RM} ${STAGEDIR}${PREFIX}/man/man1/autokey-qt.1
+ @${RM} -r ${STAGEDIR}${PYTHON_SITELIBDIR}${PORTNAME}/gtkui
.include <bsd.port.mk>
diff --git a/deskutils/py-autokey/distinfo b/deskutils/py-autokey/distinfo
index 357c91962dff..4a22e17e17bd 100644
--- a/deskutils/py-autokey/distinfo
+++ b/deskutils/py-autokey/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1543643976
+TIMESTAMP = 1546268894
SHA256 (autokey-0.95.4.tar.gz) = 0e46d27727cd611ddf5a23a5a88924fc614662bd797db4fa177cabbe63448206
SIZE (autokey-0.95.4.tar.gz) = 263627