aboutsummaryrefslogtreecommitdiff
path: root/deskutils/py-bugwarrior
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-06-27 01:46:27 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-06-27 01:46:27 +0000
commit078ec8c3fd6d12e4f6a2a9a6afa8ab8cebd99f1d (patch)
treecabab3fafdd0ba3cbf2dae73ede97801deef6006 /deskutils/py-bugwarrior
parent118b68da5ed299e4b1360267a329b9cff9934e1d (diff)
downloadports-078ec8c3fd6d12e4f6a2a9a6afa8ab8cebd99f1d.tar.gz
ports-078ec8c3fd6d12e4f6a2a9a6afa8ab8cebd99f1d.zip
deskutils/py-bugwarrior: Update to 1.1.4
- Update to 1.1.4 - Add TEST_DEPENDS and regression-test target now that tests are included in the PyPI sdist [1] Thanks Ralph! - Patch setup.py to enable test command until PR #222 [2] is in release. Changes: https://github.com/ralphbean/bugwarrior/blob/1.1.4/CHANGELOG.rst [1] https://github.com/ralphbean/bugwarrior/pull/221 [2] https://github.com/ralphbean/bugwarrior/pull/222
Notes
Notes: svn path=/head/; revision=390687
Diffstat (limited to 'deskutils/py-bugwarrior')
-rw-r--r--deskutils/py-bugwarrior/Makefile8
-rw-r--r--deskutils/py-bugwarrior/distinfo4
-rw-r--r--deskutils/py-bugwarrior/files/patch-setup.py10
3 files changed, 19 insertions, 3 deletions
diff --git a/deskutils/py-bugwarrior/Makefile b/deskutils/py-bugwarrior/Makefile
index af898385f4ee..c4d8b7273292 100644
--- a/deskutils/py-bugwarrior/Makefile
+++ b/deskutils/py-bugwarrior/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bugwarrior
-PORTVERSION= 1.1.3
+PORTVERSION= 1.1.4
CATEGORIES= deskutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -28,8 +28,14 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twiggy>0:${PORTSDIR}/devel/py-twiggy \
${PYTHON_PKGNAMEPREFIX}lockfile>=0.9.1:${PORTSDIR}/devel/py-lockfile \
${PYTHON_PKGNAMEPREFIX}click>0:${PORTSDIR}/devel/py-click \
${PYTHON_PKGNAMEPREFIX}xdg>0:${PORTSDIR}/devel/py-xdg
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
USES= python:2
USE_PYTHON= autoplist concurrent distutils
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
.include <bsd.port.mk>
diff --git a/deskutils/py-bugwarrior/distinfo b/deskutils/py-bugwarrior/distinfo
index 805f81c1074c..850876cc99b9 100644
--- a/deskutils/py-bugwarrior/distinfo
+++ b/deskutils/py-bugwarrior/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bugwarrior-1.1.3.tar.gz) = a92d1785fc7975c8beb7e3426e839fb771d29c80b186670ea365ecffa0fcee64
-SIZE (bugwarrior-1.1.3.tar.gz) = 62439
+SHA256 (bugwarrior-1.1.4.tar.gz) = 6bb687d702b1a91cdd13f067928bcf3018f615954132697fcc287f4182dd2acf
+SIZE (bugwarrior-1.1.4.tar.gz) = 81566
diff --git a/deskutils/py-bugwarrior/files/patch-setup.py b/deskutils/py-bugwarrior/files/patch-setup.py
new file mode 100644
index 000000000000..3e8085265698
--- /dev/null
+++ b/deskutils/py-bugwarrior/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2015-02-25 17:30:21 UTC
++++ setup.py
+@@ -52,6 +52,7 @@ setup(name='bugwarrior',
+ "jira>=0.22",
+ "megaplan>=1.4",
+ ],
++ test_suite='nose.collector',
+ entry_points="""
+ [console_scripts]
+ bugwarrior-pull = bugwarrior:pull