aboutsummaryrefslogtreecommitdiff
path: root/deskutils/rubrica
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /deskutils/rubrica
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Notes
Notes: svn path=/head/; revision=280300
Diffstat (limited to 'deskutils/rubrica')
-rw-r--r--deskutils/rubrica/Makefile4
-rw-r--r--deskutils/rubrica/files/patch-src_app.c12
2 files changed, 14 insertions, 2 deletions
diff --git a/deskutils/rubrica/Makefile b/deskutils/rubrica/Makefile
index 7ba0b320e75e..7e08ef38d55a 100644
--- a/deskutils/rubrica/Makefile
+++ b/deskutils/rubrica/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rubrica
PORTVERSION= 2.0.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= deskutils gnome
MASTER_SITES= BERLIOS
DISTNAME= ${PORTNAME}2-${PORTVERSION}
@@ -18,7 +18,7 @@ COMMENT= An addressbook for the GNOME 2 desktop
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
USE_BZIP2= yes
diff --git a/deskutils/rubrica/files/patch-src_app.c b/deskutils/rubrica/files/patch-src_app.c
new file mode 100644
index 000000000000..f40a1a0c509f
--- /dev/null
+++ b/deskutils/rubrica/files/patch-src_app.c
@@ -0,0 +1,12 @@
+--- src/app.c.orig 2011-08-12 15:55:03.000000000 +0200
++++ src/app.c 2011-08-12 15:55:26.000000000 +0200
+@@ -1269,8 +1269,7 @@ rubrica_app_init(RubricaApp* self)
+ self->priv->cutted = NULL;
+ self->priv->notify = notify_notification_new("Rubrica Addressbook",
+ NULL,
+- "info",
+- NULL);
++ "info");
+ self->priv->show_card = TRUE;
+
+ g_object_set(self->priv->notebook, "homogeneous", FALSE, NULL);