aboutsummaryrefslogtreecommitdiff
path: root/deskutils/semantik
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2004-07-06 14:35:49 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2004-07-06 14:35:49 +0000
commit24dea8a53ba59ffa4efc2332ffda1b8ba752aca1 (patch)
tree66235cddc849bed3d5410826f095878d745d5d0b /deskutils/semantik
parent9c3292f5bdc997de8a8eca4703d914b795eead53 (diff)
downloadports-24dea8a53ba59ffa4efc2332ffda1b8ba752aca1.tar.gz
ports-24dea8a53ba59ffa4efc2332ffda1b8ba752aca1.zip
Add kdissert, a KDE mindmapping tool.
The goal of kdissert is to help to structure ideas and concepts by associating them into a tree. The tree is there to help to see how the ideas interact, and then to develop them further (add ramifications). An idea is represented by a shape which can be a text or a picture. The ideas can be connected, but there is a constraint : an idea cannot have more than one parent. A kdissert mind-map can be exported as a picture, or used to generate documents. Templates include pdflatex (article, book) and html file formats. WWW: http://freehackers.org/~tnagy/kdissert/index.html
Notes
Notes: svn path=/head/; revision=113067
Diffstat (limited to 'deskutils/semantik')
-rw-r--r--deskutils/semantik/Makefile26
-rw-r--r--deskutils/semantik/distinfo2
-rw-r--r--deskutils/semantik/pkg-descr13
-rw-r--r--deskutils/semantik/pkg-plist40
4 files changed, 81 insertions, 0 deletions
diff --git a/deskutils/semantik/Makefile b/deskutils/semantik/Makefile
new file mode 100644
index 000000000000..296b6fb74738
--- /dev/null
+++ b/deskutils/semantik/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: kdissert
+# Date created: 2004 06 July
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kdissert
+PORTVERSION= 0.2.4
+CATEGORIES= deskutils kde
+MASTER_SITES= http://freehackers.org/~tnagy/kdissert/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= KDE mindmapping tool
+
+USE_BZIP2= yes
+USE_KDELIBS_VER= 3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/-O2//g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/deskutils/semantik/distinfo b/deskutils/semantik/distinfo
new file mode 100644
index 000000000000..308651d733a9
--- /dev/null
+++ b/deskutils/semantik/distinfo
@@ -0,0 +1,2 @@
+MD5 (kdissert-0.2.4.tar.bz2) = add63402adc3475bcfc8362d4c5728a7
+SIZE (kdissert-0.2.4.tar.bz2) = 717047
diff --git a/deskutils/semantik/pkg-descr b/deskutils/semantik/pkg-descr
new file mode 100644
index 000000000000..b9e2b59a419c
--- /dev/null
+++ b/deskutils/semantik/pkg-descr
@@ -0,0 +1,13 @@
+The goal of kdissert is to help to structure ideas and concepts by
+associating them into a tree. The tree is there to help to see how the
+ideas interact, and then to develop them further (add ramifications).
+
+An idea is represented by a shape which can be a text or a picture. The
+ideas can be connected, but there is a constraint : an idea cannot have
+more than one parent.
+
+A kdissert mind-map can be exported as a picture, or used to generate
+documents. Templates include pdflatex (article, book) and html file
+formats.
+
+WWW: http://freehackers.org/~tnagy/kdissert/index.html
diff --git a/deskutils/semantik/pkg-plist b/deskutils/semantik/pkg-plist
new file mode 100644
index 000000000000..f980815370e7
--- /dev/null
+++ b/deskutils/semantik/pkg-plist
@@ -0,0 +1,40 @@
+bin/kdissert
+lib/libkdisshtmldoc.la
+lib/libkdisshtmldoc.so
+lib/libkdisspdflatexarticle.la
+lib/libkdisspdflatexarticle.so
+lib/libkdisspdflatexbook.la
+lib/libkdisspdflatexbook.so
+share/applications/kde/kdissert.desktop
+share/applnk/Utilities/kdissert.desktop
+share/apps/kdissert/kdissertui.rc
+share/apps/kdissert/pics/nopix.png
+share/apps/kdissert/templatedata/kdisshtmldoc.tar.gz
+share/apps/kdissert/templatedata/kdisspdflatexarticle.tar.gz
+share/apps/kdissert/templatedata/kdisspdflatexbook.tar.gz
+share/apps/kdissert/tips
+share/config.kcfg/kdissert.kcfg
+share/doc/HTML/en/kdissert/common
+share/doc/HTML/en/kdissert/index.cache.bz2
+share/doc/HTML/en/kdissert/index.docbook
+share/icons/crystalsvg/128x128/actions/kdissert_sort.png
+share/icons/crystalsvg/16x16/actions/kdissert_link.png
+share/icons/crystalsvg/16x16/actions/kdissert_point.png
+share/icons/crystalsvg/16x16/actions/kdissert_sort.png
+share/icons/crystalsvg/22x22/actions/kdissert_link.png
+share/icons/crystalsvg/22x22/actions/kdissert_point.png
+share/icons/crystalsvg/22x22/actions/kdissert_sort.png
+share/icons/crystalsvg/32x32/actions/kdissert_link.png
+share/icons/crystalsvg/32x32/actions/kdissert_point.png
+share/icons/crystalsvg/32x32/actions/kdissert_sort.png
+share/icons/crystalsvg/64x64/actions/kdissert_sort.png
+share/icons/hicolor/128x128/apps/kdissert.png
+share/icons/hicolor/16x16/apps/kdissert.png
+share/icons/hicolor/32x32/apps/kdissert.png
+share/icons/hicolor/64x64/apps/kdissert.png
+share/locale/de/LC_MESSAGES/kdissert.mo
+share/locale/fr/LC_MESSAGES/kdissert.mo
+share/locale/nl/LC_MESSAGES/kdissert.mo
+@dirrm share/apps/kdissert/templatedata
+@dirrm share/apps/kdissert/pics
+@dirrm share/apps/kdissert