aboutsummaryrefslogtreecommitdiff
path: root/deskutils/treeline/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-01-28 23:50:29 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-01-28 23:50:29 +0000
commitf90ced7dc862ceaf0c1f21d7e7a069838267553c (patch)
treee2aa7d94cb25a9712761dc00357282d8a9e1675e /deskutils/treeline/Makefile
parent54b76750e30ff3a5fcf616d7ce993de8f42c10c7 (diff)
downloadports-f90ced7dc862ceaf0c1f21d7e7a069838267553c.tar.gz
ports-f90ced7dc862ceaf0c1f21d7e7a069838267553c.zip
- Remove option for ispell spell checking, now deprecated [1]
- Add DOCS option to config menu - Revise DESKTOP_ENTRIES - Fix staging support, use install.py -b option to set STAGEDIR correctly, otherwise it leaks to compiled code and scripts Submitted by: bapt [1]
Notes
Notes: svn path=/head/; revision=341678
Diffstat (limited to 'deskutils/treeline/Makefile')
-rw-r--r--deskutils/treeline/Makefile31
1 files changed, 11 insertions, 20 deletions
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index e6e358c54213..7a626f8f1a7a 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -3,7 +3,7 @@
PORTNAME= treeline
PORTVERSION= 1.4.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/:treeline \
http://treeline.bellz.org/plugins/:plugins \
@@ -17,43 +17,34 @@ COMMENT= Structured information storage program
LICENSE= GPLv2
+BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:${PORTSDIR}/x11-toolkits/py-qt4-gui \
- ${PYTHON_PKGNAMEPREFIX}qt4-network>=0:${PORTSDIR}/net/py-qt4-network
+ ${PYTHON_PKGNAMEPREFIX}qt4-network>=0:${PORTSDIR}/net/py-qt4-network \
+ aspell:${PORTSDIR}/textproc/aspell
WRKSRC= ${WRKDIR}/TreeLine
USE_QT4= # empty
USE_PYTHON= 2
NO_BUILD= yes
-DESKTOP_ENTRIES= "TreeLine" "Structured information storage program" \
- "${DATADIR}/icons/tree/treeline.png" "treeline" \
- "Utility;" false
+DESKTOP_ENTRIES= "TreeLine" "" "${DATADIR}/icons/tree/treeline.png" \
+ "${PORTNAME}" "Utility;" false
-OPTIONS_DEFINE= HTTPLOAD
-OPTIONS_SINGLE= SPELLER
-OPTIONS_SINGLE_SPELLER= ASPELL ISPELL
-
-HTTPLOAD_DESC= httpLoad plugin
-SPELLER_DESC= Spell checking backend
-
-OPTIONS_DEFAULT= ASPELL
+OPTIONS_DEFINE= DOCS HTTPLOAD
OPTIONS_SUB= yes
-ASPELL_BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
-ASPELL_RUN_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+HTTPLOAD_DESC= httpLoad plugin
HTTPLOAD_DISTFILES= httpload2.py:plugins
-ISPELL_BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
-ISPELL_RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
.include <bsd.port.options.mk>
do-install:
- cd ${WRKSRC} && ${PYTHON_CMD} install.py -p ${STAGEDIR}${PREFIX} \
- -d ${STAGEDIR}${DOCSDIR} -i ${STAGEDIR}${DATADIR}/icons -x
+ (cd ${WRKSRC} && ${PYTHON_CMD} install.py -b ${STAGEDIR} -p ${PREFIX} \
+ -d ${DOCSDIR} -i ${DATADIR}/icons)
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/plugins
.if ${PORT_OPTIONS:MHTTPLOAD}
${INSTALL_DATA} ${DISTDIR}/httpload2.py \
- ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/plugins/
+ ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/plugins
.endif
.include <bsd.port.mk>