aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-generic-slider/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-03-22 08:26:45 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-03-22 08:26:45 +0000
commit47f51016930148e46f31a47c108043cf287651d5 (patch)
treed92b2d482dacc57802309bf7cf52636815624c68 /deskutils/xfce4-generic-slider/Makefile
parenta067889d03aa690c998315b3eae37edaed0a3216 (diff)
downloadports-47f51016930148e46f31a47c108043cf287651d5.tar.gz
ports-47f51016930148e46f31a47c108043cf287651d5.zip
Update to a newer snapshot from it's source. Move to the official github
mirror, since this allows to use the USE_GITHUB helper. Unfortunately this snapshot is not tagged so we have to use GH_TAGNAME. One big advantage is that this new version does not depend on the deprecated x11-toolkits/libxfce4gui component anymore. Since it's a in development plugin it does not provide a configure script but depends on devel/xfce4-dev-tools to generate the required parts. Move the two files from pkg-plist to PLIST_FILES. PR: 226821 Submitted by: madpilot
Notes
Notes: svn path=/head/; revision=465266
Diffstat (limited to 'deskutils/xfce4-generic-slider/Makefile')
-rw-r--r--deskutils/xfce4-generic-slider/Makefile46
1 files changed, 18 insertions, 28 deletions
diff --git a/deskutils/xfce4-generic-slider/Makefile b/deskutils/xfce4-generic-slider/Makefile
index a3821760e3fa..5264542909c1 100644
--- a/deskutils/xfce4-generic-slider/Makefile
+++ b/deskutils/xfce4-generic-slider/Makefile
@@ -2,43 +2,33 @@
# $FreeBSD$
PORTNAME= xfce4-generic-slider
-PORTVERSION= 0.0.20100827
-PORTREVISION= 7
+PORTVERSION= 0.0.20171223
CATEGORIES= deskutils
-MASTER_SITES= LOCAL/ehaupt/
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Slider plugin to adjust and/or monitor any numeric variable
LICENSE= GPLv3
+BUILD_DEPENDS= xdt-autogen:devel/xfce4-dev-tools
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gettext-runtime pkgconfig xfce
-USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
-USE_XFCE= libgui panel
-
-CFLAGS+= `pkg-config --cflags libxfce4panel-1.0 libxfcegui4-1.0`
-LDFLAGS+= `pkg-config --libs libxfce4panel-1.0 libxfcegui4-1.0`
-
-post-patch:
- @${REINPLACE_CMD} -e \
- "s|@PLUGINDIR@|${PREFIX}/lib/xfce4/xfce4/panel-plugins|" \
- ${WRKSRC}/generic-slider.desktop
-
-do-build:
- ${CC} ${CFLAGS} -c ${WRKSRC}/generic-slider.c \
- -o ${WRKSRC}/generic-slider.o
- ${CC} ${LDFLAGS} ${WRKSRC}/generic-slider.o \
- -o ${WRKSRC}/xfce4-generic-slider-plugin
-
-do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/xfce4/panel-plugins
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/xfce4/xfce4/panel-plugins
- ${INSTALL_DATA} ${WRKSRC}/generic-slider.desktop \
- ${STAGEDIR}${PREFIX}/share/xfce4/panel-plugins
- ${INSTALL_PROGRAM} ${WRKSRC}/xfce4-generic-slider-plugin \
- ${STAGEDIR}${PREFIX}/lib/xfce4/xfce4/panel-plugins
+USES= gettext gmake libtool pkgconfig xfce
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 intltool pango
+USE_XFCE= libmenu panel
+
+USE_GITHUB= yes
+GH_ACCOUNT= xfce-mirror
+GH_TAGNAME= d1fc31f
+
+PLIST_FILES= lib/xfce4/panel/plugins/libgeneric-slider.so \
+ share/xfce4/panel/plugins/generic-slider.desktop
+
+pre-configure:
+ (cd ${WRKSRC} && ./autogen.sh)
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/xfce4/panel/plugins/libgeneric-slider.so
.include <bsd.port.mk>