aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-notes-plugin
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
commit41ff4e536e680bc94d0949bc7708ddfe6f5646a7 (patch)
tree0b87a1825693d30844e1b681ab080746ab147896 /deskutils/xfce4-notes-plugin
parentec5f7eb8bb72b6cf44e7b35905514df560d5f22b (diff)
downloadports-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.tar.gz
ports-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.zip
Clenup xfce ports:
- Add missing dependencies - Remove unneeded patches - Regenerate and rename legacy patches - Add NLS option to ports providing such a knob, and missing the option - Add INSTALL_TARGET=install-strip where missing - Sort things - Remove unneeded += - Cosmetic changes to OPTION related variables to improve readability - Update WWW - Silence portlint warnings about variables order - Bump PORTREVISION where changing dependencies and/or adding install-strip
Notes
Notes: svn path=/head/; revision=490953
Diffstat (limited to 'deskutils/xfce4-notes-plugin')
-rw-r--r--deskutils/xfce4-notes-plugin/Makefile22
-rw-r--r--deskutils/xfce4-notes-plugin/pkg-descr2
-rw-r--r--deskutils/xfce4-notes-plugin/pkg-plist96
3 files changed, 66 insertions, 54 deletions
diff --git a/deskutils/xfce4-notes-plugin/Makefile b/deskutils/xfce4-notes-plugin/Makefile
index cfd01f79bcf8..00b805447c1d 100644
--- a/deskutils/xfce4-notes-plugin/Makefile
+++ b/deskutils/xfce4-notes-plugin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-notes-plugin
PORTVERSION= 1.8.1
+PORTREVISION= 1
CATEGORIES= deskutils xfce
MASTER_SITES= XFCE/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -12,14 +13,25 @@ COMMENT= Notes plugin for the Xfce panel
LICENSE= GPLv2
-LIB_DEPENDS= libunique-1.0.so:x11-toolkits/unique
+LIB_DEPENDS= libunique-1.0.so:x11-toolkits/unique \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libdbus-glib-1.so:devel/dbus-glib \
+ libdbus-1.so:devel/dbus
-GNU_CONFIGURE= yes
-USES= gettext gmake libtool pkgconfig xfce tar:bzip2
-USE_GNOME= glib20 gtk20 intltool intlhack
+USES= gettext-tools gmake gnome libtool pkgconfig tar:bzip2 xfce
+USE_GNOME= cairo glib20 gtk20 intlhack intltool
USE_XFCE= panel
+USE_XORG= ice sm x11
+
+GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_XORG= x11
INSTALL_TARGET= install-strip
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime
+
.include <bsd.port.mk>
diff --git a/deskutils/xfce4-notes-plugin/pkg-descr b/deskutils/xfce4-notes-plugin/pkg-descr
index b588de273267..4f788571ff61 100644
--- a/deskutils/xfce4-notes-plugin/pkg-descr
+++ b/deskutils/xfce4-notes-plugin/pkg-descr
@@ -2,4 +2,4 @@ The notes plugin provides a quick way to paste text, to write down a
list of things, to leave a note to a friend, or whatever is common to do
with Post-It's.
-WWW: http://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin
+WWW: https://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin
diff --git a/deskutils/xfce4-notes-plugin/pkg-plist b/deskutils/xfce4-notes-plugin/pkg-plist
index 389663f0c002..708f09ae3ec4 100644
--- a/deskutils/xfce4-notes-plugin/pkg-plist
+++ b/deskutils/xfce4-notes-plugin/pkg-plist
@@ -9,54 +9,54 @@ share/icons/hicolor/22x22/apps/xfce4-notes-plugin.png
share/icons/hicolor/24x24/apps/xfce4-notes-plugin.png
share/icons/hicolor/32x32/apps/xfce4-notes-plugin.png
share/icons/hicolor/scalable/apps/xfce4-notes-plugin.svg
-share/locale/ar/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ast/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/bg/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ca/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/cs/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/da/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/de/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/el/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/en_AU/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/en_GB/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/es/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/eu/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/fi/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/fr/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/gl/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/hr/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/hu/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/id/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/is/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/it/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ja/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/kk/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ko/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/lt/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/lv/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ms/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/nb/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/nl/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/oc/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/pl/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/pt/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/pt_BR/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ro/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ru/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/sk/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/sl/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/sq/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/sr/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/sv/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/th/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/tr/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ug/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/uk/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ur/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/ur_PK/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/vi/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/zh_CN/LC_MESSAGES/xfce4-notes-plugin.mo
-share/locale/zh_TW/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/en_AU/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/id/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/is/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/th/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-notes-plugin.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-notes-plugin.mo
%%DATADIR%%/gtk-2.0/gradient.png
%%DATADIR%%/gtk-2.0/notes.gtkrc
%%DATADIR%%/gtk-2.0/scrollbars/slider-horiz-active.png