aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-tumbler
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-01-14 21:25:40 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-01-14 21:25:40 +0000
commit6b4d9d6aca8f01a15dd643f377cfa09f48674677 (patch)
treec708f20ef8474638fc3abd96d90ab53cd42f2ece /deskutils/xfce4-tumbler
parentd176c05f58ac8491c22edd3ab33b4cffc5c4b4c4 (diff)
downloadports-6b4d9d6aca8f01a15dd643f377cfa09f48674677.tar.gz
ports-6b4d9d6aca8f01a15dd643f377cfa09f48674677.zip
- Update to 0.1.27
- Add new option, COVER (unset by default) for movies Now, message is displayed, because config file system controls plugins. Users can override default configuration. Approved by: rene, miwi (mentors, implicit)
Notes
Notes: svn path=/head/; revision=310402
Diffstat (limited to 'deskutils/xfce4-tumbler')
-rw-r--r--deskutils/xfce4-tumbler/Makefile66
-rw-r--r--deskutils/xfce4-tumbler/distinfo4
-rw-r--r--deskutils/xfce4-tumbler/files/patch-configure27
-rw-r--r--deskutils/xfce4-tumbler/files/patch-plugins__cover-thumbnailer__cover-thumbnailer.c15
-rw-r--r--deskutils/xfce4-tumbler/files/patch-tumblerd__tumbler.rc28
-rw-r--r--deskutils/xfce4-tumbler/files/pkg-message.in6
-rw-r--r--deskutils/xfce4-tumbler/pkg-plist5
7 files changed, 145 insertions, 6 deletions
diff --git a/deskutils/xfce4-tumbler/Makefile b/deskutils/xfce4-tumbler/Makefile
index 339384ee96e1..1d370c8b3b4b 100644
--- a/deskutils/xfce4-tumbler/Makefile
+++ b/deskutils/xfce4-tumbler/Makefile
@@ -1,8 +1,9 @@
+# Created by: Olivier Duchateau
# $FreeBSD$
#
PORTNAME= tumbler
-PORTVERSION= 0.1.26
+PORTVERSION= 0.1.27
CATEGORIES= deskutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/xfce/${PORTNAME}/${PORTVERSION:R}
@@ -13,7 +14,6 @@ MAINTAINER= xfce@FreeBSD.org
COMMENT= Thumbnail service for Xfce desktop
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
dbus-glib-1:${PORTSDIR}/devel/dbus-glib
USE_BZIP2= yes
@@ -27,11 +27,15 @@ USE_PKGCONFIG= build
CONFIGURE_ARGS= --enable-xdg-cache \
--disable-gtk-doc-html
-OPTIONS_DEFINE= DOCS NLS PIXBUF FONTS JPEG FFMPEG POPPLER GSTREAMER ODF RAW
+OPTIONS_DEFINE= DOCS NLS PIXBUF FONTS JPEG FFMPEG POPPLER \
+ GSTREAMER ODF RAW COVER
OPTIONS_DEFAULT= PIXBUF FONTS JPEG POPPLER GSTREAMER ODF
# GStreamer thumbnailer needs new 1.0 API
OPTIONS_EXCLUDE= GSTREAMER
FONTS_DESC= Fonts thumbnailer plugin
+COVER_DESC= Open Movie Database thumbnailer plugin
+
+SUB_FILES= pkg-message
.include <bsd.port.options.mk>
@@ -62,6 +66,13 @@ PLIST_SUB+= PIXBUF="@comment "
.endif
.if ${PORT_OPTIONS:MFONTS}
+# PIXBUF needs to be set
+.if ! ${PORT_OPTIONS:MPIXBUF}
+USE_GNOME+= gdkpixbuf2
+CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
+PLIST_SUB+= PIXBUF=""
+.endif
+LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
CONFIGURE_ARGS+=--enable-font-thumbnailer
PLIST_SUB+= FONTS=""
.else
@@ -70,6 +81,11 @@ PLIST_SUB+= FONTS="@comment "
.endif
.if ${PORT_OPTIONS:MJPEG}
+.if ! ${PORT_OPTIONS:MPIXBUF}
+USE_GNOME+= gdkpixbuf2
+CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
+PLIST_SUB+= PIXBUF=""
+.endif
LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
exif:${PORTSDIR}/graphics/exif
CONFIGURE_ARGS+=--enable-jpeg-thumbnailer
@@ -80,6 +96,11 @@ PLIST_SUB+= JPEG="@comment "
.endif
.if ${PORT_OPTIONS:MFFMPEG}
+.if ! ${PORT_OPTIONS:MPIXBUF}
+USE_GNOME+= gdkpixbuf2
+CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
+PLIST_SUB+= PIXBUF=""
+.endif
LIB_DEPENDS+= ffmpegthumbnailer:${PORTSDIR}/multimedia/ffmpegthumbnailer
CONFIGURE_ARGS+=--enable-ffmpeg-thumbnailer
PLIST_SUB+= FFMPEG=""
@@ -89,6 +110,11 @@ PLIST_SUB+= FFMPEG="@comment "
.endif
.if ${PORT_OPTIONS:MPOPPLER}
+.if ! ${PORT_OPTIONS:MPIXBUF}
+USE_GNOME+= gdkpixbuf2
+CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
+PLIST_SUB+= PIXBUF=""
+.endif
LIB_DEPENDS+= poppler-glib:${PORTSDIR}/graphics/poppler-glib
CONFIGURE_ARGS+=--enable-poppler-thumbnailer
PLIST_SUB+= POPPLER=""
@@ -98,6 +124,11 @@ PLIST_SUB+= POPPLER="@comment "
.endif
.if ${PORT_OPTIONS:MGSTREAMER}
+.if ! ${PORT_OPTIONS:MPIXBUF}
+USE_GNOME+= gdkpixbuf2
+CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
+PLIST_SUB+= PIXBUF=""
+.endif
USE_GSTREAMER= yes
CONFIGURE_ARGS+=--enable-gstreamer-thumbnailer
PLIST_SUB+= GSTREAMER=""
@@ -107,6 +138,11 @@ PLIST_SUB+= GSTREAMER="@comment "
.endif
.if ${PORT_OPTIONS:MODF}
+.if ! ${PORT_OPTIONS:MPIXBUF}
+USE_GNOME+= gdkpixbuf2
+CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
+PLIST_SUB+= PIXBUF=""
+.endif
USE_GNOME+= libgsf
CONFIGURE_ARGS+=--enable-odf-thumbnailer
PLIST_SUB+= ODF=""
@@ -116,6 +152,11 @@ PLIST_SUB+= ODF="@comment "
.endif
.if ${PORT_OPTIONS:MRAW}
+.if ! ${PORT_OPTIONS:MPIXBUF}
+USE_GNOME+= gdkpixbuf2
+CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
+PLIST_SUB+= PIXBUF=""
+.endif
LIB_DEPENDS+= openraw:${PORTSDIR}/graphics/libopenraw
CONFIGURE_ARGS+=--enable-raw-thumbnailer
PLIST_SUB+= RAW=""
@@ -124,9 +165,28 @@ CONFIGURE_ARGS+=--disable-raw-thumbnailer
PLIST_SUB+= RAW="@comment "
.endif
+.if ${PORT_OPTIONS:MCOVER}
+.if ! ${PORT_OPTIONS:MPIXBUF}
+USE_GNOME+= gdkpixbuf2
+CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+PLIST_SUB+= PIXBUF=""
+.endif
+CONFIGURE_ARGS+=--enable-cover-thumbnailer
+PLIST_SUB+= COVER=""
+.else
+CONFIGURE_ARGS+=--disable-cover-thumbnailer
+PLIST_SUB+= COVER="@comment "
+.endif
+
post-patch:
.if empty(PORT_OPTIONS:MNLS)
@${REINPLACE_CMD} -e 's| po||' ${WRKSRC}/Makefile.in
.endif
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
.include <bsd.port.mk>
diff --git a/deskutils/xfce4-tumbler/distinfo b/deskutils/xfce4-tumbler/distinfo
index 4ec603c17f9a..362f127665d5 100644
--- a/deskutils/xfce4-tumbler/distinfo
+++ b/deskutils/xfce4-tumbler/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/tumbler-0.1.26.tar.bz2) = 6602ce700160d09edd88ea0b9bcb16abbc28974f372e646709e0ed8fbacc8a78
-SIZE (xfce4/tumbler-0.1.26.tar.bz2) = 482470
+SHA256 (xfce4/tumbler-0.1.27.tar.bz2) = 4c60b3b92877257fcc54d18acbbe4ad73c84a7ff7608a430ad5a05b452923869
+SIZE (xfce4/tumbler-0.1.27.tar.bz2) = 504996
diff --git a/deskutils/xfce4-tumbler/files/patch-configure b/deskutils/xfce4-tumbler/files/patch-configure
new file mode 100644
index 000000000000..07f4f0640a7e
--- /dev/null
+++ b/deskutils/xfce4-tumbler/files/patch-configure
@@ -0,0 +1,27 @@
+--- ./configure.orig 2013-01-12 11:14:34.000000000 +0000
++++ ./configure 2013-01-12 18:25:40.000000000 +0000
+@@ -915,9 +915,10 @@
+ enable_gtk_doc
+ enable_gtk_doc_html
+ enable_gtk_doc_pdf
+-enable_pixbuf_thumbnailer
++enable_cover_thumbnailer
+ enable_font_thumbnailer
+ enable_jpeg_thumbnailer
++enable_pixbuf_thumbnailer
+ enable_ffmpeg_thumbnailer
+ enable_gstreamer_thumbnailer
+ enable_odf_thumbnailer
+@@ -15618,9 +15619,9 @@
+ fi
+
+
+-# Check whether --enable-pixbuf-thumbnailer was given.
+-if test "${enable_pixbuf_thumbnailer+set}" = set; then :
+- enableval=$enable_pixbuf_thumbnailer; ac_tumbler_cover_thumbnailer=$enableval
++# Check whether --enable-cover-thumbnailer was given.
++if test "${enable_cover_thumbnailer+set}" = set; then :
++ enableval=$enable_cover_thumbnailer; ac_tumbler_cover_thumbnailer=$enableval
+ else
+ ac_tumbler_cover_thumbnailer=yes
+ fi
diff --git a/deskutils/xfce4-tumbler/files/patch-plugins__cover-thumbnailer__cover-thumbnailer.c b/deskutils/xfce4-tumbler/files/patch-plugins__cover-thumbnailer__cover-thumbnailer.c
new file mode 100644
index 000000000000..8387e29598ae
--- /dev/null
+++ b/deskutils/xfce4-tumbler/files/patch-plugins__cover-thumbnailer__cover-thumbnailer.c
@@ -0,0 +1,15 @@
+--- ./plugins/cover-thumbnailer/cover-thumbnailer.c.orig 2013-01-12 11:14:28.000000000 +0000
++++ ./plugins/cover-thumbnailer/cover-thumbnailer.c 2013-01-12 22:37:33.000000000 +0000
+@@ -274,7 +274,12 @@
+ curl_handle = curl_easy_init ();
+ curl_multi_add_handle (cover->curl_multi, curl_handle);
+ /* curl_easy_setopt (curl_handle, CURLOPT_VERBOSE, TRUE); */
++
++ /* CURLOPT_TCP_KEEPALIVE appears from 7.25.0 */
++#if LIBCURL_VERSION_MINOR >= 25
+ curl_easy_setopt (curl_handle, CURLOPT_TCP_KEEPALIVE, TRUE);
++#endif
++
+ curl_easy_setopt (curl_handle, CURLOPT_URL, url);
+ curl_easy_setopt (curl_handle, CURLOPT_USERAGENT, PACKAGE_NAME "/" PACKAGE_VERSION);
+
diff --git a/deskutils/xfce4-tumbler/files/patch-tumblerd__tumbler.rc b/deskutils/xfce4-tumbler/files/patch-tumblerd__tumbler.rc
new file mode 100644
index 000000000000..6f182e75be82
--- /dev/null
+++ b/deskutils/xfce4-tumbler/files/patch-tumblerd__tumbler.rc
@@ -0,0 +1,28 @@
+--- ./tumblerd/tumbler.rc.orig 2013-01-12 11:14:28.000000000 +0000
++++ ./tumblerd/tumbler.rc 2013-01-12 22:12:40.000000000 +0000
+@@ -37,7 +37,7 @@
+
+ # RAW image files using libopenraw
+ [RawThumbnailer]
+-Disabled=false
++Disabled=true
+ Priority=1
+ Locations=
+ MaxFileSize=0
+@@ -58,14 +58,14 @@
+
+ # ffmpegthumbnailer plugin
+ [FfmegThumbnailer]
+-Disabled=false
++Disabled=true
+ Priority=2
+ Locations=
+ MaxFileSize=0
+
+ # GStreamer plugin
+ [GstThumbnailer]
+-Disabled=false
++Disabled=true
+ Priority=1
+ Locations=
+ MaxFileSize=0
diff --git a/deskutils/xfce4-tumbler/files/pkg-message.in b/deskutils/xfce4-tumbler/files/pkg-message.in
new file mode 100644
index 000000000000..6e2424ee2314
--- /dev/null
+++ b/deskutils/xfce4-tumbler/files/pkg-message.in
@@ -0,0 +1,6 @@
+To override the default configuration, you must copy the rc-file:
+
+ mkdir ~/.config/tumbler
+ cp %%PREFIX%%/etc/xdg/tumbler/tumbler.rc ~/.config/tumbler
+
+For more information see http://docs.xfce.org/xfce/thunar/tumbler
diff --git a/deskutils/xfce4-tumbler/pkg-plist b/deskutils/xfce4-tumbler/pkg-plist
index 9cf55169ed29..38544deba504 100644
--- a/deskutils/xfce4-tumbler/pkg-plist
+++ b/deskutils/xfce4-tumbler/pkg-plist
@@ -1,3 +1,4 @@
+etc/xdg/tumbler/tumbler.rc
include/tumbler-1/tumbler/tumbler-abstract-thumbnailer.h
include/tumbler-1/tumbler/tumbler-cache-plugin.h
include/tumbler-1/tumbler/tumbler-cache.h
@@ -21,6 +22,8 @@ lib/libtumbler-1.so.0
lib/tumbler-1/plugins/cache/tumbler-cache-plugin.so
lib/tumbler-1/plugins/cache/tumbler-xdg-cache.la
lib/tumbler-1/plugins/cache/tumbler-xdg-cache.so
+%%COVER%%lib/tumbler-1/plugins/tumbler-cover-thumbnailer.la
+%%COVER%%lib/tumbler-1/plugins/tumbler-cover-thumbnailer.so
%%FFMPEG%%lib/tumbler-1/plugins/tumbler-ffmpeg-thumbnailer.la
%%FFMPEG%%lib/tumbler-1/plugins/tumbler-ffmpeg-thumbnailer.so
%%FONTS%%lib/tumbler-1/plugins/tumbler-font-thumbnailer.la
@@ -92,7 +95,6 @@ share/dbus-1/services/org.xfce.Tumbler.Thumbnailer1.service
%%NLS%%share/locale/ko/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/lt/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/lv/LC_MESSAGES/tumbler.mo
-%%NLS%%share/locale/ms/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/nb/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/nl/LC_MESSAGES/tumbler.mo
%%NLS%%share/locale/nn/LC_MESSAGES/tumbler.mo
@@ -130,3 +132,4 @@ share/dbus-1/services/org.xfce.Tumbler.Thumbnailer1.service
@dirrm lib/tumbler-1
@dirrm include/tumbler-1/tumbler
@dirrm include/tumbler-1
+@dirrm etc/xdg/tumbler