aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-tumbler
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-10-14 18:48:19 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-10-14 18:48:19 +0000
commit8026518389bceef9d08f5d9bb32197012a4be978 (patch)
tree092b7150099a416636cd3827e0cdf201c8f5515d /deskutils/xfce4-tumbler
parent501e0cfeb36ec783fcffd165d2f7fc2df90af7c1 (diff)
downloadports-8026518389bceef9d08f5d9bb32197012a4be978.tar.gz
ports-8026518389bceef9d08f5d9bb32197012a4be978.zip
- Support STAGEDIR
- Convert to new LIB_DEPENDS format - Switch to USES=gmake (deskutils/xfce4-tumbler) Approved by: ehaupt@ (maintainer of deskutils/xfce4-notifyd)
Notes
Notes: svn path=/head/; revision=330340
Diffstat (limited to 'deskutils/xfce4-tumbler')
-rw-r--r--deskutils/xfce4-tumbler/Makefile27
1 files changed, 10 insertions, 17 deletions
diff --git a/deskutils/xfce4-tumbler/Makefile b/deskutils/xfce4-tumbler/Makefile
index 753202c047d4..666b24031fc7 100644
--- a/deskutils/xfce4-tumbler/Makefile
+++ b/deskutils/xfce4-tumbler/Makefile
@@ -13,13 +13,12 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Thumbnail service for Xfce desktop
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gmake
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GNOME= glib20 intltool intlhack
USE_LDCONFIG= yes
USE_XFCE= configenv
@@ -36,7 +35,6 @@ GSTREAMER_DESC= GStreamer (1.0) thumbnailer plugin
SUB_FILES= pkg-message
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -72,7 +70,7 @@ USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
PLIST_SUB+= PIXBUF=""
.endif
-LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
CONFIGURE_ARGS+=--enable-font-thumbnailer
PLIST_SUB+= FONTS=""
.else
@@ -86,8 +84,8 @@ USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
PLIST_SUB+= PIXBUF=""
.endif
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
- exif:${PORTSDIR}/graphics/exif
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libexif.so:${PORTSDIR}/graphics/exif
CONFIGURE_ARGS+=--enable-jpeg-thumbnailer
PLIST_SUB+= JPEG=""
.else
@@ -101,7 +99,7 @@ USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
PLIST_SUB+= PIXBUF=""
.endif
-LIB_DEPENDS+= ffmpegthumbnailer:${PORTSDIR}/multimedia/ffmpegthumbnailer
+LIB_DEPENDS+= libffmpegthumbnailer.so:${PORTSDIR}/multimedia/ffmpegthumbnailer
CONFIGURE_ARGS+=--enable-ffmpeg-thumbnailer
PLIST_SUB+= FFMPEG=""
.else
@@ -115,7 +113,7 @@ USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
PLIST_SUB+= PIXBUF=""
.endif
-LIB_DEPENDS+= poppler-glib:${PORTSDIR}/graphics/poppler-glib
+LIB_DEPENDS+= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
CONFIGURE_ARGS+=--enable-poppler-thumbnailer
PLIST_SUB+= POPPLER=""
.else
@@ -157,7 +155,7 @@ USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
PLIST_SUB+= PIXBUF=""
.endif
-LIB_DEPENDS+= openraw:${PORTSDIR}/graphics/libopenraw
+LIB_DEPENDS+= libopenraw.so:${PORTSDIR}/graphics/libopenraw
CONFIGURE_ARGS+=--enable-raw-thumbnailer
PLIST_SUB+= RAW=""
.else
@@ -171,7 +169,7 @@ USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+=--enable-pixbuf-thumbnailer
PLIST_SUB+= PIXBUF=""
.endif
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--enable-cover-thumbnailer
PLIST_SUB+= COVER=""
.else
@@ -179,9 +177,4 @@ CONFIGURE_ARGS+=--disable-cover-thumbnailer
PLIST_SUB+= COVER="@comment "
.endif
-post-install:
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-
.include <bsd.port.mk>