aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xpostitPlus
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-08-31 02:12:31 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-08-31 02:12:31 +0000
commit61cb9d32317a4e87212cdba821a660c7748b478c (patch)
treed9ff198737a848cad0bdcb4a6f8d20052c019bc3 /deskutils/xpostitPlus
parentd28bceea22082ed7b0fd3755c5abc8ea3f091873 (diff)
downloadports-61cb9d32317a4e87212cdba821a660c7748b478c.tar.gz
ports-61cb9d32317a4e87212cdba821a660c7748b478c.zip
Make not fail when width or height = 0
Bump PORTREVISION PR: 23701 No Response: maintainer Submitted by: dgilbert@velocet.ca
Notes
Notes: svn path=/head/; revision=47193
Diffstat (limited to 'deskutils/xpostitPlus')
-rw-r--r--deskutils/xpostitPlus/Makefile1
-rw-r--r--deskutils/xpostitPlus/files/patch-notes.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/deskutils/xpostitPlus/Makefile b/deskutils/xpostitPlus/Makefile
index 34dcd72c3fde..c8abc748b16c 100644
--- a/deskutils/xpostitPlus/Makefile
+++ b/deskutils/xpostitPlus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XPostitPlus
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= office
diff --git a/deskutils/xpostitPlus/files/patch-notes.c b/deskutils/xpostitPlus/files/patch-notes.c
new file mode 100644
index 000000000000..63fd0e7d4c21
--- /dev/null
+++ b/deskutils/xpostitPlus/files/patch-notes.c
@@ -0,0 +1,20 @@
+*** note.c.orig Wed Dec 20 17:15:34 2000
+--- note.c Wed Dec 20 17:20:15 2000
+***************
+*** 359,364 ****
+--- 359,373 ----
+ }
+ }
+
++ /*
++ * The problem is that texth == 0 or textw == 0 causes an ungraceful exit.
++ * In this case, we set them all to a standard size.
++ */
++ if(texth == 0 || textw == 0)
++ {
++ texth = 169;
++ textw = 227;
++ }
+
+ /*
+ * Get the index number of this note.