aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-07 12:54:22 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-07 12:59:12 +0000
commit09f5a2edb26a7d6afd3b62a078a558a3c1786a29 (patch)
treed86598a26fa44b182d8e587dc84a18defbcfba7d /deskutils
parent158944b89e6532daf6e1c9d6b635694273a8685d (diff)
downloadports-09f5a2edb26a7d6afd3b62a078a558a3c1786a29.tar.gz
ports-09f5a2edb26a7d6afd3b62a078a558a3c1786a29.zip
*: (KDE PIM) Reduce dependencies
- Boost is a build-dep for all of these ports, using header-only libraries; there **are** library-uses of Boost in KDE PIM, just not here. - ECM is a build-dep that is not needed at runtime. - Qt testlib is a build-dep.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/kdepim-runtime/Makefile1
-rw-r--r--deskutils/libkdepim/Makefile8
2 files changed, 6 insertions, 3 deletions
diff --git a/deskutils/kdepim-runtime/Makefile b/deskutils/kdepim-runtime/Makefile
index 2ee4f76916e4..3002f66277c4 100644
--- a/deskutils/kdepim-runtime/Makefile
+++ b/deskutils/kdepim-runtime/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdepim-runtime
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/deskutils/libkdepim/Makefile b/deskutils/libkdepim/Makefile
index 0c1a8e72cb0e..9f0b271d91ea 100644
--- a/deskutils/libkdepim/Makefile
+++ b/deskutils/libkdepim/Makefile
@@ -1,5 +1,6 @@
PORTNAME= libkdepim
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -7,12 +8,13 @@ COMMENT= KDE PIM Libraries
LICENSE= LGPL21
-LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/range/algorithm.hpp:devel/boost-libs
USES= cmake gettext compiler:c++11-lib kde:5 qt:5 tar:xz
-USE_KDE= auth codecs completion config configwidgets coreaddons ecm \
+USE_KDE= auth codecs completion config configwidgets coreaddons \
i18n iconthemes itemmodels itemviews jobwidgets kcmutils \
- kio service wallet widgetsaddons
+ kio service wallet widgetsaddons \
+ ecm_build
# pim components
USE_KDE+= akonadi akonadicontacts akonadisearch contacts ldap mime
USE_QT= concurrent core dbus designer gui network testlib uiplugin uitools \