aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-04-24 12:58:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-04-24 12:58:02 +0000
commit1b81d1e1c83fe577a3b20de1c4a3edbb5cabd1bc (patch)
treee164a866ccecca209e23c94b5b7bc7ac50ec08d9 /deskutils
parentc906d75bf458abe979bcac81b647e487071a4857 (diff)
downloadports-1b81d1e1c83fe577a3b20de1c4a3edbb5cabd1bc.tar.gz
ports-1b81d1e1c83fe577a3b20de1c4a3edbb5cabd1bc.zip
- Fix shebangs
Submitted by: Jochen Neumeister (via irc)
Notes
Notes: svn path=/head/; revision=439287
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gcalcli/Makefile5
-rw-r--r--deskutils/rox-memo/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/deskutils/gcalcli/Makefile b/deskutils/gcalcli/Makefile
index 7ab233459a09..0ed15a2b43b4 100644
--- a/deskutils/gcalcli/Makefile
+++ b/deskutils/gcalcli/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gcalcli
PORTVERSION= 3.2
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils python
MAINTAINER= ports@thelanman.net
@@ -18,8 +18,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}httplib2>=0:www/py-httplib2 \
${PYTHON_PKGNAMEPREFIX}python-gflags>=0:devel/py-python-gflags
-USES= python:-2.7
+USES= python:-2.7 shebangfix
USE_GITHUB= yes
+SHEBANG_FILES= gcalcli
GH_ACCOUNT= insanum
diff --git a/deskutils/rox-memo/Makefile b/deskutils/rox-memo/Makefile
index 96bdad6468ae..815d4f6b111f 100644
--- a/deskutils/rox-memo/Makefile
+++ b/deskutils/rox-memo/Makefile
@@ -2,7 +2,7 @@
PORTNAME= rox-memo
PORTVERSION= 2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= SF/rox/Memo/${PORTVERSION}
DISTNAME= memo-${PORTVERSION}
@@ -13,7 +13,8 @@ COMMENT= Appointment/TODO management for the ROX desktop
RUN_DEPENDS= ${LOCALBASE}/bin/rox:x11-fm/rox-filer \
${LOCALBASE}/lib/ROX-Lib2/python/rox/__init__.py:devel/py-roxlib
-USES= python tar:bzip2
+USES= python shebangfix tar:bzip2
+SHEBANG_FILES= Memo/AppRun Memo/AppletRun
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}