aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-08-19 04:04:18 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-08-19 04:04:18 +0000
commit285fdd95a15212b7fc409a6ca17b0ade5a0f2cd4 (patch)
treee183f94a6e0a5316f2afdc5ae237bcde87e089bd /deskutils
parent54197fab232933dcd681a5730fb875d9c12ccbe6 (diff)
downloadports-285fdd95a15212b7fc409a6ca17b0ade5a0f2cd4.tar.gz
ports-285fdd95a15212b7fc409a6ca17b0ade5a0f2cd4.zip
Switchover to libtool14 to resolve no relink on install
issue elegant way. Approved by: marcus (mentor)
Notes
Notes: svn path=/head/; revision=87252
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/libmrproject/Makefile8
-rw-r--r--deskutils/libmrproject/files/libmrproject.sh16
-rw-r--r--deskutils/libmrproject/files/patch-configure21
-rw-r--r--deskutils/libmrproject/pkg-plist1
-rw-r--r--deskutils/mrproject/Makefile7
-rw-r--r--deskutils/mrproject/files/mrproject.sh16
-rw-r--r--deskutils/mrproject/files/patch-configure21
-rw-r--r--deskutils/mrproject/pkg-plist1
-rw-r--r--deskutils/planner/Makefile7
-rw-r--r--deskutils/planner/files/mrproject.sh16
-rw-r--r--deskutils/planner/files/patch-configure21
-rw-r--r--deskutils/planner/pkg-plist1
12 files changed, 40 insertions, 96 deletions
diff --git a/deskutils/libmrproject/Makefile b/deskutils/libmrproject/Makefile
index 27de1b709857..23cd2c139d1d 100644
--- a/deskutils/libmrproject/Makefile
+++ b/deskutils/libmrproject/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libmrproject
PORTVERSION= 0.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= deskutils gnome
MASTER_SITES= ftp://ftp.codefactory.se/pub/software/mrproject/source/
@@ -20,11 +20,9 @@ USE_GNOME= gnomeprefix gnomehack gnometarget libgsf
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 14
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-
-post-install:
- @${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/libmrproject.sh > ${PREFIX}/etc/rc.d/000.libmrproject.sh
- @${CHMOD} 750 ${PREFIX}/etc/rc.d/000.libmrproject.sh
+CONFIGURE_ARGS= --enable-static
.include <bsd.port.mk>
diff --git a/deskutils/libmrproject/files/libmrproject.sh b/deskutils/libmrproject/files/libmrproject.sh
deleted file mode 100644
index 42f654399d82..000000000000
--- a/deskutils/libmrproject/files/libmrproject.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-case "$1" in
- start)
- /sbin/ldconfig -m %%PREFIX%%/lib/mrproject/file-modules
- /sbin/ldconfig -m %%PREFIX%%/lib/mrproject/storage-modules
- ;;
- stop)
- ;;
- *)
- echo ""
- echo "Usage: `basename $0` { start | stop }"
- echo ""
- exit 64
- ;;
-esac
diff --git a/deskutils/libmrproject/files/patch-configure b/deskutils/libmrproject/files/patch-configure
index d46ada0ffe2d..ec9874cf8362 100644
--- a/deskutils/libmrproject/files/patch-configure
+++ b/deskutils/libmrproject/files/patch-configure
@@ -1,10 +1,11 @@
---- configure.orig Mon Feb 17 18:43:33 2003
-+++ configure Mon Feb 17 18:45:00 2003
-@@ -8260,6 +8260,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+--- configure.orig Tue Aug 19 12:23:20 2003
++++ configure Tue Aug 19 12:23:44 2003
+@@ -5171,7 +5171,7 @@
+ # All known linkers require a `.a' archive for static linking (except M$VC,
+ # which needs '.lib').
+ libext=a
+-ltmain="$ac_aux_dir/ltmain.sh"
++ltmain="/usr/local/share/libtool14/ltmain.sh"
+ ofile="$default_ofile"
+ with_gnu_ld="$lt_cv_prog_gnu_ld"
+ need_locks="$enable_libtool_lock"
diff --git a/deskutils/libmrproject/pkg-plist b/deskutils/libmrproject/pkg-plist
index 161c2776ef85..361379909a95 100644
--- a/deskutils/libmrproject/pkg-plist
+++ b/deskutils/libmrproject/pkg-plist
@@ -1,4 +1,3 @@
-etc/rc.d/000.libmrproject.sh
include/mrproject-1.0/mrproject/mrp-application.h
include/mrproject-1.0/mrproject/mrp-assignment.h
include/mrproject-1.0/mrproject/mrp-calendar.h
diff --git a/deskutils/mrproject/Makefile b/deskutils/mrproject/Makefile
index 37e2932f917c..97a78dfd3693 100644
--- a/deskutils/mrproject/Makefile
+++ b/deskutils/mrproject/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mrproject
PORTVERSION= 0.9.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils gnome
MASTER_SITES= ftp://ftp.codefactory.se/pub/software/mrproject/source/
@@ -21,11 +21,8 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui
USE_REINPLACE= yes
USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 14
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-post-install:
- @${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/mrproject.sh > ${PREFIX}/etc/rc.d/000.mrproject.sh
- @${CHMOD} 750 ${PREFIX}/etc/rc.d/000.mrproject.sh
-
.include <bsd.port.mk>
diff --git a/deskutils/mrproject/files/mrproject.sh b/deskutils/mrproject/files/mrproject.sh
deleted file mode 100644
index 82e41f4d7b06..000000000000
--- a/deskutils/mrproject/files/mrproject.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-case "$1" in
- start)
- /sbin/ldconfig -m %%PREFIX%%/lib/mrproject
- /sbin/ldconfig -m %%PREFIX%%/lib/mrproject/views
- ;;
- stop)
- ;;
- *)
- echo ""
- echo "Usage: `basename $0` { start | stop }"
- echo ""
- exit 64
- ;;
-esac
diff --git a/deskutils/mrproject/files/patch-configure b/deskutils/mrproject/files/patch-configure
index d46ada0ffe2d..adc4d1b44f8b 100644
--- a/deskutils/mrproject/files/patch-configure
+++ b/deskutils/mrproject/files/patch-configure
@@ -1,10 +1,11 @@
---- configure.orig Mon Feb 17 18:43:33 2003
-+++ configure Mon Feb 17 18:45:00 2003
-@@ -8260,6 +8260,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+--- configure.orig Tue Aug 19 12:17:22 2003
++++ configure Tue Aug 19 12:19:16 2003
+@@ -5168,7 +5168,7 @@
+ # All known linkers require a `.a' archive for static linking (except M$VC,
+ # which needs '.lib').
+ libext=a
+-ltmain="$ac_aux_dir/ltmain.sh"
++ltmain="/usr/local/share/libtool14/ltmain.sh"
+ ofile="$default_ofile"
+ with_gnu_ld="$lt_cv_prog_gnu_ld"
+ need_locks="$enable_libtool_lock"
diff --git a/deskutils/mrproject/pkg-plist b/deskutils/mrproject/pkg-plist
index 685ae571f19d..ca04460df56f 100644
--- a/deskutils/mrproject/pkg-plist
+++ b/deskutils/mrproject/pkg-plist
@@ -1,4 +1,3 @@
-etc/rc.d/000.mrproject.sh
bin/mrproject
lib/mrproject/libcalendardialog.so
lib/mrproject/libcellrenderers.so
diff --git a/deskutils/planner/Makefile b/deskutils/planner/Makefile
index 37e2932f917c..97a78dfd3693 100644
--- a/deskutils/planner/Makefile
+++ b/deskutils/planner/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mrproject
PORTVERSION= 0.9.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils gnome
MASTER_SITES= ftp://ftp.codefactory.se/pub/software/mrproject/source/
@@ -21,11 +21,8 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui
USE_REINPLACE= yes
USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 14
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-post-install:
- @${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/mrproject.sh > ${PREFIX}/etc/rc.d/000.mrproject.sh
- @${CHMOD} 750 ${PREFIX}/etc/rc.d/000.mrproject.sh
-
.include <bsd.port.mk>
diff --git a/deskutils/planner/files/mrproject.sh b/deskutils/planner/files/mrproject.sh
deleted file mode 100644
index 82e41f4d7b06..000000000000
--- a/deskutils/planner/files/mrproject.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-case "$1" in
- start)
- /sbin/ldconfig -m %%PREFIX%%/lib/mrproject
- /sbin/ldconfig -m %%PREFIX%%/lib/mrproject/views
- ;;
- stop)
- ;;
- *)
- echo ""
- echo "Usage: `basename $0` { start | stop }"
- echo ""
- exit 64
- ;;
-esac
diff --git a/deskutils/planner/files/patch-configure b/deskutils/planner/files/patch-configure
index d46ada0ffe2d..adc4d1b44f8b 100644
--- a/deskutils/planner/files/patch-configure
+++ b/deskutils/planner/files/patch-configure
@@ -1,10 +1,11 @@
---- configure.orig Mon Feb 17 18:43:33 2003
-+++ configure Mon Feb 17 18:45:00 2003
-@@ -8260,6 +8260,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+--- configure.orig Tue Aug 19 12:17:22 2003
++++ configure Tue Aug 19 12:19:16 2003
+@@ -5168,7 +5168,7 @@
+ # All known linkers require a `.a' archive for static linking (except M$VC,
+ # which needs '.lib').
+ libext=a
+-ltmain="$ac_aux_dir/ltmain.sh"
++ltmain="/usr/local/share/libtool14/ltmain.sh"
+ ofile="$default_ofile"
+ with_gnu_ld="$lt_cv_prog_gnu_ld"
+ need_locks="$enable_libtool_lock"
diff --git a/deskutils/planner/pkg-plist b/deskutils/planner/pkg-plist
index 685ae571f19d..ca04460df56f 100644
--- a/deskutils/planner/pkg-plist
+++ b/deskutils/planner/pkg-plist
@@ -1,4 +1,3 @@
-etc/rc.d/000.mrproject.sh
bin/mrproject
lib/mrproject/libcalendardialog.so
lib/mrproject/libcellrenderers.so