aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2020-06-26 17:34:05 +0000
committerAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2020-06-26 17:34:05 +0000
commit3aab7a6b1b30688e88dac8be1ab7786737c1ac44 (patch)
tree67f83eb9d95043c058903d1bc569919393921784 /deskutils
parent6a0cc49100282b0787b2fa28cf12fe05674d05f0 (diff)
downloadports-3aab7a6b1b30688e88dac8be1ab7786737c1ac44.tar.gz
ports-3aab7a6b1b30688e88dac8be1ab7786737c1ac44.zip
deskutils/py-vdirsyncer: Add compatibility with latest py-click.
- vdirsyncer was failing at runtime due to requering a outdated py-click version. PR: 247191 Reported by: Simeon Simeonov <sgs@pichove.org>
Notes
Notes: svn path=/head/; revision=540535
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/py-vdirsyncer/Makefile1
-rw-r--r--deskutils/py-vdirsyncer/files/patch-github_3eb9ce5.patch39
2 files changed, 40 insertions, 0 deletions
diff --git a/deskutils/py-vdirsyncer/Makefile b/deskutils/py-vdirsyncer/Makefile
index 8e288888e9f1..90f02cad2bd4 100644
--- a/deskutils/py-vdirsyncer/Makefile
+++ b/deskutils/py-vdirsyncer/Makefile
@@ -2,6 +2,7 @@
PORTNAME= vdirsyncer
DISTVERSION= 0.16.8
+PORTREVISION= 1
CATEGORIES= deskutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/deskutils/py-vdirsyncer/files/patch-github_3eb9ce5.patch b/deskutils/py-vdirsyncer/files/patch-github_3eb9ce5.patch
new file mode 100644
index 000000000000..6c68ce6f13f5
--- /dev/null
+++ b/deskutils/py-vdirsyncer/files/patch-github_3eb9ce5.patch
@@ -0,0 +1,39 @@
+From 3eb9ce5ae4320d52e6c876874511ff96a8a45f51 Mon Sep 17 00:00:00 2001
+From: Hugo Osvaldo Barrera <hugo@barrera.io>
+Date: Tue, 9 Jun 2020 14:45:02 +0200
+Subject: [PATCH] Add compatibility with latest click
+
+---
+ setup.py | 2 +-
+ tests/system/cli/test_sync.py | 5 ++++-
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 59549f16..d584b95d 100644
+--- setup.py
++++ setup.py
+@@ -11,7 +11,7 @@
+
+ requirements = [
+ # https://github.com/mitsuhiko/click/issues/200
+- 'click>=5.0,<6.0',
++ 'click>=5.0',
+ 'click-log>=0.3.0, <0.4.0',
+
+ # https://github.com/pimutils/vdirsyncer/issues/478
+diff --git a/tests/system/cli/test_sync.py b/tests/system/cli/test_sync.py
+index f2423764..43d35dd8 100644
+--- tests/system/cli/test_sync.py
++++ tests/system/cli/test_sync.py
+@@ -123,7 +123,10 @@ def test_verbosity(tmpdir, runner):
+ runner.write_with_general('')
+ result = runner.invoke(['--verbosity=HAHA', 'sync'])
+ assert result.exception
+- assert 'invalid value for "--verbosity"' in result.output.lower()
++ assert (
++ 'invalid value for "--verbosity"' in result.output.lower()
++ or "invalid value for '--verbosity'" in result.output.lower()
++ )
+
+
+ def test_collections_cache_invalidation(tmpdir, runner):