aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-06-03 17:55:46 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-06-03 17:55:46 +0000
commit8c42a4abcc8af65919606300f47cef6238b38249 (patch)
tree32c3e0cb29989a2b0b68461592e3a4e0b862b99f /deskutils
parentf39ef1eb204a34b21ed6a2c0d9548efa062f257e (diff)
downloadports-8c42a4abcc8af65919606300f47cef6238b38249.tar.gz
ports-8c42a4abcc8af65919606300f47cef6238b38249.zip
- Update to 1.0.2
- Fix build with custom LOCALBASE. PR: ports/135219 Submitted by: Lucas Holt <luke@justjournal.com> (maintainer)
Notes
Notes: svn path=/head/; revision=235131
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/jjclient/Makefile9
-rw-r--r--deskutils/jjclient/distinfo6
-rw-r--r--deskutils/jjclient/files/patch-Makefile14
3 files changed, 21 insertions, 8 deletions
diff --git a/deskutils/jjclient/Makefile b/deskutils/jjclient/Makefile
index 7a845931c4d0..cc846f1fb99e 100644
--- a/deskutils/jjclient/Makefile
+++ b/deskutils/jjclient/Makefile
@@ -6,18 +6,17 @@
#
PORTNAME= jjclient
-PORTVERSION= 1.0
+PORTVERSION= 1.0.2
CATEGORIES= deskutils
-MASTER_SITES= http://www.justjournal.com/software/unix/
-DISTNAME= ${PORTNAME}_1.0
+MASTER_SITES= SF \
+ http://www.justjournal.com/software/unix/
+MASTER_SITE_SUBDIR= justjournal
MAINTAINER= luke@justjournal.com
COMMENT= A command line client for posting JustJournal entries
LIB_DEPENDS+= xmlrpc.9:${PORTSDIR}/net/xmlrpc-c
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
PLIST_FILES= bin/jjclient
.include <bsd.port.mk>
diff --git a/deskutils/jjclient/distinfo b/deskutils/jjclient/distinfo
index 12283c061724..aee18735d0d6 100644
--- a/deskutils/jjclient/distinfo
+++ b/deskutils/jjclient/distinfo
@@ -1,3 +1,3 @@
-MD5 (jjclient_1.0.tar.gz) = 832a27f354fb56206fdc9c07ca129ab5
-SHA256 (jjclient_1.0.tar.gz) = 9771a31a57a252d889c98615dcc1610826145aff9a057a493348037220c2dd46
-SIZE (jjclient_1.0.tar.gz) = 2399
+MD5 (jjclient-1.0.2.tar.gz) = 198400ba67daf563e57abc8b16ae3723
+SHA256 (jjclient-1.0.2.tar.gz) = 88ee5b4a4083e26990cc8167c0c44c9495f9f489487fc552b728ae35c49e15b5
+SIZE (jjclient-1.0.2.tar.gz) = 4540
diff --git a/deskutils/jjclient/files/patch-Makefile b/deskutils/jjclient/files/patch-Makefile
new file mode 100644
index 000000000000..5f181a769118
--- /dev/null
+++ b/deskutils/jjclient/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig 2008-06-19 23:41:17.000000000 +0000
++++ Makefile 2009-06-03 16:48:58.000000000 +0000
+@@ -1,7 +1,7 @@
+-CC=gcc
+-CFLAGS= -I/usr/local/include -Wall -pedantic -std=c99
+-LDFLAGS= -L/usr/local/lib -lxmlrpc_client -lxmlrpc -lxmlrpc_xmlparse -lxmlrpc_xmltok -lxmlrpc_util -lcurl
+-PREFIX= /usr/local
++CC?=gcc
++CFLAGS= -I/usr/local/include -I${LOCALBASE}/include -Wall -pedantic -std=c99
++LDFLAGS= -L/usr/local/lib -L${LOCALBASE}/lib -lxmlrpc_client -lxmlrpc -lxmlrpc_xmlparse -lxmlrpc_xmltok -lxmlrpc_util -lcurl
++PREFIX?= /usr/local
+
+ all: clean jjclient
+