aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-01-23 15:45:58 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-01-23 15:45:58 +0000
commit8feb034d4c07a1dac14571b21e2b37177f9b584e (patch)
treeea6539de27acd787674fc916999a1fcc08ef207c /deskutils
parentb3f248cea361788bdbf03088920fe64ef57f9ba6 (diff)
downloadports-8feb034d4c07a1dac14571b21e2b37177f9b584e.tar.gz
ports-8feb034d4c07a1dac14571b21e2b37177f9b584e.zip
deskutils/freeplane: Use a relative symlink for the launcher script
PR: 225399 Requested by: danfe
Notes
Notes: svn path=/head/; revision=459780
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/freeplane/Makefile7
-rw-r--r--deskutils/freeplane/files/patch-freeplane.sh2
2 files changed, 4 insertions, 5 deletions
diff --git a/deskutils/freeplane/Makefile b/deskutils/freeplane/Makefile
index 0c606819ea71..3c4ce19f4202 100644
--- a/deskutils/freeplane/Makefile
+++ b/deskutils/freeplane/Makefile
@@ -3,6 +3,7 @@
PORTNAME= freeplane
PORTVERSION= 1.6.12
+PORTREVISION= 1
CATEGORIES= deskutils editors java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable
DISTNAME= ${PORTNAME}_bin-${PORTVERSION}
@@ -26,10 +27,8 @@ do-install:
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} \
"! ( -name freeplane\.sh* -or -name license\.txt -or -name *\.bat -or -name *\.exe )"
# Install freeplane.sh with the right permission, link to it to bin/
-# and let it resolve the path to DATADIR automatically to avoid
-# patching it further. For this to work it has to be a link to an
-# absolute path.
+# and let it resolve the path to DATADIR automatically.
${INSTALL_SCRIPT} ${WRKSRC}/freeplane.sh ${STAGEDIR}${DATADIR}
- ${LN} -s ${DATADIR}/freeplane.sh ${STAGEDIR}${PREFIX}/bin/freeplane
+ ${RLN} ${STAGEDIR}${DATADIR}/freeplane.sh ${STAGEDIR}${PREFIX}/bin/freeplane
.include <bsd.port.mk>
diff --git a/deskutils/freeplane/files/patch-freeplane.sh b/deskutils/freeplane/files/patch-freeplane.sh
index 1a59ee16e19b..481f3fed5aa8 100644
--- a/deskutils/freeplane/files/patch-freeplane.sh
+++ b/deskutils/freeplane/files/patch-freeplane.sh
@@ -11,7 +11,7 @@
# -m should be faster and link does always resolve, else this script
# wouldn't be called, would it?
- freefile=$(readlink -mn "$0")
-+ freefile=$(readlink -n "$0")
++ freefile=$(readlink -fn "$0")
_debug "Link '$0' resolved to '${freefile}'."
else
freefile="$0"